Wifi issues suse 13.2 (KDE) - Rookie in need of aid

Hi all,

First of all it might be best to state that I am somewhat of a rookie to Suse. I only have some ancient knowledge of Ubuntu (used it between 2007-2009) and after this I haven’t used any kind of Linux untill 3 months ago when I got a raspberry with Debian on it. And now I really want to get working more with Linux again and came across Suse. So, should anyone be able to help me with my problem (listed below) then please help in a dummie proof way. I would really appreciate it :).

When I open the network menu (on the bottom right) I get absolutely no SSID’s listed, and when I hover over the wifi emblem it says “Wireless Disabled”. (Clicking on it doesn’t do anything) Now after some research I did found out that people recommend using YaST to setup the network. Naturally I tried this and I failed at getting anything to work. The first problem already pops up when I open the Network Settings “Network is currently handled by NetworkManager or completely disabled. YaST is unable to configure some options” I got the impression this ain’t good, but have no clue on how to fix this.

When I go to the Global Options tab I got the option to choose between NetworkManager Service, Wicked Service and Network Services Disabled. I take it that the last option is not what I need so I haven’t looked into that.
When I used the first option NetworkManager service I can change absolutely nothing and have no idea what to do in here. I do however keep the wifi emblem in the menu on the bottom right.
If I choose Wicked Service I can change a few more things and even setup the wifi adapters that are listed in the overview tab, however even after doing this and saving it I still can’t connect to my wifi and the wifi option has disappeared from the network menu on the bottom right.

I also get the feeling that the answer should be fairly simple, however to me it is rocket science at the moment and could really use some help. I’ve listed some additional information below incase it would come in handy. Should any unformation be needed I will gladly provide it.

protection = MAC based, no password needed (MAC is already listed as approved in the router)
Laptop I’m using = Lenovo IdeaPad G50-30 80G000XDNX

  • Build in wifi adapter is a RTL8723be (Device name: wlp2s0)
  • USB drive wifi adapter is a RTL8192cu (Device name: wlp0s20u2)

First, you need to switch back to Network Manager instead of Wicked if you want to easily connect your WiFi to different locations as you travel around with your laptop.

Second, why are you using two wireless adapters?

Remove the USB adapter, at least until you have solved your basic connection problems.

Make certain you have the mechanical switch for your internal WiFi turned on.

On your tray, click on the Networking icon. A dialogue should pop up.

On the bottom left of that, there should be two checkmark boxes for Enable networking and Enable wireless.

Clear them both, if they are not clear.

Then, check Enable networking, and then Enable wireless.

Does your wireless router now show up in the list? (If not, do you have wireless turned on in the router? Check.)

At the bottom of the list of wireless (the right panel on the Network Manager dialogue), you should also see +Show More…, click that.

Do you now see what you are looking for?

If not, report back here with what you do see for the above steps.

I have had that happen to me.

It happened when I had previously booted Windows, and used the magic keys (FnF2) in windows to turn off Wireless.

So I rebooted to Windows, turned it on again, and then it worked in opensuse.

I later discovered the I could have simply used FnF2 in opensuse, and avoided all of the rebooting. But that depends on how the function keys are being mapped.

Please remove the USB device for now
And let us see the result of

/sbin/lspci -nnk | grep -iA2 net

At the moment I have 2 wireless adapters, I only listed the USB one incase it should come in handy, it isn’t connected at the moment. (It’s just a back-up.) There seems to be only 1 wifi key on my keyboard and this won’t do a single thing, I’ve pressed it multiple times and tried to connect to the wifi inbetween usages, but no result.
After making sure the network was on NetworkManager Services I took a look at the tray and could only find the network icon to the bottom right, once I opened this I couldn’t find the option you are reffering to. (See the screenshot below)


Could there be something I’m doing wrong??

I get the following when i try this.

linux-qqw0:~ # /sbin/lspci -nnk |grep -iA2 net
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
        Subsystem: Lenovo Device [17aa:b736]
        Kernel driver in use: rtl8723be
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
        Subsystem: Lenovo Device [17aa:3816]
        Kernel driver in use: r8169
linux-qqw0:~ # 

This shows that your wireless is turned off, so:

Also, see that wrench at the top right? More settings in there. What do you see when you click on that wrench?

There could be issues if you consider this

There’s also a power issue with this chip on Lenovos. As I don’t need bluetooth I solved this by disabling bluetooth in the BIOS settings, saves some millivolts for the wifi chip.

I’d wish it would be that easy. The checkbox is a little bit darker grey then the one for airplane mode and as a result the airplane mode checkbox works when I click it and the Wifi one doesn’t.
As for the other advises and links, I will take a look at this later this evening and report my findings.

I see from the comments by the others that there is most likely a problem with that WiFi card, so I would be following their hints.

I believe I’ve found my problem. The Wifi card doesn’t work at all. After installing Windows and installing the correct drivers the Wifi stil wasn’t available and working. Will send the notebook back (only 2 weeks old) and get a new one and hope that one works without problems.