Wifi Hard Blocked

Hello all!

When I got home today, I fired up my System76 laptop but I could not connect to the Internet. This was because my Wifi was down. a quick

rfkill list

Showed that the device was Hard Blocked. This means it is physically switched off. So I used the Fn+F11 key to turn it on again. No effect. I reset the BIOS to factory defaults, no effect. I booted into Ubuntu 12.04 (The newest official System76 supported Ubuntu Version) and tried Fn+F11, no effect. On a lark, I booted into OpenSUSE 31.1 Gnome, and the hard block was gone! I booted into my Tumbleweed and enabled the Wifi card from the Network Manager interface, and here I am. lol!

It seems to me that there is a kernel issue or a firmware issue. The kernel on Ubuntu 12.04 is 3.13, on OpenSUSE 13.1 it is 3.12. I am on 3.15. Does anyone have any idea what happened?

No idea
But before now I have had success by Power Off and Remove Battery. Try again.
But that was a few years back. No issues recently.
And I don’t use a System 76 Machine

But isn’t there a System 76 section @ubuntu-forum?

I tried to remove the Wifi but it had no effect. All is fine now, FWIW.

There is a System76 section on the Ubuntu Forums, but I am using an unsupported kernel and OS. :wink:

I suppose it would be better if I could change some settings in the BIOS, but there are no such settings there for Wireless.

Update–

To make sure I have wifi access, I purchased a small USB wifi dongle last week (Edimax EW-7811Un 150M 11n). It seemed to work fine, and I thought I had a work around if the Intel wifi went down again.

But today, I had no wireless connectivity AGAIN. Yes, even the USB wireless adapter was “off.” Since I suspected the kernel again, I booted into Ubuntu, but still no luck. I combed the web, and my problem seems pretty unique. So I unloaded the Intel wireless drivers with the rmmod command


rmmod iwldvm
rmmod iwlwifi

and VOILA! My USB wifi came right up and connected to my WAP!

At this point, I suspect that there is a hardware issue with the Intel card. Either that or a seriou sissue with he Intel drivers, which I do not think is very likely.

In such a situation are you working with a permanent blacklist for the Intel device, because IMO that would be necessary.

Yes, blacklisted the drivers.

You could just pull the wifi card from the machine

Did we ever see

/sbin/lspci -nnk

The device was shown when I typed in the command. The issue is, that due to the iwlwifi etc. drivers being loaded, ALL other wifi adapters were shown to be “off.”

Anyway, here is the output:

02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a] (rev 34)
        Subsystem: Intel Corporation Centrino Wireless-N 1030 BGN [8086:5305]
        Kernel modules: iwlwifi


I verified the driver is not loaded.

I think I don’t
And unless Google has found you any ideas, I’m not sure, and I still suggest you might consider pulling it…