Wifi hangs on "Waiting for Authorization"

Whenever I boot the laptop (its not mine, which makes administrating it harder) the wireless network refuses to connect. If I mouse over it, it says “Waiting for Authorization”, and then eventually times out and just sits there telling me I don’t have internet access. After that, if I try to look at the currently available wireless networks I see all the networks around me, except for the one I was just trying to connect to. If I restart the wireless (running service network restart, or clicking on the “enable wireless” or “enable networking” buttons) then the list of available wireless networks refreshes and I am able to connect to my wifi like normal, without having to enter a password.
I suspect that the problem with with kWallet, or something that was done to kWallet. When I first got the laptop every time you tried to connect to the wifi kWallet would pop up and ask for a password. I don’t use kWallet so I would closed it and tried to connect to the wifi without it. kWallet didn’t seem happy with this so it kept popping up asking for a password every time I tried to connect. Eventually I disabled kWallet using the button in the GUI, as well as in one of the config files. Now I am able to connect to the wifi normally, but only after I restating the wireless.
I actually removed kWallet in YaST but that hasn’t made a difference.
I’m out of ideas. Do any of y’all have any?
Some information about the laptop:
It is an Asus A73SD
Its running openSUSE 12.1 (x86_64)
The output of kde4-config -v is

Qt: 4.7.4
KDE Development Platform 4.7.2 (4.7.2) "release 5"
kde-config: 1.0

The output of running lspci | grep -i network is

03:00.0 Network controller: Ralink corp. RT5390 Wireless 802.11n 1T/1R PCIe

And last, the version of the “NetworkManager” package that shows up in YaST is but I just updated it to and still experience the same behavior. It is the plasmoid network manager.

IIRC there was a bug in the KDE NetworkManager regarding this.
You could try to upgrade your KDE to 4.9 (the latest version still available fro 12.1):

On the other hand, 12.1 is already out of support since over 2 months ago.
Maybe you should consider upgrading to 12.2 or 12.3?