Wifi don't work. The lshw command returns DISABLED

I am using the networkmanager
The wired connection works well
When I try use the wireless connection, no shows the networks WiFi names.
See the command “lshw” result:



positivo:/home/sergio # lshw -C network
  *-network DISABLED      
       description: Wireless interface
       product: RTL8188EE Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlan0
       version: 01
       serial: 74:c6:3b:28:13:8e
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8188ee driverversion=4.1.34-33-default firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:94 ioport:e000(size=256) memory:d0700000-d0703fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.1
       bus info: pci@0000:02:00.1
       logical name: eth0
       version: 12
       serial: 80:ee:73:bd:85:27
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8411-2_0.0.1 07/08/13 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:92 ioport:d000(size=256) memory:d0614000-d0614fff memory:d0610000-d0613fff
positivo:/home/sergio #                                                                      

Please, any ideas?
Thanks in advance

Show:

/sbin/lspci -nnk | grep -iA3 net
rfkill list all

Is the Firmware installed?

positivo:/home/sergio # /sbin/lspci -nnk | grep -iA3 net
01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)
        Subsystem: AzureWave Device [1a3b:1f38]
        Kernel driver in use: rtl8188ee
        Kernel modules: rtl8188ee
--
02:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 12)
        Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer Device [1297:2041]
        Kernel driver in use: r8169
        Kernel modules: r8169


positivo:/home/sergio # rfkill list all
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes

How do I know if Is the Firmware installed?

positivo:/home/sergio # rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

Enable it by a switch…

Please, where is this switch?

Am Sun, 23 Oct 2016 19:06:01 GMT
schrieb sergelli <sergelli@no-mx.forums.microfocus.com>:

> Please, where is this switch?
>
>

Well, just send me your machine with your preferred parcel service and I have a
look at it in order to tell you where the switch is.

(Sorry, could not resist)

AK


Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)

We’re not magicians. What is the model of the machine we’re dealing with here?

Oh … yeah … you can laugh at will, but here we are becoming sad.
But it’s better you happy than angry with me.
Sorry, my native language is not English.

We Translate “SWITCH” = “apparatus to connect or disconnect an electrical appliance”
So, I do not understand what you want information when talking about “switch”.

Deano_ferrari, about “What is the model of the machine we’re dealing with here?”
Please inform the command that lists the information that you need, and i post here.

Is this a desktop computer or a laptop,…? I was asking about the model (in case it was a laptop) so that we can search for the switch, button, or key combo that might be responsible for enabling/disabling an internal wifi device. When you leave out the details, all we can do is speculate.

This machine is a model “All in One”
This unit has no key to turn on or off the WiFi
The manual says nothing about key combination to turn on/off the wifi

Hi,

Most likely it is a laptop since it is blocked via hardware e.g.

**Hard blocked: yes**

Check the manual of your computer (if it has one) or check the website of the manufacturer/maker of that brand/model.

I only want to add that you can check the wifi state/status using nmcli which is included in package NetworkManager both for KDE and Gnome (afaik) one added bonus is that you don’t need to be root to run it.
You can check it with a simple grep from the output of rpm

rpm -ql NetworkManager | grep nmcli

The output should be something like.


/usr/bin/nmcli
/usr/share/bash-completion/completions/nmcli
/usr/share/man/man1/nmcli.1.gz
/usr/share/man/man5/nmcli-examples.5.gz

nmcli radio

Or to be more specific

nmcli radio wifi

use tab completion if you’re not sure which command/options are supported.

nmcli radio<TAB><TAB>
nmcli radio wifi<TAB><TAB>

Press the tab key twice.

You can also edit/create and connect/disconnect to both wired and wireless connection using nmcli just in case X server decided not to start for some reason.
But thats another story and topic :slight_smile:

Ok, check that the wifi device is not disabled in the BIOS perhaps.

Definitely this machine is not a laptop.
Here are the outputs of the “nmcli”


sergio@positivo:~> LANG=EN nmcli g
STATE      CONNECTIVITY  WIFI-HW   WIFI      WWAN-HW  WWAN     
connected  full          disabled  disabled  enabled  disabled 

sergio@positivo:~> LANG=EN nmcli r
WIFI-HW   WIFI      WWAN-HW  WWAN     
disabled  disabled  enabled  disabled 

sergio@positivo:~> LANG=EN nmcli d
DEVICE  TYPE      STATE        CONNECTION         
eth0    ethernet  connected    Wired connection 1 
wlan0   wifi      unavailable  --                 
lo      loopback  unmanaged    --                 

You think that “edit/create and connect/disconnect to both wired and wireless connection using nmcli” solves my problem?

Lord Deano_Ferrari.

You are a genius.

Yes. The problem was in the BIOS.
Although the setting does not speak directly about WiFi
I disabled in the BIOS items “LAN REMOTE BOOT” and “FAST BOOT”
When the OpenSuse ascended, the wired connection was turned off and the wireless worked.

Thank you, it seems that the case is solved

I’m just a regular user, the same as you, but glad to read of your success after checking/adjusting the BIOS settings.