wifi connection on openSUSE 11.0

System info:

  • Realtek 8187 (usb 802.11g)
  • Linux kernel
  • openSUSE 11.0 (with updates)

My wireless connection fails as follows:

  • after successfully associating and obtaining a dhcp lease, the access point can no longer be pinged.
  • if I iwconfig wlan0 essid <apname>, the ping will be successful for 7 or 8 pings before going back to ‘destination host unreachable’.

I have tried the following so far:

  • reinstall with default software load
  • reinstall with updates (i copied the update repository to a thumb drive from another system)
  • reconfigured wlan0 to associate to a friends wireless network
  • tried various network utilities (kismet, aircrack-ng). any utility not requiring a properly working network work fine.
  • it worked in 10.3 with the rtl8187 drivers from the update site and with injection patched drivers
  • i noticed the system currently uses mac80211 stack, instead of ieee80211 stack. (don’t know if this is a problem, but I would prefer the mac stack).
  • lsmod shows rtl8187, mac80211, cfg80211 loaded

Any help will be greatly appreciated!

– jolly

The ongoing struggle:

I wrote a perl script to keep my connection alive:

use strict;
use warnings;

while (1)
  print "reset wlan0
  `iwconfig wlan0 ap off`;
  sleep 6;

With this I have been able to update the system to the latest and greatest.

I started ‘iwevent’ to look for something to explain my problem, but when the connection drops, iwevent shows no information and I can’t find anything in the logs.

I tried downloading the latest mac80211 rtl8187 driver. It compiles without problems, but shows no improvement.

Anyone else having similar problems?