WiFi Connected but no internet

I just installed Tumbleweed with KDE and booted it up, to start with the wifi options weren’t showing at all, so I ran systemctl enable NetworkManager and rebooted to get that menu. Then I connected to the wifi, but there is no internet through it, apart from at occasional times, when there will be a spike for a second. The internet is working on my laptop running arch connected to the same network. I have tried ping google.com, but it says name or service not known, and Firefox can’t load web pages. This is running on a wifi card from an Asus motherboard.

Please offer facts and not (only) conclusions. Why do you think you have “no internet”. There must be something that brought you to coming to that conclusion. So please tell us.

And again the general way of checking things step by step:

You check from bottom to top:

  1. Is the NIC up with an IP address?
ip addr
  1. Can you connect to another system on your LAN?
ping -c1 <IP-address of your router>

(I hope you know that address)

  1. Do you have a default route to the Internet?
ip route
  1. Can you connect to a system on the internet?
ping -c1
  1. Can you resolve host/domain names?
ping -c1 forums.opensuse.org

Take care. As soon a one step fails, that must be resolved first. It is useless to go to the next step before it is resolved.

So start with 1. and do not hesitate to post the output here to get help on the interpretation.

Thanks for the reply, sorry about stating conclusions rather than facts, the wifi symbol in the bottom panel has an exclamation mark next to it, and when clicking on it it shows the network has 0B/s up and down. When using ping I got name or service not known, making me think my computer could not access the DNS. When opening firefox and when trying to use the update tool, both could not connect. This lead me to believe the internet was not working. I believe it is connected as when clicking on the wifi icon in the bottom panel it shows my wifi network name with connected written underneath it.

  1. This didn’t seem to show any errors, it gave one ip address and one

  2. I pinged my router and got bytes back

3.ip route gave the output

default via dev wlp5s0 proto dchp metric 206000 dev wlp5s0 proto kernel scope link src metric 600

4.Sending a ping to worked

5.Sadly sending a ping to forums.opensuse.org did not work

So from this I guess I can connect to the internet, but don’t have access to a DNS, sorry but I don’t know how to fix this

Exactly. You do have connection to the internet and thus your claim was not true.

Now there is bug around about DNS problems. Th fastest way to check if that is the culprit is:

netconfig -f update


rm /etc/resolve.conf 
rcnetwork restart

(or reboot if that is easier). All to be done as root.

I did the first, then checked if I could ping google.com, and couldn’t, so rebooted and tried again, with no success. I then tried the second, but /etc/resolve.conf did not exist, presumably due to me trying the first method. I then tried to ping again, to no success, then rebooted and pinged, again to no success

Can you ping

Sorry, that is my fault. It should be resolv.conf (without the e). :shame:

BTW, it is much better to simply copy/paste the prompt-command line, the output and the next prompt between CODE tags in your post. Then there is no need to do a lot of explanatory talking and we all see exactly what you saw.


boven:~ # rm /etc/resolve.conf
rm: cannot remove ‘/etc/resolve.conf’: No such file or directory
boven:~ # 

I managed to fix this by writing


to /etc/resolv.conf thanks to hcvv for all the help. Sorry, I’m new here, do I need to mark this as solved in some way?

That is indeed an alternative way to do it. You now have Google’s DNS server as server, while by removing and letting it re-created by DHCP, you would have got the one your DHCP server (router?) gives you. But living with the Google’s is certainly possible.

You saying that you are satisfied (as you did above) is enough to make it “solved”.

If you read the comments in the /etc/resolv.conf file, it will say that when you edit the file directly in this way, your entry will be effective only for as long as you don’t reboot or restart your network service. In other words, what you’ve done can only be a temporary fix, enough for you to know what the problem is but not a proper permanent fix.

Re-reading your post,
I don’t know that you’ve even set your networking to be managed by Network Manager, you need to do this in YaST > System > Network Settings > Global Options tab

By default, Network Manager is installed on all systems and on some Desktops you will see the Network Manager applet in the panel running across your screen, but Network Manager will be disabled. You have to enable in YaST before Network Manager can be activated to manage your network configurations.

Until you do so, you’d be using Wicked (ifup/ifdown) which can use only one network configuration which means that each time you connect to a different network, your old configuration will likely be lost.