WiFi configuration problem

I just installed OpenSUSE. The install went fine without any errors. In the device viewer I can see my wlan0 wireless device. It appears to be reported correctly as DWA-160 Xtreme N Dual Band USB Adapter (rev.B) [Ralink RT2870] from D-Link. It reports a hardware address and in response to Wireless? it says Yes.

In the YasST2 Control Center I see it listed in the Overview tab. I haven’t messed with all the different settings in the different tabs, but it is not working. I don’t recall where, but at some point it scanned for available networks and found mine. I provided my shared key and the device flashed as if it were at least trying to connect, but I got no message back saying connection successful or failed.

Can I get some help on getting this to work? Otherwise I am SOL b/c my router is in my attic and it would be a major pain to get a long ethernet cable down from there to my computer.

Please help?

As anyone can see, I posted this request for help almost two weeks ago. Over 100 people have viewed it, and I have gotten ZERO replies.

I left the Linux Mint community and uninstalled that because although there were very many very helpful people in the community, the Mint documentation is terrible. Even experienced users provided wildly varying “solutions,” and I had enormous problems getting networking to work with Windows based PCs and Macs as well as setting up servers.

I read that Open SUSE was the best for such networking, so I decided to try it.

Installations of Mint and Ubuntu have no problem at all recognizing my D-Link WiFi devices.

I was BAFFLED to see that Open SUSE can’t recognize them and apparently nobody really knows how to get it to do so - at least not within 100 + views and two weeks.

I’m collecting this information to post as a response to the completely inaccurate Mashable review and recommendations on Linux system distributions installs.

If anybody - maybe a board moderator - sees this, can you PLEASE find somebody who knows how to get this to work and reply to my post?

On 09/29/2013 10:06 AM, raysilva wrote:
>
> As anyone can see, I posted this request for help almost two weeks ago.
> Over 100 people have viewed it, and I have gotten ZERO replies.
>
> I left the Linux Mint community and uninstalled that because although
> there were very many very helpful people in the community, the Mint
> documentation is terrible. Even experienced users provided wildly
> varying “solutions,” and I had enormous problems getting networking to
> work with Windows based PCs and Macs as well as setting up servers.
>
> I read that Open SUSE was the best for such networking, so I decided to
> try it.
>
> Installations of Mint and Ubuntu have no problem at all recognizing my
> D-Link WiFi devices.
>
> I was BAFFLED to see that Open SUSE can’t recognize them and apparently
> nobody really knows how to get it to do so - at least not within 100 +
> views and two weeks.
>
> I’m collecting this information to post as a response to the completely
> inaccurate Mashable review and recommendations on Linux system
> distributions installs.
>
> If anybody - maybe a board moderator - sees this, can you PLEASE find
> somebody who knows how to get this to work and reply to my post?

I probably know how to help you, but I have gotten very tired of trying to help
people that post requests like yours, and I find it much better to read and
ignore them rather than get in trouble by posting the nasty, sarcastic responses
that they deserve. As you are blaming us for your shortcomings, I am making an
exception here.

Please read the stickies at the start of this forum and supply the information
requested. Note, there are two absolutely critical pieces of information missing
from your initial posting. You failed to specify the version of openSUSE that
you use. More than once, we have tried to help someone only to discover that
they were working with a version that was released 3 years ago.

The second piece of missing information is the USB ID for your device. The make
and model is useless, as the vendors frequently change the chip with little or
no change in the model name. The output of lsusb will be definitive.

The reason that other distros worked and openSUSE did not may be due to the
firmware package not being installed here, or perhaps their kernel is newer. The
rt2800usb driver, which is likely the one you need, has has a whole new class of
devices added in kernel 3.11.

raysilva wrote:
>
> As anyone can see, I posted this request for help almost two weeks ago.
> Over 100 people have viewed it, and I have gotten ZERO replies.
>
> I left the Linux Mint community and uninstalled that because although
> there were very many very helpful people in the community, the Mint
> documentation is terrible. Even experienced users provided wildly
> varying “solutions,” and I had enormous problems getting networking to
> work with Windows based PCs and Macs as well as setting up servers.
>
> I read that Open SUSE was the best for such networking, so I decided to
> try it.
>
> Installations of Mint and Ubuntu have no problem at all recognizing my
> D-Link WiFi devices.
>
> I was BAFFLED to see that Open SUSE can’t recognize them and apparently
> nobody really knows how to get it to do so - at least not within 100 +
> views and two weeks.
>
> I’m collecting this information to post as a response to the completely
> inaccurate Mashable review and recommendations on Linux system
> distributions installs.
>
> If anybody - maybe a board moderator - sees this, can you PLEASE find
> somebody who knows how to get this to work and reply to my post?
>
>

Try swicthing to Network Manager if you are using YaST current
YaST ==> Network Settings ==> Global Options ==> Swicth to “User
Controlled with Networkmanager”. After you do that you can configure
your network using NM icon which sits on your panel/taskbar

You probably did not get any replies because you did not mention:-

==> openSUSE version you are using ?
==> Desktop you are using (KDE,GNOME,LXDE,XFCE,E17) ?

You can also try and work with one of the stickies in the wireless forum
and report back any error you have.


GNOME 3.6.2
openSUSE Release 12.3 (Dartmouth) 64-bit
Kernel Linux 3.7.10-1.16-desktop

OK, thanks for at least replying. Please hold off on the nasty sarcasm you believe people deserve. I am not a newbie in the sense that I did many years ago work a lot with Unix. I know Windows and Mac OSes very well. I have spent the past year checking out the various colors of Linux available. As I mentioned in my initial post, Ubuntu has no problem recognizing my WiFi device (not at all a rare one). Mint had no trouble with that either. After reading reviews in lifehacker and elsewhere about just how great OpenSuse is working with Windows on a network, I thought I’d try it. Bang. Right off the bat, nothing but a ton of advice that is either completely wrong or so confused that it is impossible to follow. I installed version 12.3 64. Frankly, I don’t understand why anybody would install any old versions unless they were experts & were actually looking for an old version for a very specific reason; but, maybe that’w what has you frustrated.

The EHCI Host Controller on which my D-Link DWA 160 is connected shows Manufacturer as Llinux 3.7.10-1.1-desktop ehci_hcd. It reports USB version as 2.00 with the Product ID as 0x2. The DWA is revision B. The lsusb output on the device is “Bus 001 Device 005: ID 07d1:3c11 D-Link System DWA-160 Xtreme N Dual Band USB Adapter(rev.B) [Ralink RT2870]”

Sorry -

openSUSE version 12.3 (Dartmouth) (x86_64)
Desktop KDE 4.10.00 “release 1”

Try swicthing to Network Manager if you are using YaST current
YaST ==> Network Settings ==> Global Options ==> Swicth to “User
Controlled with Networkmanager”. After you do that you can configure
your network using NM icon which sits on your panel/taskbar

I did go to the Network Manager. The problem is that it shows nothing in the “Wireless” tab at all. It is grayed out. I can’t even run Yast anymore b/c since so much time has passed & frustration I forgot my root password. That’s it. I’m doing a complete clean re-installation now.

On 10/19/2013 12:56 PM, raysilva wrote:
>
> Try swicthing to Network Manager if you are using YaST current
> YaST ==> Network Settings ==> Global Options ==> Swicth to “User
> Controlled with Networkmanager”. After you do that you can configure
> your network using NM icon which sits on your panel/taskbar
>
> I did go to the Network Manager. The problem is that it shows nothing in
> the “Wireless” tab at all. It is grayed out. I can’t even run Yast
> anymore b/c since so much time has passed & frustration I forgot my root
> password. That’s it. I’m doing a complete clean re-installation now.

Are you blaming us for you forgetting your password? I hope not. BTW, the root
password is usually that of the first user created, i.e. the one that you
created at installation.

When you do the install, make sure the USB dongle is plugged in. That will cause
the installer to load the kernel-firmware package, which is likely the part you
were missing before.

I’m quite aware of that – don’t feed your paranoia. I know that I created it. I wrote it down. A couple of months have passed without any use of it at all. I just could not find where I wrote it down. I’m not as stupid as you think. No, I am NOT blaming you. HOLY COW!

I did a complete clean re-install, and yes, the USB dongle was plugged in at the time. And no, the installer did not recognize it. And respectfully you’re wrong. I did not miss that part before. Now, again respectfully, have you done any searching on the issue of Open SUSE not recognizing the D-Link DWA-160? Because this seems a known issue, but I have nobody who has actually solved it (or explained it in an understandable manner).

If it helps you, upon completion of the install, the dongle’s light is stuck in the on state (no flashing, as when it is searching for available networks). So, now, do you have any other suggestions or ideas?

On 10/19/2013 06:56 PM, raysilva wrote:

> If it helps you, upon completion of the install, the dongle’s light is
> stuck in the on state (no flashing, as when it is searching for
> available networks). So, now, do you have any other suggestions or
> ideas?

The state of the LED depends on the driver, and I have no idea what that one
should do.

The correct driver for your device is rt2800usb. The USB IDs for it were added
to that driver in 2011. Any kernel you are likely to run will have it installed.

The firmware file you need is /lib/firmware/rt2870.bin. Please check that it is
present. Missing firmware will prevent the driver from actually producing a
wireless device.

You also need to check if some device is killing the radio. That will also cause
NM to have wireless disabled. With a network connection, run the following:


sudo zypper install rfkill
/usr/sbin/rfkill list

If rfkill reports “yes” for any device, then post that output here.

I don’t know if you read my initial post. I have no way to do a wired connection; my router is in the attic and all my network connections are therefore wireless. How do you propose I download and install zypper if I can’t get my wireless to work?

I had already gotten the appropriate Linux driver from D-Link for the DWA-160. In the software notes it reads that it is compatible with SUSE Linux Enterprise (Suse10) Kernel_2.6.16.21-0.8-smp. I downloaded that onto a thumb drive from a Windows computer. The drive is recognized by the Suse machine. The Rt2x00Wiki says the latest driver is already part of the Linux kernel (but the project was only for b/g/i cards - I want to be able to use the n capacity on my dongle). While you mention Rt2800, I’m pretty sure it is actually Rt2870. Please confirm that you are CERTAIN, as I have already done some research. See here. Linux wireless LAN support http://linux-wless.passys.nl Mine is the revision B.

I tried to follow the instructions but got a bunch of command not found replies. Maybe you can understand it.

You’ll have to make the effort - it is your hardware. Maybe a visit to an internet cafe or library perhaps? Copy it to a memory stick if necessary.

software.opensuse.org:

I had already gotten the appropriate Linux driver from D-Link for the DWA-160. In the software notes it reads that it is compatible with SUSE Linux Enterprise (Suse10) Kernel_2.6.16.21-0.8-smp. I downloaded that onto a thumb drive from a Windows computer. The drive is recognized by the Suse machine. The Rt2x00Wiki says the latest driver is already part of the Linux kernel (but the project was only for b/g/i cards - I want to be able to use the n capacity on my dongle). While you mention Rt2800, I’m pretty sure it is actually Rt2870. Please confirm that you are CERTAIN, as I have already done some research. See here. Linux wireless LAN support http://linux-wless.passys.nl Mine is the revision B.

I tried to follow the instructions but got a bunch of command not found replies. Maybe you can understand it.

Maybe you should tell us definitively about your wireless chipset. That is what is relevant.

lsusb

On 10/20/2013 05:06 PM, deano ferrari wrote:
> Maybe you should tell us definitively about your wireless chipset. That
> is what is relevant.

He already told us his USB ID. From that I determined that his device needs
driver rt2800usb.

Building the driver from the web site will need a whole lot more software than
getting the built-in one to work. You would need the kernel headers, the
compiler, make, and who knows what else. In addition, a driver that builds on
2.6.16 will need many, many fixes to build on kernel 3.7. I am not convinced
that you would have the necessary skills to do that. I am certain that I would
not want to do that, and I do kernel development work every day.

Is the firmware file I told you that you need available? You will need only ls
to check that. Once I know the answer to that, I will tell you what rpm’s you
will need to download offline and how to install them.

BTW, zypper is part of every recent openSUSE system. You will not need to
install it.

BTW, zypper is part of every recent openSUSE system. You will not need to
install it.

He may have meant the ‘rfkill’ package.

Just had another unpleasant bout trying to get Suse to handle wireless like a gentleman or lady, no success again. This time with Suse 12.3 64 bit. After wrestling with it for an hour or two I gave up and loaded Fedora 19 64 bit and this distro found my Edimax PCI instantly and off it went. The same was true for Ubuntu 13.10 as well as Mint 14. What the problem with Suse is I can’t begin to imagine. Suse just can’t seem to get this part of the install correct with any of its iterations over the years. I even tried a TP-Link dongle TL-WN422G, duh Suse doesn’t even see the hardware. I gotten it to work in the past, and when it works I love it but I don’t think I’ll ever bother with it again too **** much trouble. I assume the same problems occur with the TL-WN725n v2, just sayin…

Welcome new member. I can understand your frustration, when things don’t work out of the box as hoped - Are you
asking for help, or are you just venting?" BTW, the best chance of help comes if you start your own thread, with a suitably descriptive title to attract the attention of those that can help.

I am the thread originator. I am still looking for help. If I have sounded like “venting,” it is only out of frustration. I too have had no problem installing Ubuntu or Mint. They both identified my WiFi device without the slightest “hitch.” I had best performance out of Mint, but configuring it to recognize and access my network (that includes Windows computers) was a major pain with useful help from its forum. Then I read a review on I believe Mashable (or maybe it was LifeHacker) about how OpenSuse was really the best for the type of networking I wanted to do. I was excited about installing it and finding out just how Windows network friendly it was touted to be.

I have explained that my router is in my attic and I have for years been using my wireless network. Every solution suggested required that I download something which is not the least bit useful since I can’t connect until Suse recognizes my wireless device. It is not at all a rare device. I can connect to Internet on a Windows computer and download drivers for it, but the “instructions” to get the installation to work on Suse leave a lot to be desired. Even after many hours of many attempted “solutions,” I have not been able to get Suse to recognize my device.

I will wait patiently for some moderator to maybe look at this and deign to help me. Otherwise, honestly, OpenSuse is totally useless to me. Anyone can sift through my thread and see all the information about my install and device. Thanks.

I am not a moderator, and I certainly do not “enjoy” your attitude towards us
volunteers, but I will try to help.

First of all, when we ask you to download something, it is possible to locate
the appropriate rpm in the openSUSE repos, download that on some other
internet-connected computer, transport it to openSUSE, and install it with the
rpm command. None of the things here will be kernel dependent, which makes it
easier.

One of the problems we are fighting is that the installed version of 12.3 has
some networking problems. In the case of wired connections, a reboot fixed them.
I do not recall what the complications are for wireless. These were all fixed by
the initial updates, but that is impossible.

We can forget about installing a driver from source. There are too many packages
needed to even think about using the sneaker-net solution.

Does your system contain the file /lib/firmware/rt2870.bin? I asked you this
earlier, but I never saw an answer. If it does not, then you need to download
http://download.opensuse.org/distribution/12.3/repo/oss/suse/noarch/kernel-firmware-20130114git-1.2.1.noarch.rpm.
While you are downloading, also get file
http://download.opensuse.org/distribution/12.3/repo/oss/suse/x86_64/rfkill-0.4-16.1.1.x86_64.rpm.
Once you have those files on a USB stick, copy them to openSUSE and issue the
commands


sudo rpm -U kernel-firmware-20130114git-1.2.1.noarch.rpm
sudo rpm -i rfkill-0.4-16.1.1.x86_64.rpm
sudo /sbin/modprobe -rv rt2800usb
sudo /sbin/modprobe -v rt2800usb

You should now have the firmware available. Next, does the wifi device find your
access point? Run the commands


/usr/sbin/rfkill list
sudo /usr/sbin/iwlist scan

If the rfkill command shows “yes” for any of the lines, you will need to clear
that. Check if “sudo /usr/sbin/rfkill unblock all” clears any soft blocks. If
you have any hard blocks, that means a wifi switch is off.

Assuming that you know how to capture the output of commands into a file either
by copy and paste or redirection, post the output of those last two commands here.