wifi complete off after new LEAP install. And also from my windows os?

Hi i’m new in linux, i’m having the following problem now that a can’t find the solution in the internet .
i’m using a Asus vivo minipc with windows and open suse LEap 15, so when i installed opensuse for the second time NetworkManager did not help me anymore like when i did it for the first time and mess up my wifi so i tried many thinks but nothing work, i also delete the settings grom Wicked and after a did that my wifi died completely (ALSO IN THE WINDOWS PARTITION) that is i dont know what to do know i jsut want to know what may be the problem the wifi icon is gone its like wifi doesn’t exist in both os appart from wifi everything its ok i did not know that one setting can affect another operative sistem that has nohing to do with another , so please help and thanks.

Hi, welcome

Have the Fn keys, one should be for turning wifi on and off.

If rfkill is installed, check the wifi status with

/usr/sbin/rfkill list

This may be a well-known problem with Leap 15 installation; make sure your wifi is controlled by NetworkManager and then open a console, enter

su --

and then your root password. Then enter

rm /etc/resolv.conf
init 6

When the computer reboots, all should be fine.

I tried that and nothing happens , in hardware info my wifi and Bluetooth card are missing

Thanks for the tip but I tried that and the problem still there NetworkManager is on and when I go to wifi settings it says “No Wi-Fi adapter found make sure you have a wifi adapter plugged and turn on.” The same with Bluetooth

I assume no wifi hardware evident here?

/sbin/lspci -nnk

In that case they may be disabled at the hardware level. Check your BIOS settings perhaps.

Hi guys, today when I woke up I turn on my PC and openSUSE leap wifi appear again .now it’s working thanks guys I appreciate it

The total power cycle may have helped here. Thanks for the update.