WiFi challenge runing Suse 11.1 KDE i64

I guess this belongs in the laptop section and the 64bit section.

Please forgive the multiple post.

I am having a connection issue with OpenSuse 11.1 KDE i64 on my i64 Panasonic Toughbook.
It connects great at home, it sees and connects to my Apple Airport and even the neighbor’s Netgear open base across the street. HOWEVER! No matter what I install (Fedora, Kubuntu, Open SUSE, Saboyan, and whatever it will NOT connect to outside WiFi networks Like AT&T, at Starbucks, McDonalds or at any hotel or public WiFi AS LONG AS I RUN A 64 BIT VERSION.

When I install the 32 bit version we have connection, with BOTH Network Manager or Wicd. Install a 64 bit version and we are dead in the water. (NO CONNECTION!) Can’t get IP address even after it sees the connections!!

Obviously it has to be some type of driver issue for the Intel chipset??. (Wicd it tells me: “failed to get IP Address”)

I have been a SuSE Linux user since version 7, I want to stick with it, its GREAT! But this issue has be trying other distros, now I have to carry a MacBook and I have developed an inferiority complex.

Please help. What can I do?

I recently installed the Wicd version (1.6.1.1) at the Open Suse Linux Build site. I was running version 1.6.2.2 before and had the same results.

About my laptop:

Panasonic Toughbook CF-52

Running Open Suse 11.1 with a PRO/Wireless 4965AG or AGN (Kendron) Network ConnectionDHCP
Linux 2.6.27.29-0.1-default x86_64
openSUSE 11.1 (x86_64)
KDE:4.1.3 (KDE 4.1.3) “release 4.10.4”

Processor (CPU): Intel(R) Core™2 Duo CPU T7100 @ 1.80GHzSpeed:800.00 MhzCores:2

Total memory (RAM):3.9 GB
Free memory:2.8 GB (+ 451.9 MB Caches)Free swap:3.0 GB

I don’t care what I have to install (Network Manager or Wicd) as long as it works!

Thanks,

Your input will be greatly appreciated!

Riberto

This is how I get it working:

Yast - Network Devices - Networksettings
Disable ipV6
Set to use ifup instead of Networkmanager
reboot
Use WICD to connect.

On systems and laptops I’ve tried to fix WiFi this has worked so far.

Thanks so much for your reply!

There was something with the PRO/Wireless 4965 AG and the 64 bit software.
It would connect at home, provided I was within 9 feet of my base.
Yes, I could see other access points but NO CIGAR!
This happened with BOTH Network Manager and Wicd regardless of the i64 distro I would use.
It was simply beyond my current capabilities to keep looking for the solution AND I needed to use this Laptop on the road.

SO I did a clean install of the latest Suse 11.2 release and BINGO!
YES, I realize it still in the testing stage and I have found a couple of MINOR things not working as they should!
BUT I use this Laptop for video presentations, word processing, spreadsheets, e-mail and web browsing and it does that GREAT!
This version of Network Manager works GREAT! I pick-up and sometimes connect to points half way down the street. I know use access points from my car, while parked out in the parking lot of McDonalds, Starbucks and others.

My hat is off to the Open Source Community.
You have my vote and my support.

Thanks,

Rr

And the headline reads:

openSUSE 11.2 Milestone 8 Released

And if you look further under most annoying bugs:

Bug 537112 – Intel 4965 wireless is completely broken

I tell you, this noe thinks “Someone is out to get us!”
(seriously)
The same article says “it was working fine in the previous version just a few days ago”.
I know!!! I am running that version, it is connecting better than IT EVER HAS.
(I am in Miami, South Florida USA, I think I am connecting with hot spots in the next County, heck Georgia, The Bahamas, Cuba, Cancun. !!! I think I connected with the International Space Station on its last orbital passby!!! YES!!, I am that happy with it FINNALLY!!!

Why someone wanted to mess with it is beyond me.
Like some politician once said: “for WiFi users, Its the CONNECTION stupid!

This crazy 4965 user will keep using this beautiful, buggy, un-updatable (Milestone 7) version till the official 11.2 release has been out for a few months.

A big THANK YOU to the great guys working on this Open Suse release and the great bunch here for their valuable support.

I respectfully hope our moderators won’t get too mad for this slightly off topic post!

Thanks,

Rr