WiFi but no internet connection

I’ve been having a weird problem on my Tumbleweed install. This started happening a few weeks ago, and just today I made a USB stick with the most recent build so I could update everything, and my problem hasn’t gone away.

I’m able to connect to the wifi network and am assigned an IP address, but I can’t actually get an internet connection. I can ping my router and even access it’s GUI in the browser, but nothing else works. I’ve tried adding the Google nameservers to /etc/resolv.conf, but that didn’t resolve (heh) anything. Also, ethernet connections aren’t an option.

I have to copy this output by hand as I’m typing this on a different computer for obvious reasons, so if you can’t take my word for it that the output of “ip a” shows that I’ve been given an IP via dhcp, just let me know and I can copy the relevant bits.

lnx-jstanley: sudo route -n

Kernel IP routing table
Destination   Gateway            Genmask          Flags    Metric     Ref     Use     Iface             UG      600         0        0        wlp3s0       U        600         0        0        wlp3s0

lnx-jstanley: sudo iwconfig

lo                no wireless extensions
wlp3s0            IEEE 802.11   ESSID:"The Promised LAN"
                   MODE:Managed    FREQUENCY:5.2 GHz     Access Point: 60:E3:27:3A:03:A8
                   Bit Rate=6 Mb/s     Tx-Power=14 dBm
                   Retry short limit:7    RTS thr:off      Fragment thr:off
                   Encryption key:off
                   Power Management:off
                   Link Quality=43/70   Signal level=-67 dBm
                   Rx invalid nwid:0     Rx invalid crypt:0    Rx invalid frag:0
                   Tx excessive retries:0     Invalid misc:24     Missed beacon:0

enp0s25        no wireless extension

If you guys need any other output, just let me know.

Hi and welcome to the forum :slight_smile:
Try deleting the /etc/resolv.conf file and rebooting.

If you have no other option,
Use your phone and take a picture of your screen, upload it to the Cloud and then use the URL to that image in the embed image button when you create your Forum Post… Or, just post the hyperlink.

Post the results for

ip addr

You can test name resolution without making changes to your /etc/resolv.conf.

Run nslookup in a root console


You can test any FQDN or IP address(reverse lookup) by simply typing the FQDN, for instance


A successful result will return an IP address for the FQDN you entered. If it fails, then you can specify a different server by typing “server” followed by an IP address, for example the following which changes your DNS server name resolution to a Google server


After pointing to your new DNS server, you can repeat querying for a FQDN

Depending on the results of above, you can either focus your effort on configuring a working DNS or look elsewhere for a possible cause of your problems.


Having a connection to the Internet or not and having functioning name resolution (DNS) are two different things.

It seems that you have an IP address and a default router, thus in theory you must be able to connect systems on the internet. Check with


If that works OK, you have connection to the internet.

You could have an DNS problem. Tools like nslookup for testing this are explained above. Also a possible way to cure it is suggested.

Thanks for all the responses. hcvv was right in that I DO have an internet connection - as I am able to ping the Google nameservers - so it appears that I have DNS problems. This is a good first step. I deleted /etc/resolv.conf before doing anything else (per malcomlewis’ suggestion), so I was able to ping the Google ns and such after the fact.

There’s some output from ip addr and nslookup at the bottom. I have already tried adding the Google nameservers to /etc/resolv.conf, so what are the next steps in configuring a working DNS?

EDIT: I added the google NS back into /etc/resolv.conf and now everything works. I guess the combination of deleting, rebooting and re-adding did the trick. Thanks for helping me get here and teaching me some new troubleshooting steps!


So is the wifi access point your connecting to issuing out DNS (assuming DHCP), or is this a static ip address configured in Network Manager or wicked?

Okay, I spoke too soon about ALL my problems being resolved. It seems that when I connect to my work’s VPN, these (possibly still DNS?) issues come back. I do receive an IP on a new interface when I connect to the VPN, and gnome indicates that the connection was successful, but I’m unable to connect to or ping any of our servers.

RE malcomlewis: this is DHCP as far as my computer is concerned. I previously reserved an IP address for it in the router settings, but I disabled it when I was trying to fix these problems

Which wifi service provider do you use ?

This tip worked for me when I upgrade from Leap 42.3 to Leap 15. Now my internet is fine. You’re awesome.