WiFi always fails to start on boot

On my Laptop running Gnome Version 3.34.7 the WiFi never starts on the first boot. It seems impossible to switch it on using the ‘settings’, either from Gnome or via Yast. However, WiFi will always be activated on reboot. This means that I am forced to boot twice at every activation of the Laptop in order to have a working WiFi.

Is there any way to correct this behaviour?

First question is of course: are you using Wicked or NetworkManager?

Hardware details might be useful as well.

Thanks for your responses!!

I’m using the Network Manager.

inxi --network
  Device-1: Intel Centrino Wireless-N 135 driver: iwlwifi 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 

In which case the only thing you can do with YaST is setting it to NM.

…and it makes no difference whether the Network Manager or Wicked is used.

Good to know that you tried both.

Does this mean that

  1. your WIFI-card is deactivated after system start?
  2. a WIFI network connection - which you would expect to be set up automatically after system start - is not established automatically?

In case of 2.) it would be interesting to know what the associated NetworkManager connection file (from /etc/NetworkManager/system-connections) looks like.



Again, this is likely a hardware issue (not openSUSE specific). Hardware details?

If ‘inxi’ is installed, you can do

inxi -MNxx

and report back here with the output.

inxi -MNxx
  Type: Laptop System: Wortmann_AG product: TERRA_MOBILE_1512/1712 v: N/A 
  serial: <superuser/root required> Chassis: Clevo type: 10 
  serial: <superuser/root required> 
  Mobo: Clevo model: W2xxCZQ v: V3.0 serial: <superuser/root required> 
  BIOS: American Megatrends v: 4.6.5 date: 11/18/2013 
  Device-1: Intel Centrino Wireless-N 135 driver: iwlwifi v: kernel 
  port: f040 bus ID: 02:00.0 chip ID: 8086:0892 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: CLEVO/KAPOK 
  driver: r8169 v: kernel port: e000 bus ID: 03:00.2 chip ID: 10ec:8136 

Thanks for providing the hardware details.

Capture the following dmesg output following boot…

dmesg|egrep "iwlwifi|firmware" > out.txt

That might yield some further clues perhaps.

Does “wlan0” exist after booting from power up?

ip a

Or only after a reboot?

Output from dmesg|egrep “iwlwifi|firmware” > out.txt

    0.291143] Spectre V2 : Enabling Restricted Speculation for firmware calls
   13.518111] iwlwifi 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
   13.568731] iwlwifi 0000:02:00.0: loaded firmware version op_mode iwldvm
   13.834042] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUG enabled
   13.834045] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
   13.834046] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
   13.834048] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Wireless-N 135 BGN, REV=0x120
   26.425356] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x0
   26.520475] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x0
   26.644380] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x0
   26.750766] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x0
   59.940221] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x0
   60.044850] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x0

On the hint of an earlier post I checked the YaST Services Manager for the Network Manager settings. I have now ensured that the Network Manager, the Network Manager-dispatcher and the Network Manager-wait-online services are all set to start on boot up. Although that seemed not to work first time around, the behaviour is currently no longer evident. Can I say ‘Problem solved?’ Maybe:\

Maybe the wifi device just takes longer to power up than is typical.

…but then I should have been able to start wifi manually…but that seemed not possible…even after starting the services.

Well, NetworkManager-dispatcher.service and NetworkManager-wait-online.service certainly won’t make a difference here either. NetworkManager (or any other network management framework) can only work with the interfaces available (as per the kernel and device itself).

Well, I have no idea what NetworkManager-dispatcher.service and NetworkManager-wait-online.services are for. Just that after I activated both, it seemed to have made the difference. I’ll keep an eye on it.

If that were the case, then maybe there is a time-out value that can be set somewhere?

You already said manual connectivity fails as well though, (so that rules any delay-based solution out)?

I am still struggling with this issue, i.e. Laptop WiFi does not start on a laptop ‘cold’-start. The Login screen is reached and WiFi is off. Even after login, the wireless menu utility is unresponsive to any WiFi selections (Wireless on/off, WLAN selection). However, if I now press the Laptop power on/off button shortly, the system goes into (presumably) hibernation mode. Another press of the on/off button fetches it out of hibernation and (voila) WiFi is on.

It is difficult to believe that this behaviour is due to faulty hardware, as the Wifi functions properly with the above work-around . I can only think that the boot sequence was changed at the time I started this thread, and it hasn’t been corrected since. What information could I provide to show what is happening to settle the matter?

Please start a new thread on your issue with the OS in use prefix. You can always link back to this thread as a starting point.