Wierd Logon issue...


I work at a company that is 99.99% M$ WINDOWS. The .01% that is NOT beholden to M$ is ME! As half my time is spent in IT support I have some latitude in the software I run. I chose to install OpenSUSE 10.3 to make use of the gEDA tools. Naturally the company uses MS Server for Domain control et al. I have successfully added my OpenSUSE machine to the corporate domain. My issue is that when the machine starts the corporate domain is not an option in the Domain Login ‘drop-down’, nothing but ‘<LOCAL>’ is listed. However if I login as root and then logout the corporate domain then shows up in the drop down! This seems like a silly little issue but it annoys the bejesus out of me.

Anyone have a clue?

thanks in advance!

Robert M. Lombardi II
Sr. Electronics Engineering Technician

Azonix Corporation
900 Middlesex Tpke. - Bldg. 6
Billerica, MA 01821

direct: 978-313-3343
fax: 978-
mobile: 978-821-7495
email: rlombardi@azonix.com

Yes, i have had the same problem too.
It has to do with the fact that XDM is started before winbindd
The easiest way to get rid of this problem is to open a terminal as root and type

chkconfig earlyxdm off

You will now see that is takes a bit longer for the logon screen to appear but you will have the dropdown enabled immediately.