Widget settings

Each time I pass with a cursor over a widget on the desktop its side bar appears, of course it should because of resizing and moving or do some setting, but that is very boring if I do not intend to use that bar. Screenlets behave better, the setting menu appear only with proper clicking. Is there a way to manage jumping widget menu bar not to appear on every cursor passing ?

Right-click on the desktop and select “Lock Widgets.” That’s it.

Thank you. That it is :))