Widget missing on one montior (OS 13.2) - how to get back?

I have this monster of a graphics card that has 6 outputs. Recently I removed all my old vga type cables and replaced them with HDMI. Now Linux knows my monitors, I get beter res. and all that – it’s a long story why I took so long to make the step but there were good reasons.

In any case, one monitor has completely lost the desktop widget – at least that’s how I interpret what is happening.

Here’s the env. & symtoms:

  • All monitors are arranged in a grid of 3 across by 2 down
  • I can move my cursor and windows across all perfectly so that part of the setup seems fine
  • All montors have the default opensuse 13.2 background with the “Desktop” thing at the top-right
  • Except… the top-left monitor. That is completely black has no “Desktop” thingy (what is that called?) and when I right-click on that monitor no menu comes up. If I click on that monitor and then type Alt-F2 the command entry area comes up on the monitor below that monitor. That is nothing can happen on that monitor except when sliding objects around (e.g. FireFox) it seems to hold an app/object just like any other screen.

In 13.1 I remember on the multi-display setup I could hover over each display representation (in the area where you arrange display’s relative positions to each other) and have some options to do things to those displays. That option seems to be missing on my 13.2 which I am assuming is a minor bug they’ll fix at some point.

That’s all I’ve come up with so far, any ideas to get that one monitor back to normal much appreciated.


You need to specify which DE you are on, OS version and so on…
Which GPU this concerns and the method you used for the multiple display set-up, might also be useful to know for whomever which might have any knowledge about this.

I don’t have any suggestions other than to swap around cables; try using five monitors instead of six, including the one who behaves strangely; rearange which montior thats holds the top left position etc.
Perhaps also try to start from scratch with a test user, might be an inherited problem somewhere.

Point taken. More information:

More details on this problem: The first time I encountered this problem was when I upgraded from 13.1 to 13.2 on an old system. The system below however I only just built over the weekend and so it was a completely cleen install. This time however it happened when I walked away from the computer and so it shut down all the monitors for power saving and I saw the desktop missing when I hit a key to get all my monitors to power up.

More details on the system:

  • OS: Opensuse 13.2
  • Desktop: KDE
  • Motherboard: ASUS X99-E WS
  • CPU: Intel Core i7-5960X
  • OS mounted on OS RAID-1 on: SSD’s
  • /Home + /srv dirs. mounted on OS RAID-5: 4TB HDD’s
  • RAM: 32GB DDR4 2666MHz

The display that this happens to is considered by the system as display # 0. The displays are numbered by the system graphically laid out as follows:

0 2 4
1 3 5

I’ve logged this as a bug now which you can see here: Bugzilla and there I could attach an image showing what’s happening which here: image.

Right now just a way to get the display back when it happens as a workaround would be appreciated.

I just rebooted my computer and saw something curious. As my system booted the desktop showed up as it was finishing it literally faded away until it was gone. Perhaps it’s there but it got a disable flag attached to it somehow?

Maybe a messed up config file you have a very complex system setup. Try another user first. If they work ok, try renaming ~/.kde4 (have to do that when not logged in as you) and reset things up.


I just rebooted my computer and saw something curious. As my system booted the desktop showed up as it was finishing it literally faded away until it was gone. Perhaps it’s there but it got a disable flag attached to it somehow?


I don’t know if I can be of much use on this one but have you looked at /etc/X11/xorg.conf?

Though, it is more likely to be KDE related I guess, have you looked at the files in /home/[user]/.kde4/share/apps/kscreen/?
If you don’t spot anything, try delete the files and have them recreated at next log-in; if you have made any manual alteration to them, make a copy first.

BTW, I couldn’t find any GPU info; your system looks impressive though!

I had a user setup I always keep called “Clean”. This just in case I can’t start up into my normal user I have a spare. I did a compare (using meld directory compare) between .KDE4 of clean and my user.

Then I took files that I thought would be the likely cuprits and copied them from clean to my user. A few tries of that didn’t work. Then I just copied the whole directory from clean to my user and it solved it. Thanks for the tip about the .KDE4 directory!

However, it doesn’t help me pinpoint the problem so I setup hourly backups with rsync (using the feature of rsync to create symlinks to the previous backup for unchanged files to save space) so when it happens again I’ll have snapshot no older than 1 hour to compare files between a good setup and the broken one. Hopefully that will make it possible to pinpont what’s going on I’ll pass that information to the bug I raised which hopefully will get it fixed.