Wicked seems to aonly allow one NIC at a time

My machine has 2 ethernet NICs. In OpenSuSE 13.2, I could use both of them. I upgraded to OpenSuSE Leap 42.2 and forced to use either Wicked or Network Manager, I could not get more than one NIC up at a time on
the same hardware. I just upgraded ( fresh install ) OpenSuSE Leap 15.0. and same issue. I have read articles but none of the are the same issue. If this can’t be resolved, I will have to consider another desktop Operating System. It’s unfortunate as I have been using SuSE since version 6.X. I do not like either Network Manager or Wicked as they are not industry standard. Does anyone know how to get the second NIC working ? When I
try to bring it up, either static or DHCP, it is stuck at ‘setup-in-progress’. I am using wicked but network manager does not bring up the second NIC either.

Show us the definitive evidence. I’ve not had this problem when using wicked or NetworkManager. Starting with wicked, you should show us how your interfaces are configured.

What is reported by the following for example?

ip a
ip r

Also, you can get the status of an individual interface eg

ifstatus eth0

or

wicked ifstatus eth0

Assuming that you have an interface that is down, try bringing it up eg

sudo ifup wlan0

or

sudo wicked ifup wlan0

For NM, the nmcli utility is your friend. Run on its own it will give a list of network interfaces and their current status.

nmcli

This can be used to see which network interfaces are under NM’s control…

nmcli d

It can also show the list of defined connections

nmcli c show

and connect using a particular connection profile

nmcli c up <name of connection>

Do you mean to the same network, or to two different networks?

BTW it is openSUSE and not the camel hump you make of it.

Haven’t seen the machine for a while, it’s a friend’s, but I did setup a 42.3 install with 2 NICs ( 2 networks ) without issues . It should even be very well possible to setup both using the same network.
This brings up a question: how was the system upgraded? Upgrade method or clean install? Asking this because I suspect an upgrade issue.

A thing you can do, is download a Leap 15 live image here http://download.opensuse.org/distribution/leap/15.0/live/ , put that on a USB stick, boot from it and see if you can setup the NICs to your need.

Do you setup manually, or do you use YaST?

First,
LEAP 42.2 is so old, it’s no longer maintained like your 13.2.
You should upgrade at least to 42.3 which will also be no longer supported or LEAP 15 which will be supported well beyond a year from now.

Your basic question about whether LEAP supports only one NIC is that LEAP will support as many NICs simultaneously as are detected. But, Wicked like the “classical ifup/ifdown” in 13.2 supports only one network configuration at a time which is why it’s less suitable for a WiFi interface if your machine moves around from one wireless network to another. Download the LEAP 15 ISO from the following page
https://software.opensuse.org/distributions/leap

So,
As others have asked you in above posts,
You need to provide information about the network interfaces on your machine.

Without knowing how you upgraded from 13.2 to 42.2, I also hope you have a 42.2 DVD which will make it easier to recover if things go unexpectedly badly.
If you don’t have it already, you can download from the following link
https://download.opensuse.org/distribution/leap/42.2/iso/openSUSE-Leap-42.2-DVD-x86_64.iso

TSU

No way. From 10.1 I’ve always had 2 NICS in my serverbox, routing all incoming traffic from my private LAN to the public LAN ( with a guest wifi AP ). That worked fine ever since, also on 13.2 .

Think you can have multiple NICs in a given configuration., but only one configuration at a time.

Yes, one configuration per network interface.

I performed a fresh install of my system from 42.2 to leap 15.0.

As I stated that the networking issue I am seeing did not happen on Suse 13.2 ( yes I know it’s old ) on the same hardware. This tells me that the issue is with OpenSuSE Leap 14.2 and 15.0 since the
same hardware is being used.

I normally use static IP’s. One is on the 192.168.254.X subnet ( that one works ), and the other is on the 10.1.1.X subnet. I found that I can have only one NIC that is brought up at one time.
The other hangs at ‘setup-in-progress’.
The current configuration for eth2 is DHCP.

Suse 42.2 and 15.0 are the first times I have had this networking issue. I have not had it on any previous verison of suse ( I still have a file server running Suse 11.4 with 3 nics in it and it works just fine ).

Here is the output of ‘wicked ifstatus all’.
lo up link: #1, state up
type: loopback
config: compat:suse:/etc/sysconfig/network/ifcfg-lo
leases: ipv4 static granted
addr: ipv4 127.0.0.1/8 [static]

eth0 up
link: #2, state up, mtu 1500
type: ethernet, hwaddr 54:04:a6:4c:95:04
config: compat:suse:/etc/sysconfig/network/ifcfg-eth0
leases: ipv4 static granted
addr: ipv4 192.168.254.254/24 [static]
route: ipv4 default via 192.168.254.2 proto boot

eth1 setup-in-progress
link: #3, state device-up, mtu 1500
type: ethernet, hwaddr 00:14:d1:23:13:b2
config: compat:suse:/etc/sysconfig/network/ifcfg-eth1

Do you actually mean eth1?

Can you post the current configuration for /etc/sysconfig/network/ifcfg-eth1 please?

Additional info:

I always perform a fresh/clean install, no upgrades ( they usually don’t work ).

I retried setting the second nic from dhcp to static, using yast, and still same issue. I just sits at ‘setup-in-progress’.

config files for eth0 and eth1(problem NIC):
eth0:
BOOTPROTO=‘static’
BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=‘192.168.254.254/24’
MTU=’’
NAME=’’
NETMASK=’’
NETWORK=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
DHCLIENT_SET_DEFAULT_ROUTE=‘no’

eth1:
BOOTPROTO=‘static’
BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=‘10.1.10.10/8’
MTU=’’
NAME=‘RTL8169 PCI Gigabit Ethernet Controller’
NETWORK=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
PREFIXLEN=‘24’

output of ‘ifstatus all’
lo up
link: #1, state up
type: loopback
config: compat:suse:/etc/sysconfig/network/ifcfg-lo
leases: ipv4 static granted
addr: ipv4 127.0.0.1/8 [static]

eth0 up
link: #2, state up, mtu 1500
type: ethernet, hwaddr 54:04:a6:4c:95:04
config: compat:suse:/etc/sysconfig/network/ifcfg-eth0
leases: ipv4 static granted
addr: ipv4 192.168.254.254/24 [static]
route: ipv4 default via 192.168.254.2 proto boot

eth1 setup-in-progress
link: #3, state device-up, mtu 1500
type: ethernet, hwaddr 00:14:d1:23:13:b2
config: compat:suse:/etc/sysconfig/network/ifcfg-eth1

output of hwoinfo --netcard:
hwinfo --netcard
22: PCI 406.0: 0200 Ethernet controller
[Created at pci.378]
Unique ID: JNkJ.oxSyVMMObW1
Parent ID: qscc.UsCA9N2eQqB
SysFS ID: /devices/pci0000:00/0000:00:14.4/0000:04:06.0
SysFS BusID: 0000:04:06.0
Hardware Class: network
Model: “Realtek RTL8169/8110 Family PCI Gigabit Ethernet NIC”
Vendor: pci 0x10ec “Realtek Semiconductor Co., Ltd.”
Device: pci 0x8169 “RTL8169 PCI Gigabit Ethernet Controller”
SubVendor: pci 0x10ec “Realtek Semiconductor Co., Ltd.”
SubDevice: pci 0x8169 “RTL8169/8110 Family PCI Gigabit Ethernet NIC”
Revision: 0x10
Driver: “r8169”
Driver Modules: “r8169”
Device File: eth1
I/O Ports: 0xc000-0xcfff (rw)
Memory Range: 0xfe220000-0xfe2200ff (rw,non-prefetchable)
Memory Range: 0xfe200000-0xfe21ffff (ro,non-prefetchable,disabled)
IRQ: 21 (1228262 events)
HW Address: 00:14:d1:23:13:b2
Permanent HW Address: 00:14:d1:23:13:b2
Link detected: no
Module Alias: “pci:v000010ECd00008169sv000010ECsd00008169bc02sc00i00”
Driver Info #0:
Driver Status: r8169 is active
Driver Activation Cmd: “modprobe r8169”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #15 (PCI bridge)

26: PCI 200.0: 0200 Ethernet controller
[Created at pci.378]
Unique ID: rBUF.2dzJn7ktuZF
Parent ID: 8otl.om932x2mw06
SysFS ID: /devices/pci0000:00/0000:00:04.0/0000:02:00.0
SysFS BusID: 0000:02:00.0
Hardware Class: network
Model: “Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller”
Vendor: pci 0x10ec “Realtek Semiconductor Co., Ltd.”
Device: pci 0x8168 “RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller”
SubVendor: pci 0x1043 “ASUSTeK Computer Inc.”
SubDevice: pci 0x8432 “P8P67 and other motherboards”
Revision: 0x06
Driver: “r8169”
Driver Modules: “r8169”
Device File: eth0
I/O Ports: 0xd000-0xdfff (rw)
Memory Range: 0xd2104000-0xd2104fff (ro,non-prefetchable)
Memory Range: 0xd2100000-0xd2103fff (ro,non-prefetchable)
IRQ: 36 (738403 events)
HW Address: 54:04:a6:4c:95:04
Permanent HW Address: 54:04:a6:4c:95:04
Link detected: yes
Module Alias: “pci:v000010ECd00008168sv00001043sd00008432bc02sc00i00”
Driver Info #0:
Driver Status: r8169 is active
Driver Activation Cmd: “modprobe r8169”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #31 (PCI bridge)

[QUOTE=rmouse;2872854]I retried setting the second nic from dhcp to static, using yast, and still same issue. I just sits at ‘setup-in-progress’.

After you’ve made the changes with YaST, try restarting wicked

systemctl restart wicked

It might also be useful to monitor the wicked journalling in another terminal

journalctl -fu wicked

or if using rsyslog instead…

tail -f /var/log/messages

NIC hardware details too please…

hwinfo --netcard

Sorry, missed the hardware details you posted.

You problem is that there is no link for eth1! (Refer to your posted hwinfo output).

Is this openSUSE virtualized or installed on bare metal?
If the machine is virtualized, then it can be important whether your interface name has changed…
There was a problem and still a problem in practically all other distros that in some scenarios, a NIC might not be recognized and another network interface is created…

Example…
If your machine originally is set up with eth0 and eth1, working great.
The machine is changed (more often re-deployed to a new network), maybe then eth1 does not migrate successfully.
You might then find eth0 and eth2 instead of what you had originally, and now eth1 and eth2 are screwed up… Although eth1 had a valid configuration, etho2 is now installed but must be unique, so is typically set with its own new MAC address (which of course does not match what the system expects). Bottom line is you end up with an inactive interface with a valid MAC address and a “working” interface with an invalid MAC address… the end result is that both interface configs are invalid and you might be left with the impression that only one interface can work and the other can’t.

So,
Again…
This only can happen in a virtualized installation but is more often seen in a slightly different scenario…
But the main way to suspect this problem is that you now don’t see the same interface names as before, one or both might be incremented (eg from eth1 to eth2)

Verify if this has happened, if the case post the results of the following and I can tell you what needs to be done to fix it

cat /etc/sysconfig/network/ifcfg-eth0
cat /etc/sysconfig/network/ifcfg-eth1
cat /etc/sysconfig/network/ifcfg-eth2

TSU

@tsu2: Read the OP’s output from post #11. The hwinfo output reports that there is no link detected for eth1. Could be faulty cabling, port, or perhaps the NIC itself, but that’s what needs addressing here.

Yes,
I didn’t see that post, sometimes it takes me more than the 20 minutes between that and my post if I’m doing different things at the same time. Also, his post does nto describe another interface besides eth0 and eth1’

So, my post about a virtualized machine does not apply.

TSU

Yes, it’s just eth0 and eth1 based on the definitive output posted to date.

Thanks for all the responses.

However, there have been several requests for info not sure what else I can provide.

The machine is bare metal.
The second NIC, eth1, does not have a cable plugged into it at the moment. However, that is irrelevant.

At this point, I am thinking that the drivers may not work on the Trendnet Gigabit NIC.
As I said, it worked in 13.2 but not on leap 42.2 OR 15.0.

I am going to try a NIC from a different manufacturer.
This box is a virtualbox host so you will see some virtual box network info

hwinfo --net
61: None 00.0: 10701 Ethernet
[Created at net.126]
Unique ID: usDW.ndpeucax6V1
Parent ID: rBUF.2dzJn7ktuZF
SysFS ID: /class/net/eth0
SysFS Device Link: /devices/pci0000:00/0000:00:04.0/0000:02:00.0
Hardware Class: network interface
Model: “Ethernet network interface”
Driver: “r8169”
Driver Modules: “r8169”
Device File: eth0
HW Address: 54:04:a6:4c:95:04
Permanent HW Address: 54:04:a6:4c:95:04
Link detected: yes
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #20 (Ethernet controller)

62: None 01.0: 10701 Ethernet
[Created at net.126]
Unique ID: JSHY.ndpeucax6V1
SysFS ID: /class/net/vboxnet1
Hardware Class: network interface
Model: “Ethernet network interface”
Driver: “vboxnet”
Device File: vboxnet1
HW Address: 0a:00:27:00:00:01
Permanent HW Address: 0a:00:27:00:00:01
Link detected: no
Config Status: cfg=new, avail=yes, need=no, active=unknown

63: None 00.0: 10700 Loopback
[Created at net.126]
Unique ID: ZsBS.GQNx7L4uPNA
SysFS ID: /class/net/lo
Hardware Class: network interface
Model: “Loopback network interface”
Device File: lo
Link detected: yes
Config Status: cfg=no, avail=yes, need=no, active=unknown

64: None 01.0: 10701 Ethernet
[Created at net.126]
Unique ID: L2Ua.ndpeucax6V1
Parent ID: JNkJ.oxSyVMMObW1
SysFS ID: /class/net/eth1
SysFS Device Link: /devices/pci0000:00/0000:00:14.4/0000:04:06.0
Hardware Class: network interface
Model: “Ethernet network interface”
Driver: “r8169”
Driver Modules: “r8169”
Device File: eth1
HW Address: 00:14:d1:23:13:b2
Permanent HW Address: 00:14:d1:23:13:b2
Link detected: no
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #16 (Ethernet controller)

65: None 02.0: 10701 Ethernet
[Created at net.126]
Unique ID: mdXc.ndpeucax6V1
SysFS ID: /class/net/vboxnet2
Hardware Class: network interface
Model: “Ethernet network interface”
Driver: “vboxnet”
Device File: vboxnet2
HW Address: 0a:00:27:00:00:02
Permanent HW Address: 0a:00:27:00:00:02
Link detected: no
Config Status: cfg=new, avail=yes, need=no, active=unknown

66: None 00.0: 10701 Ethernet
[Created at net.126]
Unique ID: sG1U.ndpeucax6V1
SysFS ID: /class/net/vboxnet0
Hardware Class: network interface
Model: “Ethernet network interface”
Driver: “vboxnet”
Device File: vboxnet0
HW Address: 0a:00:27:00:00:00
Permanent HW Address: 0a:00:27:00:00:00
Link detected: no
Config Status: cfg=new, avail=yes, need=no, active=unknown

ifcfg files:
ifcfg-eth0:
BOOTPROTO=‘static’
BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=‘192.168.254.254/24’
MTU=’’
NAME=’’
NETMASK=’’
NETWORK=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
DHCLIENT_SET_DEFAULT_ROUTE=‘no’

ifcfg-eth1:
BOOTPROTO=‘static’
BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=‘10.1.10.200/24’
MTU=’’
NAME=‘RTL8169 PCI Gigabit Ethernet Controller’
NETWORK=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’

ifcfg-lo:

Loopback (lo) configuration

IPADDR=127.0.0.1/8
NETMASK=255.0.0.0
NETWORK=127.0.0.0
STARTMODE=nfsroot
BOOTPROTO=static
USERCONTROL=no
FIREWALL=no

I think you now understand that wicked was waiting for an interface (eth1) to become active, and no link was detected (which ethtool or ip commands would have shown you as well). So, this has nothing to do with wicked.

If an interface needs to be assigned with a stati IP address even when not active then the following option can be added to the appropriate ifcfg file

LINK_REQUIRED=no