Wicked problem

I did a fresh install from the openSUSE-Leap-42.3-DVD-x86_64 iso, with the Xfce desktop. In the notification area, the network app said “Networking disabled”. I opened Firefox and the network was working? The problem was solved by opening Yast and under networking global, the default was “Wicked”. I changed this back to network manager and everything was fixed. So if any of you have a “Wicked” problem, this is what to do. The newish wicked program is apparently not compatible with the notification area network app.

I’ve noticed the “extra” networking icon that says “disabled,”
It’s apparently an artifact of when Network Manager is installed but disabled (ie your system is configured to use Wicked) so although it might appear to be confusing, it’s there because if you want to change to Network Manager a step is saved(You don’t have to install the Network Manager package).
Resolution is as you’ve figured out.