Wicd, Python 2.7, and OpenSUSE 11.4

Where can a new version of wicd --meaning, one that works with Python 2.7 as provided in OpenSUSE 11.4-- be found?

I never used the Wireless Interface Connection Daemon (wicd).

I wounder if a version build against the current openSUSE Factory might work.
software.opensuse.org - Search Results (Factory): [i]wicd

And the versions in (quoted without links)

urwid- 11-Feb-2011 00:13 172K Details
wicd-1.6.1-1.2.i586.rpm 03-Jul-2009 04:16 428K Details

urwid- 10-Feb-2011 00:41 172K Details
wicd-1.6.1-1.2.x86_64.rpm 03-Jul-2009 04:13 428K Details

are older than the release date of 11.4 - so I guess they might work.

And would it be difficult to download the source code and compile it yourself for 11.4?
-> wicd - Browse Files at SourceForge.net


I’ve already tried out a 1.7.something version, and it didn’t work; it was written for Python 2.6. I tried using it anyway, and it failed, so I’m afraid it isn’t a matter of compilation; there are source code changes to be made.

Thanks for your time!

No cause to be grateful - I was just interested in the answer, too. Especially as the Wireless Interface Connection Daemon (wicd) might be an other alternative to the knetworkmanger/packet:NetworkManager-kde4 or the network-manager-applet[nm-applet]/packet:NetworkManager-gnome) and as had been looking a bit around I have chosen to post my ‘result’ - been hoping this ‘result’ would at least make a small progress (I think of a forum as a place of collaborative work via ).

But maybe the https://lists.sourceforge.net/lists/listinfo/wicd-devel would also be a place for raising your question (although it is almost empty untill n).

And out of curiosity:
Have you also tested wicd-1.7.1b2 from 2010-11-20 ?
If I understood
Gentoo’s Bugzilla : Bug 333001 - net-misc/wicd-1.7.0 doesn’t support Python 2.7
in the right way right - this beta version shall work with python 2.71 .

Have a lot of luck and than fun

Up to now, I have tried to stay with the OpenSUSE repositories’ versions, but I’m thinking about giving that version a try… I’ll post results if/after I get it to do anything.

Thanks for your time!


I got the 1.7.1 beta 2 version, and installed it with:

wget http://downloads.wicd.net/src/testing/1.7.x/wicd-1.7.1b2.tar.gz
tar zxf wicd-1.7.1b2.tar.gz
cd wicd-1.7.1b2/
python setup.py configure
python setup.py install
/etc/init.d/dbus restart
/etc/init.d/chkconfig wicd on
/etc/init.d/wicd start

after which I was able to run wicd-client with no problems at all. I figured that, since I had previously had wicd installed from a repository, I should already have all pre-requisites available; should this not be the case, read the INSTALL file for specifics.

Thanks, I had problem installing wicd and did it the way you mentioned. The only thing was “chkconfig wicd on” didn’t work for me, so I added runlevel 3 and 5 from YaST.
Thanks :slight_smile: