Wi-Fi is disabled by (missing) hardware switch

Just installed opensuse 13.1 on a new Asus notebook — freedos, no Windows on it.

Network Manager says Wi-Fi is disabled by hardware switch but notebok has none and Fn+F2 (an icon on it shows an antenna) does not do anything.

I could not find anything related in BIOS.

Booting with Puppy linux from a USB drive I can scan the network with no problems

# nm-tool


- Device: wlp2s0 ---------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k
  State:             unavailable
  Default:           no
  HW Address:        6C:71:D9:79:BF:79


  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 

# rfkill list
0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

# lspci | grep -i net
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
03:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 06)

lsmod | grep -i ath
ath9k                 109640  0 
mac80211              635562  1 ath9k
ath9k_common           13859  1 ath9k
ath9k_hw              440385  2 ath9k,ath9k_common
ath                    27923  3 ath9k,ath9k_common,ath9k_hw
cfg80211              522716  3 ath9k,mac80211,ath

Thanks for your help

This did the trick: networking - Wireless disabled by hardware switch - Ask Ubuntu

sudo echo "options asus_nb_wmi wapf=1" > /etc/modprobe.d/asus.conf

You need to run

su -c 'zypper in rfkill'
su -c 'rfkill unblock 1'

rfkill won’t work with hard blocked… already tried.

I solved anyway, see my 2nd post.

Thank you