Wi-Fi Hotspot stopped having Internet access


my Smartphone connects to a Wi-Fi Hotspot on my PC and suddenly is not able to use the connection to access the internet anymore.
The issue first occurred when rebooting after Installing Docker, the process included adding my user to the docker group through YaST, which is the only thing i can imagine caused the issue. My user is only in the groups with the username and docker, which seems odd to me.
I have had previous issues with my Wi-Fi, my card had problems with wpa2/3 transitional modes, but using sae key management fixed that, and i don’t have a reason to believe that this is the issue again.

dmesg shows the following when running “nmcli connection up Hotspot”

[ 2768.045038] IPv6: ADDRCONF(NETDEV_CHANGE): wlo1: link becomes ready
[ 2768.595761] iwlwifi 0000:04:00.0: Unhandled alg: 0x4000071b
[ 2768.601272] iwlwifi 0000:04:00.0: Unhandled alg: 0x4000071b
[ 2768.940360] iwlwifi 0000:04:00.0: Unhandled alg: 0x4000071b
[ 2769.000465] iwlwifi 0000:04:00.0: Unhandled alg: 0x4000071b
[ 2769.805971] iwlwifi 0000:04:00.0: Unhandled alg: 0x4000071b
[ 2769.812263] iwlwifi 0000:04:00.0: Unhandled alg: 0x4000071b
[ 2769.815996] iwlwifi 0000:04:00.0: Unhandled alg: 0x4000071b

I have no idea where to start troubleshooting and would greatly appreciate your help.

Edit: I just noticed that KDE Connect still works, now i am even more confused.


Are you certain that –

  1. The PC can access the Internet?
  2. There’s an active Route between the PC’s WiFi interface and, the interface it uses to connect to the Internet?
  1. Yes - The PC can acces the Internet.
  2. No - Im not sure what exactly you mean with that.
    In Gnome Settings under Network the Wired Connection Details have a check at “Make available to other users”.
    In the YaST firewall settings under Interfaces it only shows docker0 and enp5s0 and not wlo1, the Wi-Fi device name. Is that where the problem lies?

Not only does the Firewall need to recognise the WiFi interface, there has to be IP Routing enabled between the WiFi interface and, the Ethernet interface.

I added the Wi-Fi Device with nm-shared as zone, which seems to be correct. But i can’t figure out how to enable IP Routing between the interfaces, could you explain to me how?

I found a possible solution here : networking - Hotspot created and connected from linux but no internet access on phone - Ask Ubuntu.
Apparently the issue is caused by Dockers changes to iptables blocking forwarding. I have no idea of the solutions impact on security.

The openSUSE Reference Manual – <https://doc.opensuse.org/documentation/leap/reference/html/book-reference/cha-network.html#sec-network-router>

1 Like