Wi-fi died - how to connect via eth0

My wi-fi died. I connected to the router with cable. I can ping 8.8.8.8. But my DNS (8.8.8.8) is not providing an address and my browsers report “No Internet”. I do not use a firewall. My notebook ethernet connects. Please direct me to diagnostic instructions.

Post:

ip a
ping -c3 8.8.8.8
ping -c3 google.com

Show

cat /etc/resolv.conf
ls -l /etc/resolv.conf
grep hosts /etc/nsswitch.conf
dig dns.google
:~> ip -a
Usage: ip  OPTIONS ] OBJECT { COMMAND | help }
       ip  -force ] -batch filename
where  OBJECT := { link | address | addrlabel | route | rule | neigh | ntable |
                   tunnel | tuntap | maddress | mroute | mrule | monitor | xfrm |
                   netns | l2tp | fou | macsec | tcp_metrics | token | netconf | ila |
                   vrf | sr | nexthop }
       OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |
                    -h[uman-readable] | -iec | -j[son] | -p[retty] |
                    -f[amily] { inet | inet6 | mpls | bridge | link } |
                    -4 | -6 | -I | -D | -M | -B | -0 |
                    -l[oops] { maximum-addr-flush-attempts } | -br[ief] |
                    -o[neline] | -t[imestamp] | -ts[hort] | -b[atch] [filename] |
                    -rc[vbuf] [size=] | -n[etns] name | -N[umeric] | -a[ll] |
                    -c[olor]}


:~> ping -c3 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=59 time=9.26 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=59 time=9.12 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=59 time=9.11 ms

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 9.110/9.168/9.267/0.105 ms


:~> ping -c3 google.com
ping: google.com: Name or service not known


[/size]

@ionmich:
ip a is not ip -a

But post what @arvidjaar has said.

ion@localhost:~> cat /etc/resolv.conf
ion@localhost:~>

:~> ls -l /etc/resolv.conf
lrwxrwxrwx 1 root root 26 Jun  9 16:16 /etc/resolv.conf -> /run/netconfig/resolv.conf


:~> grep hosts /etc/nsswitch.conf
# Valid databases are: aliases, ethers, group, gshadow, hosts,
hosts:      files mdns_minimal [NOTFOUND=return] dns


:~> dig dns.google

; <<>> DiG 9.16.6 <<>> dns.google
;; global options: +cmd
;; connection timed out; no servers could be reached


Also traceroute might be helpful

sudo traceroute 8.8.8.8

How do you expect DNS to work? You claimed “my DNS (8.8.8.8) is not providing an address” - what exactly “my DNS” means here? How did you configure “your DNS”?

In which way?

:~> ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:25:22:d9:2d:b8 brd ff:ff:ff:ff:ff:ff
    altname enp1s0
    inet 192.168.1.253/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0
       valid_lft 86296sec preferred_lft 86296sec
    inet6 fe80::64c2:db22:500d:1c93/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever


How do you get your IP?
with dhcp?
if yes, try as root:

netconfig update -f

Otherwise you have to add it by hand…

Yes DHCP. Did that. Nothing changed. Thanks for the suggestions. I would just buy another wireless card except that there are none available locally and ordering from the Internet takes time and risks. So it’s re-install time.

Your dns is not working, thats all…
Have you rebooted your Router?

You can add a dns to /etc/resolv.conf such as:

linux64:/home/stephan # cat /etc/resolv.conf 
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
#search linux

# Cloudflare and APNIC
nameserver 1.1.1.1
# quad9
nameserver 9.9.9.9
# Router
nameserver 192.168.0.254


No, that is not the way forward. As sauerland has mentioned already, it is a DNS issue to be sorted. Focus on that.

I switched to systemd networking some time ago: Network Management With Systemd - openSUSE Wiki

No maintenance required, no malfunction encountered since March 2019, concise configuration with a single file:

**erlangen:~ #** cat /etc/systemd/network/20-wired.network 
[Match] 
Name=e* 

[Network] 
DHCP=yes 
Domains=fritz.box 
**erlangen:~ #** 

Did what?

So it’s re-install time.

Well, if it is easier for you … but we still do not even know what you are using - wicked or NetworkManager or something else - so no suggestion is possible.