why wont chromium load this site?

I ocassionally watch multimedia on this site . . .


It loads fine in Chrome and Firefox but will not load in Chromium (60.0.3112.78)
It just sits there with the company logo and cannot get past it. In the other two browser the company logo is shown for a few seconds then it displays all available content.

I’ve done a full multimedia switch to Packman and installed recommended multimedia codecs.
chromium-plugin-widevinecdm is installed to allow playback of drm content.

can anyone else view content in chromium?

I haven’t tried playing any of the content.

The page itself looks fine in “firefox”, but fails to load with “firefox” in a private browsing window. It also fails to load if I use “noscript”.

It loaded okay in “chromium”, even in an incognito window. It loaded okay in “vivaldi”.

seems to be working for me now as well. I’m not sure what changed. It wouldn’t load for about the last two to three weeks . . . despite clearing history / cache etc (but would load in the other two browsers).
Anyway - problem solved . . just not sure how :slight_smile: