why these fonts in firefox?

Viewing web pages on this site ( New Zealand, world, sport, business & entertainment news on Stuff.co.nz ) - Firefox in Opensuse displays god awful fonts.

see here


Notice the terrible font spacing

I have my system fonts set for both KDE 3 & 4 & GTK to tahoma and my fonts for Western & UTF8 encoding in firefox set to Arial

Notice how the page looks so much better on Windows XP with exactly the same settings in Firefox


Anybody have any idea on how these awful fonts are being assigned?

That site looks perfectly fine to me in Firefox.

What fonts are you using?

I use

Proportional = Serif

Serif = Time Roman

Sans Serif = Arial

Monospace = Courier New

I have almost exactly the same settings as you except for one minor difference

Proportional = Sans Serif

Serif = Times Roman

Sans Serif = Arial

Monospace = Courier New

However, fonts for this website are not dictated by firefox settings - they are being set by the site itself - just can’t understand why the fonts displayed in my linux box look so bad.

That could be the difference

What could be the difference?

I changed to exactly the same settings you listed and it made no difference.

Do you not see the bad spacing between teh characters.
Notice in the first screenshot above the word “residents”
look at the spacing between e&s and e&n.

You have un-ticked “Allow pages to choose their own fonts instead of my selections above” haven’t you?

I’m using Firefox 3.0.6, and that can be found under Edit->Preferences->Content(Tab)->Fonts and Colours(heading)->Advanced.

no - the checkbox allowing websites to use their own fonts is checked.

If I uncheck the box the page will use the fonts I specify, which solves the problem for that site. - but I should not need to do that

Most likely it’s a case of monitor DPI being incorrect and thus the font sizes are going bonkers (not to mention it looks as if you don’t have sub-pixel rendering enabled)

Would you open up a terminal (as a normal user) and type: xdpyinfo | grep -i resolution

then copy paste the results here.

Had already checked this but here you are . . .

xdpyinfo | 
grep -i resolution
  resolution:    96x96 dots per inch

fonts are set up as per
Optimal Use of MS TrueType Core Fonts for a KDE Desktop on SuSE - openSUSE

As I said previously - I only have the font issue whit this website.
I thought it might be something to do with the browser identification so I tried changing it to ID as IE on Vista but made no difference - but that may be more to do with the page being sophisticated enough to find its way round browser ID and rather look at the OS.

Incidentally - the site looks just fine in Konqueror - it is only in Firefox I have the problem.
However, not sure if Konqueror 4 allows websites to specify its own fonts.

Did you installed ms fonts in opensuse. if not it could be a case of the site font is missing in your font library which could have been sustituted with another font. Just my guess.

I went to the site using firefox and can confirm we both have the same result. I am using tahoma in firefox.
With epiphany the fonts in that site are almost the same with firefox in xp that you posted.

What helped in my case was to disable anti-aliasing (this option is available for both GNOME & KDE), fonts are clear on most websites and applications.

Some websites still have unclear fonts though (eg Linux Journal | The Original Magazine of the Linux Community).

yes - I have all the MS fonts installed and have specified system fonts as tahoma.

I’m sure the issue is to do with the website understanding that we are visiting with a linux OS and then specifying a font. And I’m sure the font we are seeing is the xorg “san serif” font.
Browser spoofing doesn’t seem to correct the problem though.

The site is probably specifying this font as it is a guaranteed that it will be on every linux install - it is just a **** ugly font though.

I do have anitaliasing disabled.

The issue is not one of the clarity of the fonts but of the bad font which is being specified to be used with the web page.

In my previous post I mentioned that I thought it was the xorg “sans serif” font but I don’t now believe this to be the case. It seems it more closely resembles xorgs “monospace”, which is strange as this is a fixed width font.

OK - have made a little headway in my research on this.

It looks as if it is caused by the font helvetica being specified by a web page or email.
Now - most linux distros do not ship with helvetica so the xorg fonts map this specification to the font Nimbus Sans L

It is the Nimbus font that has the bad spacing.

Since Opensuse ships with Adobe Helvetica what I would like to know is what changes can be made to my fonts config to specify that when Helvetica is called for it brings up the adobe font rather than the Nimbus font?