Why root password for shutdown

Hi everyone,

I wish you all a happy 2010!

When I shut down or restart my system, it asks for the root password. Is there any way that I can disable that?

Many thanks.


This happened to me after I tried to activate the fingerprint reader in Yast. Deactivating it, solved the matter.



Not sure if you’re using KDE or Gnome since you didn’t specify. In KDE 4 if you open a terminal then type:

kdesu systemsettings

then enter your root password at the prompt, click the Advanced tab and under the category System click Login Manager. Under the tab shutdown, change the local one to Everybody.

Take Care,


Hi ijbreakey,

Thank you very much for your advice. I am using KDE 4. I went to check the setting that you mentioned, but it was already set to Everybody.

I see that remote is set to Root Only, but I dont think the problem is remote because I am shutting the machine down locally.

Any other suggestions?

Many thanks


henkasdf wrote:
> Any other suggestions?

have a look in YaST > Security & Users > Local Security

where you can check to select your “Security Configuration” as “Home
Workstation” “Networked Workstation” and etc … just (for now at
least) leave it as checked by click on next until you get to a page
named “Boot Setting” or “Boot Permissions” and there you should see a
“Shutdown behavior of Login Manager” if yours is set to “Root” flip it
to “All users.” and then “Next” to “Finish”…(when you click finish
you will have, i think, created a “custom” security configuration…

CAUTION: don’t get too creative, and always read the
notes/instructions on the left side…more than one person has set
Miscellaneous Settings “File Permissions” to something other than easy
and LOCKED themselves out of their own box! (use the forums search for
that and see how much trouble it is to undo that slip.)


Thank you palladium, I did just as you recommended. I going to shut down and test it now.

I will let you know.



Hi palladium,

Thank you very much for your advice. It worked 100%

Many thanks


> Thank you very much for your advice. It worked 100%
> Many thanks

happy for you, Have a lot of fun!


Thanks again!!

This was bothering me also and I used the info here to make SUSE stop asking me.
Thanks very much!

What a great forum!
What a great OS!

happy for you toooooo


configure desktop (systemsettings)-advance-policykit authorization-org-freedesktop-hal-power-management
Authorize your user to shutdown your system.

Did you set your file permission to secure in yast2-security and users-local security if you set it to easy then you will be able to shutdown the system as user and no need to touch the policykit.

For me, the behavior changed after my latest update of all installed packages (might have been introduced via kde using the kde4.3 repo or general yast updates).
Note that under YaST/Local Security the file permission is still set to “easy”. Sure I can change the policy kit or other sysconfig settings. But does anybody know whether this change was introduced by purpose or accidentally? In SuSE 10.1 the same happened via some kde 3.5 update and went away silently some time later …