Why Leap 15.2 still is using glibc 2.26?


glibc 2.27+ is needed for some purposes.
For instance, https://forums.opensuse.org/showthread.php/540694-Blender-opencl-I-need-the-propertairy-drivers?p=2941097#post2941097


2020-02-01: glibc 2.31 released.
2019-08-01: glibc 2.30 released.
2019-01-31: glibc 2.29 released.
2018-08-01: glibc 2.28 released.
2018-02-01: glibc 2.27 released.
2017-08-02: glibc 2.26 released.

System software from 2017-08-02 in 2020 - and for what?

I think the version used in Leap is tied to the version used in SLE.

I guess it would be quite easy to install a later level as the Waterfox packages as supplied by the author need at least 2.28. Question is how likely is it to cause problems along the way with Leap 15.2 if I do install say 2.31 now? Would I be better installing 2.28 now rather than 2.31?


Looks like 2.31 has been built for TW, and 2.27 has been built in a private repo for openSUSE 15.2

My recommendation:

  1. Submit a request to https://bugzilla.opensuse.org, as you describe it’s likely long past time to upgrade the C libraries.
  2. Install virtualization like Virtualbox (if you’re new to virtualization, is easier to use than KVM or Xen. VMware Player is a good beginner option, too), and then install TW in a virtual machine. Your C development environment should be just what you need by default.


That in itself will address any issues of compilation where a higher level is required but will not address the issue of pre-built packages needing a higher level at least if/when a request in Bugzilla is actually accepted and activated which could likely take some time. How difficult would it be to simply install a higher level package without any re-compiling of stuff in Leap 15.2? What if any issues might arise?


OK, I understand you just want to run Waterfox and aren’t likely that much into development.
I took a look around, and it looks like since at least 2017, plenty of people have asked the Waterfox developers to create a Flatpak and/or Snap but nothing has been done. I also took a look to see if anything exists in docker hub, but nothing.

Since the project isn’t brand new, maybe someone should try building in OBS which might fix their problem of apparently building to only the latest
Speaking of which, there is an OBS Waterfox project, but he built only for Debian Unstable and nothing else.
Curious that there are numerous OBS Waterfox projects for numerous language plugins even for all openSUSE but no Waterfox itself.
Despite requests, apparently Waterfox does not retain archived builds.
I also took a look at the github source, the project does not retain source for old releases so you don’t even have an option to build an old version from source.

Bottom line,
I explored every avenue I can think of to simply install Waterfox on a system with an older Glib… but glib on openSUSE seems to have fallen through a crack at the moment and was overlooked for updating.

I don’t see an option to run Waterfox on openSUSE 15.2 until the glib rebuild is done (and I’d expect it, someone will likely decide to upgrade when it’s as old as it is)


I submitted a bug report

I noted my mistake confusing glib and glibc but still made a request for a later build to be made available to 15.2.


If someone wanted to try to build using glibc 2.26 (over-riding the 2.28 requirement), I wonder if it would work.
According to a changelog, only one performance, support for a new unicode standard and two functions were added.
If none of those makes a major bit of difference, I’d say that prospects would be good to try to build from source… Or, just install Waterfox and see if it’s hard coded to require glibc 2.28 or later no matter what.
If the install balks on the glibc version, you can find out the specific library file name and do a symlink so that the install thinks it’s reading 2.28 although using 2.26.


Bug filed for Leap 15.1: https://bugzilla.opensuse.org/show_bug.cgi?id=1173761

You may install glibc 2.31 from TW repo, but: Attention!!! - do not add TW repositories in a Leap!
If you will add TW repos in a Leap you will get non-working blend of a Leap + TW.

Make instead local repo:

  1. Create folder at your local drive and add it as a repo with YaST or zypper
  2. Download rpm packages from TW (factory) repo into this folder
  3. Update needed stuff with YaST

Please change name of this bug to something more appropriate.
Something like “We need glibc 2.29 or newer”.

I changed this name to “We need glibс 2.29+ in openSUSE 15.2”.

Developers refused to go another step:


  • Please update glibc to 2.29 or newer (PM-2030) Pending ECO approval

It were be nice to get updated glibc as an experimental package, but …

Nobody prevents you from branching glibc, updating to whatever version you want and providing result so others can also benefit.

Trying to install glibc 2.31 from TW: cannot install - too many conflicts (over 900) occured.

Workaround: 1163301 – Steam game Imperator Rome does not work - old glibc

I can workaround it via downloading glibc eg. from Tumbleweed and put “LD_PRELOAD=/home/games/lib64/libm.so.6 %command%”