Why is some packages' version in Tumbleweed lower than in openSUSE 12.2 ?

When i have read some wikis about Tumbleweed, i like it very much, because it can meet my needs.

But when i switch to it, i find some packages has been downgraded! i want to know is it normal?

Thanks

lingchax

If you compare only standard 12.2 repositories with standard tumbleweed repositories, this should never be the case. At the moment, as far as I know, they should be identical, as the tumbleweed repository is empty.

You probably had added other repositories to your installation in 12.2.

ok, nikos78, i have a littile confusion.

this is my repos:

# | Alias                            | Name                             | Enabled | Refresh--+----------------------------------+----------------------------------+---------+--------
1 | Packman Tumbleweed               | Packman Tumbleweed               | Yes     | Yes    
2 | openSUSE Current non-oss         | openSUSE Current non-oss         | Yes     | Yes    
3 | openSUSE Current oss             | openSUSE Current oss             | Yes     | Yes    
4 | openSUSE Current updates         | openSUSE Current updates         | Yes     | Yes    
5 | openSUSE Tumbleweed              | openSUSE Tumbleweed              | Yes     | Yes    
6 | openSUSE non-oss Current updates | openSUSE non-oss Current updates | Yes     | Yes  

i will keep it ot not? and is it right according to Tumbleweed?

btw: Tumbleweed is not empty, it has git、Mercurial and so on。。。

Package subversion numbers can be lower in Tumbleweed just because they were created before the versions in Update (for example). Point is that all packages available for Tumbleweed should be installed from the Tumbleweed repo. If you have followed the instructions to move to Tumbleweed, the Tumbleweed repo is the repo where software management is going to look for updates of installed packages.

On 09/19/2012 04:36 PM, douglarek wrote:
>
> When i have read some wikis about Tumbleweed, i like it very much,
> because it can meet my needs.
>
> But when i switch to it, i find some packages has been downgraded! i
> want to know is it normal?
>
> Thanks
>
> lingchax
>
>
Maybe this (not sure exactly what you’re seeing): maybe because the
packages in Packman Tumbleweed are lagging the equivalent packages in
Packman openSUSE 12.2

I’m checking the info that comes with zypper dup to see when this shakes
out, before I press the button for the first time since 12.2 was
released. I’m also waiting for the kernel version to rise back again.

I know, I’m just being fussy.


Regards
swerdna

Thanks all, i think i understand…

lingchax