Why is Knetwork Manager not found in OSS 12.1 KDE?

Could we please get back to this problem for a moment? http://forums.opensuse.org/english/get-technical-help-here/wireless/468499-knetwork-manager-not-found-opensuse-12-1-kde-live.html
I see no clear solution there. I would like to know if this is a bug, then why hasn’t it been resolved yet?

If this is not a bug, then why take away the freedom and convenience of having a network manager on that task bar as in 11.4?

How do I get my good, friendly, trustworthy network manager that I’m used to using in 11.4 into 12.1? Thanks in advance.

What is wrong with using the plasmoid-networkmanager? I think it is the same or easier to use than before? Its a KDE supplied application and was not a decision made by openSUSE.

Thank You,

The network manager plasmoid is installed by default (with KDE). It is probably installed on your system.

Here’s the difference between 11.4 and 12.1, as best I remember:

With 11.4, the network manager ICON showed up in the system tray on both desktop and laptop. The desktop defaulted to using “ifup” method, and the network manager icon showed as a red X, until I disabled it. On the laptop, it worked fine because the system defaulted to using networkmanager.

With 12.1, the icon did not show up on my desktop. It had apparenly been disabled by the installer. It did show up and worked on the laptop.

I was able to turn on networkmanager in the 12.1 desktop.
“Personal Settings” → “Startup and Shutdown” → “Service Manager” and then check the box for “NetworkManager User Settings Service”. You might have to also click the “Start” button if it is not listed as running.
Then, edit the system tray settings, and check the box for “Network Management”. You also have to go to Yast network settings and turn on NetworkManager.

Thank you very much for the info. I have done all of the above except editing the system tray settings. I don’t know how to do that and I’m not sure what to look up. Please tell me. Thanks in advance.

I did find a widget called network connection manager which serves the same purpose; it’s not like having it on my system tray, but it’s a nice substitute. Perhaps, I’m just not experienced enough in linux, but I sense that the only change from 11.4 was that the “furniture was moved around with a new carpet and drapes.” And then someone misplaced my “TV Remote” in the process.

1: Right click on your desktop. A menu should show up. It there is an option for “Unlock widgets”, the select that. If there is an option for “Lock Widgets”, then your widgets are already unlocked, so nothing to do for this step.

2: Right click on a blank spot on the system tray. If there is an option for “System Tray Settings”, select that. If you don’t see it, then hold the mouse over “panel options”. Another menu should open on the side, and select “panel settings” there.

2a: If you selected “panel settings” in the prev step, then a panel settings menu should have opened. Move your mouse along that menu until above the tray. A selection for “tray settings” should pop up. Select that.

3: On the system tray settings menu, check the box for “Network Management”. Then click “OK”.

4: (optional) Right click on the desktop, and select “Lock widgets”. (This makes it harder to make dumb mistakes).