why I fled to Kubuntu

Let me start to say that I’m a long time SUSE fan. On my trusty old Pentium 4 2,4 Ghz I installed and used almost all the SUSE releases from the past 6 years. I think the developers of SUSE do a good job in providing us release after release with one of the finest Linux distributions. I am especially delighted by one of the best KDE integrations in Linuxland.

When SUSE announced the availability of 11.1 I was looking forward to install and try this release. So when I had a whole day for myself last week I decided that 12 hours would me more than enough to rejuvenate my computer. I downloaded the I386 DVD, checked the md5 checksum and burned the DVD with read after write control. In the forums I have read that a fresh install would be best so that was the route I took.

A bit nervous I loaded the DVD, rebooted and there it was. The first install screen of what I remembered as being a very clean install program. Well first the media check. Twenty minutes later the media check was still in its first phase, so I decided to reboot and try again. Fifteen minutes later the media check still wouldn’t progress. Looking at the system messages I noticed that SUSE was still loading the base drivers. To be absolutely sure I burned the DVD again including all the checks (md5sum, read after write). Rebooted with the fresh DVD in the tray and … SUSE still froze at loading the base drivers. After some fiddling with my computer I found out that my Mybook external usb drive prevented SUSE from continuing the install So i unplugged it. OK first lesson learned.

The rest of the install went smooth and easy and I looked forward to the plasma looks of KDE 4.1, my favorite desktop. At the end of the install cycle I lost my attention for a moment and when I looked again SUSE had dumped me on the command prompt. No plasma, no KDE desktop. I checked some things and looked around a bit and soon discovered that startx would bring me back my KDE desktop. In /var/log/messages I noticed kdm errors. Duplicate lines in kdmrc. But I couldn’t find any. Well that was something that needed more attention because I don’t like to type startx again and again to enter my desktop.

At that time I thought that perhaps the installation of the correct NVIDIA driver would cure my xserver problems. Well luckily there is the one-click-install system. I found the correct button for my video card and pushed the button. A small stamp like window opened up with no indication about its function and I waited. Nothing happened, no activity and no information in the stamp sized window. And I waited and waited and waited and nothing happened,hmmmmmmmpfgrrrrrrr…

An important role for my pc is its function as music server and as home for my music collection. So I started Amarok, a brilliant music player and from the corner of my eyes I saw a pop-up screen informing me of some PHONON problem. I didn’t see it quite clearly so I decided that perhaps I had to install some restricted drivers (mp3). I decided to try my luck again with the one-click-install and pushed the button. Well there it was again, the stamp sized window and again nothing happened.

Playing around with Amarok 2 there popped up a notification window that informed me of a problem with PHONON and my trusted SBLIVE card. It seemed I had more sound problems than a restricted driver install could cure. At that particular moment I became very sad, because music is my life. Browsing the SUSE forums I soon discovered I wasn’t the only one with sound problems. Gazing at the clock I realized that 8 hours had gone by and that I was nowhere near a functioning LINUX system. I needed my computer back and fast, my time was running out.

One moment I thought about returning to SUSE 11.0 but that felt too much as a failure. I decided to go for another recent distro. But which one. Fedora 10 perhaps… no, not enough KDE oriented. Mandriva, hmmmmm that was certainly a candidate. In the end I choose for Kubuntu. For months and months I’ve read positive critics about Ubuntu but to be fair I was always a bit skeptical about it and thought it to be a kind of hype. Well I would soon find out.

I downloaded the KUBUNTU live cd and after a flawless boot I pushed the install button. Well to be honest the install program is nowhere near the beauty of the SUSE equivalent. But well all it has to do is its job. And it did.
First I was anxious to know if KUBUNTU was able to start an xserver and present me with the standard KDE desktop. Well unlike SUSE it did.
A bit nervous I started Amarok to check if I could play my music collection. Suddenly A window came up. It informed me that KUBUNTU couldn’t play mp3’s out of the box but that it would be glad to correct that for me. I had to push a button. Well unlike SUSE my music played immediately.
Then another window popped up informing me of the availability of a binary driver for my video card. Again I pushed the install button and unlike SUSE it worked.
In less than an hour my system was up and running again.

Sorry to read of your audio problems. Since you have been using SuSE for a long time, I think you MUST know of the major philosophy shift going from SuSE-10.0 to openSUSE-10.1, where it was decided to not directly support proprietary drivers, nor proprietary codecs (nor most proprietary software) in openSUSE. This was mostly implemented in 10.1, but some proprietary apps have managed to “survive” long than others, although they are all being removed from openSUSE as part of this policy. This is because openSUSE is trying hard to follow the open source free software definition of “free”. Proprietary codecs, software, drivers, while possibly free in price (and possibly not free in price) are NOT free per the open software foundation definition, as one is NOT ‘free to copy’ and NOT ‘free to give away’ and NOT ‘free to modify’ and NOT ‘free to give away modified copies’ .

This means the openSUSE community (ie YOU and ME and others like us) are trying hard to make up for this, by implementing ways to make it easier to install proprietary drivers, proprietary codecs, etc … WE (ie YOU and ME and others like us) have not totally succeeded in this, but we are trying.

I myself do NOT like the one-click install (which some users who are trying to make openSUSE easier have implemented). I always recommend users simply add 4 (and only four) repos to their software package manager to update their multimedia. They can add others on an adhoc basis to IF they know they risks and problems that they can encounter. But one click was an effort made to make it easier and many NEW users (of which you are NOT one) find that useful. (I myself do NOT)

I searched for your requests looking for help for you multimedia, as I was ready to be apologetic that your cries for help had been ignored. All I found was this: how to start xserver automatically - openSUSE Forums

I found none asking for multimedia support. I know I could have easily sorted you if you had asked, but you did not.

I’ve been using Linux for 10 years. I still ask for help when I get stumped. Things change, word does not always get around, and even the best (or in my case the not-so-good) users can be stumped. I know for multimedia you would have been sorted.

But no worries. Kbuntu is a good distribution. I have friends who use Kbuntu and Ubuntu and they are happy with that distribution. So enjoy!

I feel your pain. I got the suse 11.0 disk from a magazine. I was making a computer for my 73 year old mother for her birthday. I knew she would like the eye candy of suse and I liked the package manager so I used suse11.0 for her machine. I live a thousand miles away from her so I use vnc to admin her system. Most of the time I don’t have to do anything.

Myself I have been using Slackware from the days you installed with a handful of floppy disks. I have tried other distros but something always brought me back to Slackware. But I wanted to give suse a fair chance. I have run into bugs with the installer. Bugs when you update a kernel from the package manager. And kernels that will not compile that where installed with the package manager but kernels downloaded from kernel.org always compile. I am also having problems with my wireless working properly. It comes up fine if I use yast and the net device setup but ifconfig or networkmanager will not setup the card properly so it doesn’t connect to the access point.

I am working on some other things that are not working correctly and I suspect they were compiled incorrectly. I will download them from source and compile and see if the problems go away. I see that Slackware 12.2 is now out and I am very tempted to bite the bullet and change this over to Slackware again. One more pain in the butt and it’s bye bye eye candy.

> Then another window popped up informing me of the availability of a
> binary driver for my video card. Again I pushed the install button and
> unlike SUSE it worked.
> In less than an hour my system was up and running again.
> **

Short term gratification is nice, just let us know if you are satisfied in
the long term. Seems to be a theme of people bouncing from distro to
distro anytime the waters aren’t completely calm.

Moved to Soapbox,as it’s not a request for help


oh well

I love opensuse 11.1,

I’ve tried the rest, but always stick with the best

Amarok 2 has some problems, but sssssh, the problems aren’t limited to Opensuse, so you’ll have that on ubuntu as well

Opensuse might have a few bugs, but that is what bug reports are for.

sometimes I get the feeling some posts about why the people are leaving a certain distro, if they ever really installed and tried that distro. I get the feeling often it is just people from other distro’s trying to put people off

Opensuse 11.1 installed like a charm for me, and most people, which means the problem is most likely your end, and when that happens, ask for help, and people will help you. thats the great thing about this community, they bend over backwards to help

openSUSE did fine for me.

I actually came to openSUSE from Mandriva, a distro I was rather evangelical about.

The reason was merely because openSUSE was the only distro that I could get dual head monitors working on - and remaining similar to the Mandriva I’m used to (KDE4 and all).

But having changed, openSUSE is much smoother.

Personally I’ve always found *buntu distros to be rather patronising…

It’d be really kool if there’s a 1 click install to get those.

Anyone for a virtual-oldcpu OBS package?

I’m not sure why. I just use what works. If it works then I see nothing wrong with using it. It’s still supported. Still, you have to do what you think is best for you.

I have run (K)Ubuntu. It is easier to set up than openSuse. However, it’s not easier to maintain to me. In my experience updates often break things. Maybe your experiences will be different from mine. I hope so and I wish you luck.

Ya know, openSUSE isn’t perfect. There are things about openSUSE that drive me nuts. Do I go distro hopping? No! Why? As one mentioned above, you have to think long term. Just because the waters are choppy now, doesn’t mean it will be in the future. Besides, a more constructive way to deal with it is filling bug reports, maybe finding work arounds, or patching the code.

I find that to many people do not see this as “their” distro. It really is “your” distro. Even more so since it is a community distro. Ok, so not everyone is a hacker. But it is still “your” distro. You still have a voice and an obligation. Distro hopping doesn’t help anyone.

In my early days, I did my distro hopping to. Some was out of curriosity though. I started on Slackware 7.1. I learned a lot about fdisk, and that I like cfdisk. I learned that I liked gui installers over ncurses. I learned that I hate disk druid, and linuxconf (although I do miss it sometimes). I learned that I do like diskdrake. One of the distros would let you play solitare while installing. I learned that I really hate urpmi (rpmdrake).

In fairness though, I hung with Mandrake longer than any previous distro. From 8.0 to 10.0 beta something. It was then that I switched to SUSE 9.1. It took me a bit to learn SUSE, but I haven’t left. I may still tinker with other distros, but that’s for research purposes. Since I work with smart, it means I have to get into those distros.

For what it’s worth. I installed SUSE 11.1 on my new ( 3 months ) laptop -
Acer 4420-5963
Ati Radeon Graphics x1250
AMD Athlon x2 64x2 processor tk-57
160 GB Hard Drive 2GB memory

it came with Windows Vista installed on a partition ( I don’t understand tech talk unfortunately ) I was told by ACER that this could not be removed. There was no install or recovery disk. They told me to under no circumstances to try and mess around with it, or I would lose all support from them ( not that they give much anyway )

I tried installing Ubuntu on a dual boot, but Windows limited the size of the space alotted to it to 5GB. I use my computer for music and video a lot. ( one of my hobbies ) I couldn’t do anything without running into memory errors. So I looked around, and came across an article on SUSE ( which I honestly had never heard of ) I liked the way it looked, so I burned a DVD and decided to install. Immediately Windows tried to keep it from being installed. Then on the third try I got the " use whole disk" option and decided to go for it. I hate Vista anyway!

Once it booted I knew I liked it. However I had problems, no video would play. No sound would play. I went into the repositories and followed some of the forums suggestions. I got You Tube to play, as well as all my video formats including playing a DVD with VLC. Kaffeine still does not work. My big gripe is I have NO SOUND, nothing at all. Not even basic computer chirps and dings.

So am open to suggestions. I’m not ready to ditch it yet. I have Kubuntu 7.1 on my old PC and have it configured where everything I need works! So I can play around with this thing. It’s really just a toy for me.:expressionless:
Sorry for the long post.

Kenny1948, please start a new thread re: your sound problem. If you piggy back on someone else’s thread, with a different problem, you are not likely to get much help.