why I dont see Windows file system in OpenSuse 11?


i have installed multiboot so I have on one HDD 2 systems. One is opensuse and second is WindowsXp on ntfs.

But the problem is that suse dont want to mount windows file system (ntfs). So the question is how can i load it in suse?

Thx for advises…

Yast > System > Partitioner

Be very careful with this :slight_smile:

What you need to do is create a mount point for your ntfs partiion, select it and then click edit.

In the bottom right, where it says “mount”

create a mount point, for example


You will need to log out and back in for kde to display the mount point in “my computer”

nope it dont works,

its interessting because in all other distros which i tried mounts ntfs file system automatically.

do i have to something install ? like samba server or any support for ntfs?

Try this:

Type in terminal for root:


Then (you can change to whichever directory you’d like):

mkdir /Windows

Then (replace /dev/sda1 to the path of your ntfs partition):

mount -t ntfs /dev/sda1 /Windows

You may have to install “ntfs-3g”, I THINK :stuck_out_tongue:

If you want it to automount, as a non-root user run (kde):

kdesu kwrite /etc/fstab


gnomesu gedit /etc/fstab

then add a line at the bottom:

/dev/sda1        /Windows      auto      defaults     0   0

Save it and reboot.

Hope this helps!

thx guys, this works. Have a nice day.:slight_smile:

hi again

i have mounted windows dtive. but now. I am wondering how can i give permission to no root user?

i tried as root to change group of folder:
“chgrp users windows”
and it gives me:
chgrp: changing group of ‘windows’ : Read-only file system

so any ideas what to do?

and second question is how can i unmout this drive?

ntfs-3g Great little prog !

Why would you want to change the permission to “no root” ? Apart from the fact that I think it will be impossible and rightly so.

To unmount use: umount /dev/xyz