Why does my sound volume default to zero on each restart ?

I use headphones and have an MCP73 sound device; am running OpenSUSE 11.4.

On each restart, I get no sound. I have to go to YAST, Hardware, Sound, Other, Volume.
The ‘Other channels’, Front slider is at 0%. If I slide it up to 100%, my headphones
start working.
At this point the Help text says to press ‘Next’ to save the settings, but there isn’t a
‘Next’ button…just a Cancel and OK. OK keeps the new setting, but apparently doesn’t
save it permanently.

What can I do to avoid having to reset this slider every time ?

Thanks for any hints.

On 08/31/2011 11:16 AM, am577 wrote:
> Thanks for any hints.

hint one: always mention which desktop environment you are using, since
it almost always will impact whether or not you get a correct answer,
like: i will assume you are using KDE4.6.0:

hint two: instead of using YaST, look to your system tray and click on
the speaker looking icon and left click it, then click on the “mixer”
button and set the volume there…

three: then, open Personal Settings - Configure Desktop > System
Administration > Startup and Shutdown > Session Management > On Login
click the “Restore previous session” radio button, and click “Apply”

then, if the selected volume doesn’t persist through a boot you have a
(someway/somehow) broken system…

DD Caveat
openSUSE®, the “German Engineered Automobile” of operating systems!

Sorry, I should have said that I am using Gnome…
I think that means your suggestions won’t do it.


I use KDE and don’t know which mixer is used by GNOME on default, perhaps gamix? In any case, I would presume that this setting should be done at the user level and not through YaST(root). So instead, try adjusting the fader to the preferred level in gamix, log out and back in again and see if it has been stored. Another approach might be to use alsamixergui and proceed the same way.


Are the settings lost upon reboot if you use the ‘amixer’ command (with appropriate arguments set) ?

Note one can also put the appropriate amixer setting in a start up script if worst comes to worst.

I’m off on vacation from early tomorrow morning until mid-September (with mostly no internet access) so I likely won’t be revisiting this thread until then. Tonight is major packing/planning for our vacation!

Good luck with your efforts.

… ps :

man amixer 

gives an good overview of amixer.