why couldn't i connect - specific ESSID!!

running suse 11.1, and laptop has always worked faultlessly with wireless networks. was at a mates the other day about to do some uni work but my laptop just would not connect to the network!! i use knetworkmanager, which found the correct network and asked for a WPA key which i entered correctly. the small gear running in the bottom kept going round, the blue status bar got full (i believe thats upon IP configuring) but it stayed there, then the grey globe came back.

my mate runs windows and said he doesn’t need software to access it…so, how come it didn’t work??? the internet was virgin which i’m not a fan of anyway, but it should still work!


  • thestigm,

never got KNetworkmanager to do anything useful with wireless in KDE4. Use Wicd and be happy.


i use kde 3.5 still (yes i know, i’m old school hehe) but will give it a try. thanks, any other suggestions welcome :slight_smile:

cheers again

just tried wicd on the network i’m on at the moment, it wouldn’t connect unless i had knetworkmanager running and already connected :\ from wicd i could then disconnect and re connect. it just kept saying failed to obtain IP address. incidentally, i’m at uni and knetworkmanager usually displays just one network, but wicd displayed loads of the same network but different channels!


That’s a good one.

So Windows does not need software for connecting to wireless.

Did Bill and Steve hire a billion magic little pixies and on install one is transfered to the machine and does all the magic stuff?

Well, then you are lucky that WICD does not interfere with NWM and that NWM is still able to make the connection.

Using two different mechanisms for the same job at the same time is a very bad idea.

don’t you think that’s being a little silly, you know what i mean, the fact that he did not have to install any specific software such as you often get with the package, usually on a cd. He just used the built in network manager

knetworkmanager works…close the application, open up wcid, try to connect and it won’t obtain IP. close wcid to check if KNM works, still connects fine. close it again, open wcid, still fails, leave it open and then open KNM, it connects fine, and then wcid responds and says i’m connected.

strange. i’ve checked the drivers it’s using and they appear to be correct.

Exactly my point, NetworkManager and the tools for the alternative method with ifup are installed by default and both (of course only one at a time) work fine (not only) here.

The most likely problems are configuration errors by the user or on the AP (i.e. MAC Filter).

No, not strange at all and I already told you the reason for that in my last answer.