why can't i install google chrome?

every time i run the 64bit .rpm file i get an error:

[PK_TMP_DIR|dir:///var/tmp/TmpDir.P7eMir] Repository already exists.

chrome is not currently installed. running kde 4 on suse 11.4, 64bit. i’m having a problem with firefox with web pages with embedded youtube videos. i don’t know how to describe it, all the “buttons” (e.g. play/pauge, volume etc) flicker in white blocks and it’s really weird. anyone else know of this problem? firefox 4 by the way.

thanks for any help!


Can I see your repos?

# zypper lr -d


SUSE Paste

thanks for helping so far :smiley:

Can i see this repo

4 | PK_TMP_DIR                       | PK_TMP_DIR                       | Yes     | Yes     |   99     | plaindir | dir:///var/tmp/TmpDir.12SYtW                                                             |        
# zypper lr 4

And read this Install Google Chrome on OpenSuse 11.3


sorry for the delay, didn’t realise there was a reply:

ross@linux-ej1d:~> zypper lr 4
Alias : PK_TMP_DIR
URI : dir:///var/tmp/TmpDir.12SYtW
Enabled : Yes
Priority : 99
Auto-refresh : On
Keep Packages : Off
Type : plaindir
GPG Check : On
Path Prefix :
Parent Service :
MD Cache Path : /var/cache/zypp/raw/PK_TMP_DIR

i just tried installing it through the command line and seemed to install ok (after i had to install something called lsb)…but it said at the end “NO KEY”

it’s appeared in my menu but when i click on the icon, the bouncing icon by the mouse cursor just keeps bouncing and the programme doesn’t load. went into yast and it then listed chrome as installed, went update and it updated ok but still no success in loading it. i can’t try to open it through command line as i don’t know the command for it…?

thanks :slight_smile:

went into the application icon to find the command, typed this into command line:

ross@linux-ej1d:~> /opt/google/chrome/google-chrome %U
/opt/google/chrome/google-chrome: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Try to run it in terminal
For example

google chome

It is an example and then sellect ENTER.

Yeahh a missing library ok

open your terminal and write

# zypper install libpng12.so.0

Or install through here RPM Search libpng12.so.0

managed to get it working:

typed the above command into console and got libpng error (think you were posting as i was typing it! lol). then went into yast, typed libpng and sure enough that one it tried loading wasn’t installed. installed it and job done.

thanks for your help :smiley: really appreciated. now to see if all the extensions work, embedded videos etc.



I want something for you. Coukd you open your terminal and write

# zypper lr -d

SUSE Paste

i’m wondering what the hell that “PK_TMP_DIR” is. should i delete it?

And a

# zypper refresh

i deleted it before i read this as i couldn’t see the point of it

linux-ej1d:/home/ross # zypper refresh
Repository ‘KDE core updates’ is up to date.
Repository ‘KDE extra’ is up to date.
Repository ‘KDE updated apps’ is up to date.
Repository ‘Updates for openSUSE 11.4 11.4-0’ is up to date.
Repository ‘google-chrome’ is up to date.
Repository ‘packman linux’ is up to date.
Repository ‘openSUSE-11.4-Non-Oss’ is up to date.
Repository ‘openSUSE-11.4-Oss’ is up to date.
All repositories have been refreshed.

seems like everything else is working ok though! thanks!! at least google chrome doesn’t go a bit spastic with embedded videos unlike my firefox :smiley:

however, the latest version of kde is 4.6.2, i’m running 4.6.0 even if i click yast>online update>patterns>KDE desktop environment (and KDE base) and click all in this list > update if newer version available, but nothing updates… ??


I write you now the technique of upgrading, But you must have the correct repos for that.

Firstly go to yast and disable other KDE repos if you have(For example if you have the KDE 4.6.2 repo you must go to yast and disable it)

Open your terminal and write this

# zypper addrepo -f http://download.opensuse.org/repositories/KDE:/Release:/46/openSUSE_11.4/ kde46
# zypper dup --from kde46

When it will finish make a reboot.
That’s all

thank you, it is updating now

Make a

# zypper refresh

I want to see again if updates.

better to carry this on in the other thread :slight_smile:

thanks mate