why can't change background in gnome

I use suse 11.0,but i found a problem with gnome,
the desktop back to the original picture(green one) after reboot computer.I don’t know why.
anyone know this?please help me.

oh,there isn’t this problem when i login with root.:’(

oh,there isn’t this problem when i login with root.:’(
Maybe this is your problem. Have you never been told DON’T do this. SDB:Login as root - openSUSE

Check in the settings to restore previous session.

Oh,thank you,because i usually login as root in fedora 8 before.and there isn’t problem in it,so…
maybe i need to learn more…:shame:

It’s not a good idea on any system, openSUSE or Fedora. I suppose you’ve migrated from Windows at some point, where the default account is an administrator, and most users log into this account for general use. Even MS advises against this though, as it raises many risks. Use “su,” “kdesu,” or “gnomesu” for administrative tasks. It’s never necessary to log into the root desktop.

How are you changing your background? From the Gnome Control Center?