Why are firefox and thunderbird always crashing for me?

I’m trying to figure out why firefox and thunderbird keep crashing on me. I just installed Suse 11.3 64-bit with Gnome 2.30.0. I am using firefox version 3.6.12 and thunderbird version 3.1.6. They crash half of the time when something has to load, such as an attachment or download. Is there anything I can do about this?

So having Mozilla application issues is not normal. It looks like you have the most recent version loaded but I ask that you make sure you have the following repository added to your YaST / Software Repositories:

Index of /repositories/mozilla/openSUSE_11.3

Next, I would run YaST / Software Management and press the view button on the top left and select Repositories and then select the newly added name you gave the Mozilla repository on the left column, and then select “Switch System Packages to the versions of this repository (Mozilla)” in the package window. What this will do is to make sure ALL loaded applications for Mozilla programs comes from the same place and version. I would restart your computer and see if this helps.

Thank You,

I’m running Firefox 3.6.12 from openSUSE repo and never had to use Mozilla repo. In fact, disabling that repo, deinstalling Firefox and reinstalling it from openSUSE repo has already solved similar problems for some people.

**zypper info MozillaFirefox**

Information for package MozillaFirefox:

Repository: @System
Name: MozillaFirefox
Version: 3.6.12-0.7.1
Arch: x86_64
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 3.4 MiB
Summary: Mozilla Firefox Web Browser

  • don’t know about thunderbird though.

hello please_try_again. I think the real problem is mixing versions between repositories. Due to the limited size of the Mozilla Repository, switching to it does not blow up anything else. Doing the same thing with the openSUSE repo might upset the whole apple cart for multimedia, replacing Packman stuff with openSUSE repos. That just means to me switching Firefox and Thuderbird to the openSUSE repo is a manual function, not automatic in any way. How many files must be switched and what are their names? If the problem is mixing versions, then never using the Mozilla repository or switching to using it whole as I suggest is the fix. At least, that is how I see it.

Thank You,

After trying so much(Thunderbir, Kmail…), I switch to Gmail, setting up to receive emails from hotmail e yahoo, thus I just need to keep watching only Gmail, and all messages from other email will appear on Gmail!!

Try Chromium, Opera and even Konqueror(webkit)

Jdmcdaniel3, I did what you said, and now firefox works perfectly. Thanks! I will try the same with thunderbird and report back.

Jdmcdaniel3, I did what you said, and now firefox works perfectly. Thanks! I will try the same with thunderbird and report back.
I love it when a plan comes together with a solution. please_try_again was also correct, but I think my solution is easier to do however. As I said before, the real issue is mixing versions of the same program between repositories. An unintended thing when you have more than the four recommended repositories added and active. Also, don’t be fooled with the ease of switching to an entire repository as it works OK for small ones like Mozilla, but very odd things can occur when you do this with larger ones, even like Packman. So, don’t do it with just any repository unless recommended by someone who knows how it works.

Thank You,

I would add rekonq to that list. It came installed by default on Ubuntu Maverick. So I decided to give it a try under openSUSE (among others). I’ve been using it on that forum for about 2 weeks. Not bad.

Firefox is crashing again, although not nearly as much now. I noticed that it crashes under heavy load. When I have 10 tabs open, or I’m downloading the Suse DVD through firefox is when it crashes.

Thunderbird also crashes under heavy load, such as when I’m opening three different emails simultaneously with multiple pictures attached.

I wonder if this is because I’m using a ramdisk. I have a solid state hard drive, so I have firefox cache stored in /tmp, which is on the ramdisk. I only have 1GB of ram in this laptop. I also have no swap partition. Maybe that’s why it’s crashing…although Gnome system monitor says I’m only using 512 MB of ram when it crashes. I ran memtest and it says my stick of ram is ok.

Thoughts, anyone? Any input is much appreciated. Am I using way too little ram? I was thinking about this this morning and maybe that’s my problem–that I only have 1GB of ram. It’s a core 2 duo laptop though. I noticed that Thunderbird likes to crash when the CPU core that it’s running on hits 99% usage. Hmm…this could be a hardware resource problem. Maybe I’ll get more ram for this laptop.

My fstab:

/dev/disk/by-id/ata-INTEL_SSDSA2M080G2GN_CVPO0161048A080JGN-part1 /                    reiserfs   acl,user_xattr,noatime        1 1
/dev/disk/by-id/ata-INTEL_SSDSA2M080G2GN_CVPO0161048A080JGN-part2 /home                reiserfs   defaults,noatime              1 2
proc                 /proc                proc       defaults,noatime              0 0
sysfs                /sys                 sysfs      noauto,noatime                0 0
debugfs              /sys/kernel/debug    debugfs    noauto,noatime                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5,noatime       0 0

tmpfs /var/log tmpfs defaults,noatime,mode=0755 0 0
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0
tmpfs /var/tmp tmpfs defaults,noatime,mode=1777 0 0

results of df -h

user@linux-oejz:~> df -h                                                                                                                       
Filesystem            Size  Used Avail Use% Mounted on                                                                                         
/dev/sda1              11G  3.4G  6.7G  34% /                                                                                                  
devtmpfs              494M  252K  493M   1% /dev
tmpfs                 495M  664K  494M   1% /dev/shm
/dev/sda2              55G   31G   25G  56% /home
tmpfs                 495M  344K  495M   1% /var/log
tmpfs                 495M   13M  483M   3% /tmp
tmpfs                 495M   24K  495M   1% /var/tmp

Hm, I am not sure whether this is the culprit here, but swap is used in pretty much any session, even when RAM is still available (at least it’s used a little). The behaviour reminds me of the oom-killer (oom = out of memory), a function that will kill processes if no RAM is available. GNOME uses quite an amount of RAM and so do the Mozilla applications… I recommend to have a swap partition on any system, even with 8GB of RAM (doesn’t have to be huge, actually ½GiB of swap should be enough for home desktops).

Hardware could also be the culprit indeed, maybe you should test your cpu and RAM a bit.

I think you’re right about this being an OOM problem. I know that OOM is supposed to only sacrifice one memory-hogging program when the system is critically low on memory. When I have firefox and thunderbird at full throttle, only one of them crashes. So that sounds like OOM.

I think you’re also right that I should have a swap partition. I just didn’t install with one because I’m using an SSD, and I didn’t want to chew it up. I think I will install more ram in the laptop and see what happens. That should probably stop the crashing. I might try using a thumb disk as swap, too, and see if that makes the problem go away. If all else fails, I guess I’ll have to make a swap partition.

With no applications open:

user@linux-oejz:~> free -lm
             total       used       free     shared    buffers     cached
Mem:           989        645        343          0         23        391
Low:           989        645        343
High:            0          0          0
-/+ buffers/cache:        230        758
Swap:            0          0          0

A second before firefox crashes (with multiple tabs open, and two of them playing videos):

user@linux-oejz:~> free -lm
             total       used       free     shared    buffers     cached
Mem:           989        896         92          0         28        460
Low:           989        896         92
High:            0          0          0
-/+ buffers/cache:        407        581
Swap:            0          0          0

I downgraded to the 32-bit version of firefox, with the same version number. The crashing seems to have stopped completely now. It hasn’t crashed since I downgraded, and I have 25 tabs open. It used to crash every two minutes before I switched.

I downgraded thunderbird to the 32-bit version, and that fixed thunderbird as well. I wonder why the 64-bit versions were prone to crashing? I noticed about a 20% slowdown in thunderbird and not much in firefox.

I downgraded thunderbird to the 32-bit version, and that fixed thunderbird as well. I wonder why the 64-bit versions were prone to crashing? I noticed about a 20% slowdown in thunderbird and not much in firefox.
I offer two reasons, no swap file and not enough memory to use 64 bit software. Now the only loss may be some speed and so dropping to 32 is a very good solution. Also, gropiuskalle already picked up on the memory thing before you dropped to 32 bit. It would seem that short of buying more memory, dropping to 32 bit was the answer. I might add though, it is not too late to add a swap partition. Drop some space on an existing partition and create a swap. If you use the YaST Partitioner, it will even add the partition to your fstab file for you.

Thank You,

You might consider a reinstall and choose the entire system to be 32bit this time; 64bit most likely won’t give you any benefits at all. You should definitely add a swap partition as described by jdmcdaniel3.

Just an Advice about Mozilla Softwares and 64 bits based system:

They not intend to keep almost all their brands on near future, them use them in the 32 bits version or buy a mac to use 64 bits based!!

So Alex, Mozilla is going to start making everything 64-bit soon? I might have to upgrade my laptop. I did make a swap file now. Just 2GB.

64-bit builds of FF and TB have been available for ages.

Hypothetically, if I had a system with 8GB of ram, would swap even be used? I mean, 8GB is a lot, and I used to have a desktop with that much. If I recall correctly, I had no swap file, and some KDE tool told me that the ram was never fully utilized. Only 6GB was ever used, maximum.

In my experience it is always used, but mostly only in a very limited way. I have one system with 4GiB of RAM and another with 8GiB of RAM, after a while (at least after a certain uptime like < 8 hours) they both show a bit of swap being used (only a few kilobytes mostly) even when RAM is still available or only buffered. I can not exactly tell you why, though.