Why 3 kernels?


both yast and zypper tried to install the following on this PC
with todays update (manually blocked)
kernel-default 221MB
kernel-pv 223MB
kernel-pv-devel 51MB

not sure why as the selected kernel installed is
kernel-desktop 221MB

is it necessary to have 3 kernels installed for the
nominal installation?

or is this just an anomally with this install?


Kernel: 4.0.4-3-desktop x86_64 (64 bit)
Desktop: KDE 5
Distro: openSUSE 20150606 (x86_64) Tumbleweed

ps. install completed normally as usual.

Normally, it shouldn’t be necessary. I haven’t made this latest update yet as I tend to work from ML archive - which can give a useful delay. :wink:

Looks like it won’t happen here anyway - see this part zypper dup proposal:

        Computing upgrade... 

The following NEW package is going to be installed:
  kernel-desktop  4.0.4-3.1 

The following 92 packages are going to be upgraded:
  frameworkintegration-plugin          5.10.0-1.1 -> 5.10.0-1.2           
  java-1_8_0-openjdk          ->       
  java-1_8_0-openjdk-headless ->       
  kwin5                                5.3.1-1.1 -> 5.3.1-1.2             
  libKF5Style5                         5.10.0-1.1 -> 5.10.0-1.2           
  libQt5CLucene5                       5.4.1-1.1 -> 5.4.2-1.1             
  libQt5Concurrent5                    5.4.1-4.1 -> 5.4.2-1.1             
  libQt5Core5                          5.4.1-4.1 -> 5.4.2-1.1

  x11                20150603-1.1 -> 20150603-1.2 
  x11_opt            20150603-1.1 -> 20150603-1.2 
  yast2_basis        20150603-1.1 -> 20150603-1.2 

The following product is going to be upgraded:
  openSUSE Tumbleweed  20150605-0 -> 20150606-0 

92 packages to upgrade, 1 new. 
Overall download size: 127.5 MiB. Already cached: 0 B  After the operation,  
additional 220.9 MiB will be used.


I suspect the cause lies somewhere on your system.

Hi consused,

correct, I’d forgotten that some development packets were already installed

with only the desktop kernel installed the update only pulls in that update and
nothing else

thx for the feedback


Hi, glad you found them. Thought it would be something like that, especially with kernel-default involved.

My update went smoothly, but for the first time after reboot I had no sound in headphones, built-in speakers were ok. Not sure what fixed it after Yast sound tested, and KMix closed/reopened. Probably the latter as KMix was listed for upgrade.