White sceen on logging into Gnome


I did a clean install of openSUSE 12.3. I am able to login and use KDE4. However when i login to Gnome, all i see is a white screen and nothing else. I have to do a Ctl- Alt - Backspace to get back to the login screen. Initially i thought this was an issue with the install, but i am able to use Gnome if i login as root. So, i know it is not an issue with the install, it has to do with non-root users.

Is anyone else facing the same issue? I updated the driver to use Nvidia’s proprietary driver from the Nvidia repository. Is this the reason why Gnome is unusable? I was able to use both the desktops in 12.2.

BTW, my graphics card is an Nvidia 9700M GT.

Any help would be appreciated.

On 03/15/2013 06:36 PM, Aakhunaten wrote:
> i am able to use Gnome if i login as root

i can’t with your white screen problem, but i can offer this:

you should never log into KDE/GNOME/LXDE/Xfce or any other *nix-like
system’s graphical user interface desktop environment as root…

doing so 1) opens you up to several different security problems if
you (for example) browse the net, 2) too many, far too easy ways to
damage your system no matter how careful your actions (for
example: cases of unintended change of ownership of some files from
user to root sometimes occurs which can preclude logging in as the
user), 3) anyway logging into KDE/etc as root is never
required to do any or all administrative duties, 4) and, not even
logging in as root just to see if it works as root is useful, because
the “yes” or “no” learned is almost always totally useless
in finding the problem giving the symptoms…while, logging into the
GUI as root to learn the yes/no could cause the next adverse
symptom encountered.

so, always log in as yourself, and “become root” by using a root
powered application (like YaST, File Manager Superuser Mode) or using
“su -”, sudo, kdesu, or gnomesu in a terminal to launch whatever tool
is needed (like KWrite or gedit to edit a config file)…read more on
all that here:

su or su - ??? http://tinyurl.com/665h5ek

additionally: after logging into KDE/Gnome/etc as root, if you
experience problems (for example, with uncommanded file ownership and
permissions changes) and if you can provide us with details of what
you were doing while you were logged in as root, that would help us
identify if there’s a bug that needs to be fixed…thanks for your help…

openSUSE®, the “German Engineered Automobile” of operating systems!

Did we try booting from safe mode ?

@dd : Thanks for your note. I am aware of the risks of using root login from desktop environments. I failed to mention that i logged into Gnome as root to check and see if it works and it did. I have my own user that i use for my regular use.

@vazhavandan : I havent tried it but i have a feeling this is a Nvidia incompatibility issue - there is another user who has posted a similar issue who also uses Nvidia’s propriety drivers.

On 03/15/2013 09:46 PM, Aakhunaten wrote:
> i logged into Gnome as root to check and see if it works and it did

which you should not do because:
-knowing it works as root in no way helps solve this problem…
-adds no useful knowledge to anyone trying to fix this problem…
-could do damage which makes this problem worse…
-could cause a new problem…
-a previous instance might be the cause of the current problem…


I have exact same problem, with latest nvidia drivers and gnomeshell on opensuse 12.3, any help would be appreciated regarding this problem and trolling about root security well … doesn’t solve it but thank you for that reminder anyway .

I have a nvidia geforce GTX 550 Ti

Please ensure that the users are added to “video” group through YaSt==>user==>Edit==>Details Tab==>Additional Groups==>Check Video==>Save==>restart

Thank you. This worked for me.

You are welcome