White Flash of Death (How to troubleshoot full system crash?)

Hi all,

OpenSuse newcomer here… I’m hoping to get some help troubleshooting a system crash on Leap 42.2. I’m getting a complete system crash (on two different systems). What happens is, about once day, I’ll be doing something (anything, terminal, editor, browsing, etc.), and suddenly the screen will flash white briefly then all graphics activity is frozen and the computer is unresponsive to my mouse and keyboard. A forced shutdown is the only thing that lets me recover.

The interesting thing is that this happens both on my laptop and desktop machines, with different Intel CPUs, motherboards, graphics cards, etc.

I’m no stranger to Linux, however my skills at system administration and troubleshooting are somewhat limited. How can I troubleshoot this to get more information after the crash happens? What log files would be good to look at after rebooting?

Any tips would be greatly appreciated.

Some things I’ve tried:

  • I installed bumblebee and disabled the nvidia graphics (using the built-in cpu graphics), no change
  • I’ve been running without a swap file for a while, so I tried adding a swap file and that had no effect (I’m running 32GB RAM, and at the last crash, I was only using about 6GB anyway)

I have VirtualBox and Docker installed, if that matters. I also use IntelliJ IDEA frequently for programming.

I did try Tumbleweed for a while, and it ran very solidly actually. I don’t remember any full-system crashes at all on TW. Ironically, I installed Leap because I thought it might be more stable than Tumbleweed, even though I never had any issues with Tumbleweed. :wink: I’d like to avoid going back to Tumbleweed though… it’s on my work laptop and a rolling distro seems risky to me.