White blocks under window title area on certain applications

Hi all,

I’m a new user of openSUSE, been really impressed with it so far, but recently I’ve came across a weird occurrence that seems to happen with certain applications.

The link to the screenshot below is an example of what I am referring to in the thread title:

Screenshot of Aptana Studio 2.0 (on KDE)

As you can see there is a white block under the window title that appears on the toolbar of Aptana Studio 2.0.

This also happens on other programs such as PgAdminIII.

I was wondering what is causing the above display issue and if there is anything that can be done to fix it?



openSUSE Version: 11.4
**KDE Version: **4.6.0 Release 6

seeing this is your first post: -=welcome=- to the forum!

white junk: i guess it is probably one of these things, and fixable:

desktop effects on: turn that off and see if the defects go away

chosen theme: maybe a different theme won’t have that problem

note: in either of the cases above you are seeing a symptom. the
problem is probably solved next:

graphics driver: if running the default driver, see “openSUSE Graphic
Card Practical Theory Guide for Users” <http://tinyurl.com/37v9y7m>
and move to the better driver…

if you need help with any of that, holler (but there are plenty of
bread crumbs findable with a search engine, within these fora)…

when you post again: always include info like the operating system,
desktop environment and version numbers for each…(the photo was a
great include!! from it i could guess some recent openSUSE and KDE)

again, welcome.

Have a lot of fun.

CAVEAT: http://is.gd/bpoMD
Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

Hi DenverD,

Thanks for you reply.

Sorry for not providing enough information. I will add the missing details below, (I’d posted my KDE and openSUSE version as a reply but didn’t see your reply as I must of posted it just after you had replied!:

Graphics Driver: nVidia (Proprietary) Latest version through the one click easy option on the openSUSE wiki.
Theme: Oxygen (Default) for all window decorations and such, but using a theme called elegant for Desktop.

I’ll check out my desktop effects and the areas you described.

Thank you,


I managed to fix the problem, it looks like it was a problem with my nVidia graphics drivers.

Browsing around the forums it looks like the 260.xx drivers are problematic with openSUSE, so I decided that I would install the nVidia graphics driver “the hard way” manually using the .run script. Another thread on the SUSE forums pointed me to the 270.xx drivers:


So I installed the above driver version and wouldn’t you know it, problem solved no more white blocks in random places!

Going to the 270.30 driver also fixed my nvidia-settings which now runs where as before it would echo “Floating point exception” when ran in konsole

Thank you DenverD for pointing me in the right direction and helping me solve a few bugs which have been getting at me for days!

On 04/03/2011 10:36 AM, jmwhite19 wrote:
> Thank you DenverD for pointing me in the right direction!

you are welcome sir…

and THANK YOU for coming back and posting a clear how to solve this
problem (which i reckon someone will google in and find–so, YOU are
helping others, also!)

CAVEAT: http://is.gd/bpoMD
Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

Hi I was updating SUSE today and came across one update that stated it fixed the white rectangle appearing under the title of applications, the bug report is here:


Looks like I had this bug. Though I’d already installed a different version of the nVidia Proprietary driver to fix it.

Hope that helps people.

On 04/06/2011 10:36 PM, jmwhite19 wrote:
> Hope that helps people.

thank you for updating this thread…

CAVEAT: http://is.gd/bpoMD [NNTP via openSUSE 11.3 + KDE4.5.5 +
Thunderbird3.1.8] Can you believe it? This guy Ralph wins $181 million
in the lottery last Wednesday, and then finds the love of his life just
2 days later. Talk about LUCK!