White Background on Desktop

I installed tumbleweed using gnome desktop. It seems when I use the tweak tool to enable the desktop icons (DESKTOP) on the desktop the background disappears and turns white. If you disable the icons on the tweak tool the background returns. Is this the new behavior of the desktop or a bug?

Leap 42.1 does not have this problem

quite weird, I’ve just tried doing what you did, and on my installation it works as expected

do you have everything up to date on your system?

I installed the latest Tumbleweed 6/13/16. I updated to the latest. I just go to the tweak tool->Desktop and turn on the icons. The background goes white. turn it off everything back to normal. I believe I am using the free ati drivers. It is runs on A10 7300

I doubt it’s a driver’s problem, and the opensource drivers for AMD should work fine on your system. anyway let’s try a few things:

  1. go to a terminal and run:
gsettings set org.gnome.settings-daemon.plugins.background active true

and restart the session and try again.

  1. if that didn’t work, what happens if you turn on the icons and restart the session?

  2. changing the gtk3 theme affects anything?

the gsetting seems to have fixed that problem. However tweak now takes a long time to come up. I guess that is a tradeoff I have to live with.

that’s a very strange side effect, maybe it’s having a little trouble reading the gsetting overwrite.