Which xine plugins does kaffeine 0.8.7 need in openSUSE 11?

I updated from SUSE 10.1 to openSUSE 11.0 and have not been able to use Kaffeine with Xine.
Settings → xine Engine Parameters
gives the error message:
“Loading of player part ‘XinePart’ failed
All Video Drivers failed to initialize!”
I have tried openSUSE Kaffeine 0.8.6 and 0.8.7
and Packman Kaffeine 0.8.7, all x86_64;
with openSUSE xine-lib 1.1.12 and Packman libxine1 1.1.15, also x86_64.
Running kaffeine --verbose reveals that kaffeine is trying to use plugins from /opt/kde3/lib/xine/plugins/1.0.0

~> kaffeine --verbose
/dev/dvb/adapter0/frontend0 : opened ( DST DVB-T )
0 EPG plugins loaded for device 0:0.
Loaded epg data : 2 events (0 msecs)
~> load_plugins: skipping unreadable plugin directory /home/leopardi/.xine/plugins.
load_plugins: plugin /opt/kde3/lib/xine/plugins/1.0.0/xineplug_vo_out_xshm.so found

The directory /opt/kde3/lib/xine is not owned by any package. If I change its name to xine.old then kaffeine does this:

~> kaffeine --verbose
/dev/dvb/adapter0/frontend0 : opened ( DST DVB-T )
0 EPG plugins loaded for device 0:0.
Loaded epg data : 2 events (1 msecs)
~> load_plugins: skipping unreadable plugin directory /home/leopardi/.xine/plugins.
load_plugins: skipping unreadable plugin directory /opt/kde3/lib/xine/plugins/1.0.0.
xine_exit: bye!

I noticed that xine-lib owns the directory

~> rpm -q -f /usr/lib64/xine/plugins/1.21

If I link /opt/kde3/lib/xine to /usr/lib64/xine then kaffeine gives the same result.

Checking /opt/kde3/share/apps/kaffeine I see the line:
/opt/kde3/share/apps/kaffeine/xine_part.rc:<kpartgui name=“xine_part” version=“21”>

If I try ln -s /usr/lib64/xine/plugins/1.21 /opt/kde3/lib/xine/plugins/1.0.0
then kaffeine crashes:

~> kaffeine --verbose
/dev/dvb/adapter0/frontend0 : opened ( DST DVB-T )
0 EPG plugins loaded for device 0:0.
Loaded epg data : 2 events (0 msecs)
~> load_plugins: skipping unreadable plugin directory /home/leopardi/.xine/plugins.
load_plugins: plugin /opt/kde3/lib/xine/plugins/1.0.0/xineplug_vo_out_xshm.so found
load_plugins: ignoring plugin xshm, wrong iface version 21 (should be 20)
load_plugins: plugin /opt/kde3/lib/xine/plugins/1.0.0/xineplug_vo_out_xshm.so found
load_plugins: ignoring plugin xshm, wrong iface version 21 (should be 20)

load_plugins: plugin /opt/kde3/lib/xine/plugins/1.0.0/xineplug_vo_out_sdl.so found
load_plugins: ignoring plugin sdl, wrong iface version 21 (should be 20)
load_plugins: plugin /opt/kde3/lib/xine/plugins/1.0.0/xineplug_inp_cdda.so found
load_plugins: ignoring plugin CD, wrong iface version 17 (should be 15)
load_plugins: plugin /opt/kde3/lib/xine/plugins/1.0.0/xineplug_decode_vorbis.so found
KCrash: Application ‘kaffeine’ crashing…

What configuration files do I need to change where so that the versions match?
Do I need to downgrade Kaffeine? Do I need to upgrade xine-lib? How?

You tried the 1-click multimedia install boogie ? Have a look here Restricted Formats/11.0 - openSUSE-Community


I recommend you using packman packaged applications for your multimedia, and as much as possible ONLY packman packaged applications (with the exception of libdvdcss2).

So the first thing I recommend you do is setup your software repositories to make software installation a breeze. Setup with 4 repositories: OSS, Non-OSS, Update and Packman, and ONLY those 4. You can find guidance here on how to do that: Repositories/11.0 - openSUSE-Community Again add ONLY OSS, Non-OSS, Update and Packman, and ONLY those 4. No others. None. If you MUST, for some reason, obtain software from another repository, then add that repository on a temporary basis, install the software you need, and remove the repository. With the zypper command and cut-and-paste one can add and remove repositories in a handful of seconds.

Now, once your repositories are setup, you can install the packman packaged version of xine (called “libxine1”). First remove xine-lib (packaged by Novell/SuSE-GmbH) and install libxine1 from packman. I also recommend you install libffmpeg0 from Packman (NOT the videolan version). libffmpeg0 provides most of the codecs you need.

After you are done, test your audio/video. If you still have no success, then post here the output of copying and pasting the following into a konsole as a regular user:

rpm -q kaffeine libffmpeg0 libxine1 w32codec-all xine-ui libxine1-w32dll libquicktime0

For multimedia playback you would need to uninstall the included xine library and kaffeine, logout & login, install xine from packman, reinstall kaffeine afterwards. If the problem persists, try moving .kde to .kde.old and cycle out/in.

Also, did you do an in place update from 10.1? From 10.1->10.2->10.3 causes enough problems. Upgrading from 10.1->11.0, that is asking for trouble as all the libraries, many of the configuration files, and most of the base programs are different. A clean install avoids these mismatch issues, though after enough uninstall/reinstall cycles you will have cleaned out the most obvious problems.

to oldcpu:
I already had the repositories set up. I said in my original post that I have already tried the Packman versions of both Kaffeine and libxine1.

> rpm -q kaffeine libffmpeg0 libxine1 w32codec-all xine-ui libxine1-w32dll libquicktime0
package xine-ui is not installed
package libxine1-w32dll is not installed
package libquicktime0 is not installed

Do I need to have xine-ui, libxine1-w32dll and libquicktime0 installed in order to use DVB-T with Kaffeine? Why?

To Andy,
I tried the 1-click install, but it gave me some conflicts, so I only installed some of the stuff.

And that quote is your problem.

You have a videolan packaged libffmpeg0.

That is not compatible with the Packman players. You need to install the Packman packaged libffmpeg0.

OK, short of erasing my hard disk and starting again, I’ve done everything asked of me. I still have the same problem with
“Loading of player part ‘XinePart’ failed
All Video Drivers failed to initialize!”

My next step seems to be to start again from scratch, preferably on a different computer.

to oldcpu:
I only had libffmpeg0- installed from videolan because I followed deltaflyer44’s suggestion to use the “1-click multimedia install boogie”. I didn’t have it installed previously.

I changed the package to the Packman one and still have the same problem. Why were you so sure that was the cause of my problem? Are you a maintainer of Kaffeine or of xine-lib?

leopardi, if you only want the maintainers to help you, then I seriously doubt you will find them here. If you don’t want my suggestions, then please advise. I won’t waste your time.

Reference your question about why I recommended xine-ui, libxine1-w32dll and libquicktime0, it is so I can get a better assessment as to what players and codecs you have installed and improve my recommendations. I like to reduce the amount of speculation in my recommendations, and hence that sort of information is useful.

Typically kaffeine uses the xine engine. To test if that engine is working properly, one needs the xine-ui (where “ui” means user interface) to test if xine is the problem, or if kaffeine is the problem. Hence my curiousity if xine-ui was available to do such a test. It is not, so I can not recommend such a test. … and it appears (from reading further) that your problem is not kaffeine working with xine, … but rather your problem is related to kaffeine compatibility with a very specific function …

Now, reference libxine1-w32dll, … if you have w32codec-all installed (and I don’t know what you have installed, so I am FORCED to guess and speculate) , then libxine1-w32dll should allow you access to those codecs (as opposed to only using the libffmpeg0 codecs). As for libquicktime, it was not (and it is still not) clear to me what the codec is of what you are trying to open/play, although I am beginning to see now that both your title and first post were very misleading as to what you were trying to achieve.

In fact, it was only in this last post, that you made it clear that you wish to "in order to use DVB-T with Kaffeine? ". I guess you felt that was not important originally as your original complaint was “have not been able to use Kaffeine with Xine” … I believe we have solved that.

But it appears now that was not the problem you want solved. You need to be really clear in asking what you want.

Good luck with your efforts. Maybe someone else can see what you are precisely looking for (based on your posts), where I have failed.

As opposed to testing kaffeine by trying to use DVB-T with Kaffeine, try a more simple test (in line with the general nature of your quoted statement).

Select an avi file (maybe try some common different codecs) and maybe an mpeg file. Now that you have the proper libffmpeg0 (from packman) those should work. IMHO getting kaffeine to work with DVB-T (Digital Video Broadcasting) is a completely different kettle of fish, and you need to make it clear that:
a. kaffeine works nominally in non DVB-T use, but
b. does not work in DVB-T use.

Note if you want detailed kaffeine support, then the kaffeine forum may also be a good place to start.Kaffeine Forum :: Index

… the best we can do here on our openSUSE forum is ensure your setup with kaffeine is setup properly (and it is NOT setup properly imho with the videolan libffmpeg0). The one-click install does NOT do a good job in this case (where one previous has videolan in their repos, where having videolan as a repos is IMHO not a good idea at present time ).

Hello, old cpu is one of the most knowledgable folks in here. i have learned so much from him and delta if anyone can help those two would be first.

to correctly configure kaffiene, may i suggest to go to yast and update the packman and videolan repositories, once in a while the old files will download instead of the updated versions,this has happened to me on several laptops. then (first) install win32 codecsall.have yast install libxine1 and make sure you uninstall the old versions first. then install libdvdcss for whatever reason in this order seems to make a difference. but as i said make sure you uninstall the older versions first,it seems to create a conflict for some reason. this worked for me. it might for you.
good luck.

Hello oldCPU,

having read your posts carefully and followed exact the steps I end up with Kaffeine playing a DVD. But no pictures, just sound…

The command above gives me:


(using 11.0 fresh install, kde 4.1 )

what else can I try?

(i got some minor problems as well, like my mousepad doesn’t react on tapping; but I think they have different reasons… )

Just want to watch some DVDs…

That looks to be pretty good, but for a video dvd, if it is commercial DVD, then the DVD is often encrypted. Hence you need an application to decrypt it. Go to this link here and install libdvdcss2 (in particular send the one command that is in “black background with white print” ) Restricted Formats/10.2 - openSUSE-Community
Note libdvdcss2 is openSUSE version independant.

Also ensure you have libdvdread3 installed (I think that comes with openSUSE). http://packages.opensuse-community.org/index.jsp?distro=openSUSE_110&searchTerm=libdvdread3

I don’t think I can help with that. You may need a package called synaptic (or something like that) or it may be another package.

Thanks oldCPU for that very fast answer.

I removed libdvdcss and installed libdvdcss2 with the named command.
All went well (it shows up in yast…)

Libdvdread3 was already installed…

But no change:
Again it plays the DVD with sound but without any pictures…

I didn’t expect even an answer to my little touchpad problem…
It was just ment to indicate, that i got some problems, in case the “normal way” wouldn’t apply to my case…

Any more ideas?

Apart from that: Thank you!

It could be the DVD is very new, and libdvdcss2 does not handle the encryption.

Can you try some older DVDs?

Also, try running kaffeine from a konsole / gnome-terminal, and then play the DVD and see if you get any errors.

Alternatively, try vlc and/or smplayer (also packaged by Packman) and see if they have better luck.

well, nono of this worked either.

Tried all players, but still the same:
Audio works well, but no pictures.

Starting kaffeine from a console shows no error. It seems to be ok.
(Kaffeine finds all plugins, loads them succesfuly …)

And the DVD i treid to play, did all work in 10.3 …

Just no pictures…

Thank you anyway…

What output video modules do you have selected on those players that you tried? Please post that exact precise info for each player: ie x11 for vlc, x11 for xine, x11 for smplayer … or whatever …

What video graphics hardware do you have? Open a konsole and type:su -c 'sax2 -p’and post output here

In addition to the above, in the same konsole, please also copy and paste the following (and post here the output):
grep -i driver /etc/X11/xorg.conf