Which was the last kernel with support for intel i740?


After reading a lot and installing, every mayor distro to my PC (opensuse, ubuntu, mint, fedora, mandriva, etc.) i still get a maximum display resolution of 800x600 no matter what i do; I tryed disabling KMS, nomodeset, changing drivers, and the list goes on and on, finally I got information that the newer linux kernels doesnt support this chipset anymore(¿? or what ever is this i740 thing) i red about this in a ubuntu forum and i also got the same at an arch forum.

If i use puppy linux everithing is ok, also i have a knoppix livecd an old one with kde 3 that works fine, so i guess it is the kernel right?, my questions are:

1.- Can I downgrade the opensuse 11.3 default kernel to the last kernel that supported i740? will everithing be ok or not? and if so how should i do it? i dont know anything about compiling from source, but ive heard is not htat difficult, this could be the time to learn lol!

2.- if the above is imposible wich linux distro ships with a compatible kernel for me and if posibly with kde 3.5? puupy linux is great, but i still rather prefer something more “K” Is this posible because i believe knoppix for exaple now ships with lxde coz kde 3 is dead now :’( it doesnt matter is not the latest version of the distro for example my knoppix runs fine it is version 5.something, is 6.x still compatible for me? i know this 2nd question is off topic but i cant find anything in google shurely because i dont know what to look for anymore!

thanks for your help in andvance and sorry for my english!!!

finally I got information that the newer linux kernels doesnt support this chipset anymore(¿? or what ever is this i740 thing)

Its your aging grahics card thats no longer supported by the intel driver, leaving you with only the basic vesa (or fbdev) drivers which don’t provide higher resolutions or grahips acceleration etc.

Can I downgrade the opensuse 11.3 default kernel to the last kernel that supported i740?

Not possible. It would break installed libraries and hardware drivers that depend on it.

You could consider puchasing a replacement graphics card card (nvidia or ati) to breather new life into your PC.

As a quality check, what drivers are you using to get the 800x600 ? and what drivers did you try ? I assume you tried both Intel and FBDEV. Did you try intellegacy driver?

Hmm … looking into this further I don’t think my speculation wrt trying intellegacy driver is any good. When I type “man intellegacy” I get:

       intel supports the i810, i810-DC100, i810e, i815, i830M,  845G,  852GM,
       855GM,  865G,  915G,  915GM,  945G,  945GM,  965G,  965Q, 946GZ, 965GM,
       945GME, G33, Q33, Q35, G35, GM45, G45, Q45, G43 and G41 chipsets.

which says nothing about your hardware.

This is incomparison to the Intel driver, where if one types “man intel” one gets:

       intel supports the i810, i810-DC100, i810e, i815, i830M,  845G,  852GM,
       855GM,  865G,  915G,  915GM,  945G,  945GM,  965G,  965Q, 946GZ, 965GM,
       945GME, G33, Q33, Q35, G35, GM45, G45,  Q45,  G43,  G41  chipsets,  and
       Pineview-M in Atom N400 series, Pineview-D in Atom D400/D500 series.

Hence I share the view of deano_ferrari and it does not look good for your PC.

… still, … not wanting to give up ‘just yet’, … did you try the i740 driver? Type “man i740” and what do you get ?

Did you try put ‘i740’ in your 50-device.conf file ? (just a wild speculative guess). Is that wild suggestion enough to try, or do you need more help. Apologies as I feel darned if I do and darned if I don’t wrt guessing your knowledge level.

Note when I type (on a 32-bit openSUSE-11.3 system):

rpm -qi xorg-x11-driver-video -l

I note included with the ‘xorg-x11-driver-video’ rpm is the package:


which suggests to me the i740 driver IS included.

Hence you need to try that. Edit: and if it is the i740 driver that you specified in a 50-device.conf file and it gives you the 800x600 then I apologize for wasting your time. I confess it was not clear to me.

Hi IsmaelVC, sorry for being so slow on this, but I only noticed this morning this thread of yours: How to disable KMS???

From that it appears to me that your i740 was already recognized and it is being used. At least it was for that post.

Hence before we conclude this is kernel problem (keeping you at 800x600) can you please provide the following information so we can confirm your assessment (or my assessment that the i740 may still be tuned to work) … Please provide us with the content of your /var/log/Xorg.0.log file (when you have the i740 driver loading) and also the content of your /home/your-user-name/.xsession-errors file.

Please do NOT post those files directly here. Instead open them up with a text editor, and ONE AT A TIME copy each of their contents to the web site Pastebin.com](http://pastebin.com) and press ‘submit’ on that web site (again one at a time). Then in each case, post here the URL/Website-address that will give you. That is so that we can look at the contents and make an assessment as to the best way forward. For example its possible the EDID of your monitor is not being identified, or it could be some other problem.

I see Ubuntu believe this to be an upstream problem:
… but when I look at the Xorg.0.log files in that bug report, its not clear to me the monitor was ever identified properly … or am I missing that?

Your best bet for checking old kernels may be to try a liveCD (assuming your old PC has suffient memory to run a liveCD). For example, you can still obtain the official liveCDs for

OMG! thank you so much for your support mr. deano_ferrari and mr. oldpc,

I’ll try right away to do evrething you say, my hardware is recognized as i740, but in the 50-device.conf file it says “radeon”, I tried changing it to “intellegacy”, I didnt triy with “intel” but i guess is not going to work, so first off I’ll try changing it to “i740”, after that i’ll share the log files as you said,

and yes I started downloading opensuse 11.1 kde 3 unofficial from Carlos, just one question if the live-cd doesnt load can I install it with the 11.1 DVD, doest it install kde 3 too or just kde4, the thing is that my pc uses very old RAM memory types and I cant find anywhere anotherone compatible, whenever I ask, the vendors just smile at my naiveness, and I even went to a market were you can sometimes find old pc parts… mostly junk, but still havent had any luck. (the same happens with 11.3 it doesnt load live cd but installs well with dvd and it works so well, except for the screen resolution, that Im starting to get used to hehe) I know maybe I ask for too much with my old pc hehe but I really want to learn more about linux and believe me Im learning everyday something new, so it would be some sort of achievement for me if I can finally get this thing working lol

I’ll post the logs latter or tomorrow as I have to go to work

thanks again and greetings from Mexico!!!

Also right now im upgrading to kde 4.5 even 800x600 wont stop me to test it, hope nothing goes wrong in the upgrade while im at work :stuck_out_tongue:

If I recall correctly, the 11.1 DVD gives you a choice of Gnome, KDE4, or other. Select ‘other’ and you will find KDE3. Same version as on the 11.1 liveCD by Carlos.

Ok Im sorry it took me so long :shame:

Here is my Xorg.0.log file:

18.859] X.Org X Server - 50-device.conf - PHZVfXuH - Pastebin.com](http://pastebin.com/PHZVfXuH)

Here is the .xsession-errors:

/etc/X11/xim: Checking whether - 50-device.conf - 90vdr30p - Pastebin.com

And here is my 50-device.conf:

Section “Device” Identifier - 50-device.conf - FHZkLdft - Pastebin.com

Is my 50-device.conf correct? or should I remove the “#” like this:

Driver "i740"

instead of:

#Driver “i740”

I really dont know because in the puppy editor the entire font color is red which I guess it means that everything is being interpreted, in contrast to my puppy xorg.conf in which every line with a “#” at the begining is in grey and the rest in red, so I believe is like in Ubuntu, maybe opensuse is different and the # doesnt mathers in this case? or is it an exception? I really dont know…

And the thing is I have used both with and without the # and nothing happens, it must be something else, because I was just thinking it can’t be the kernnel as puppy 5.0.1 runs fine and has a newer kernnel than let say… Ubuntu 8.04 which stays at 800x600 like most distros ive tried on this machine maybe it is another configuration I have to tweak, It makes me think openSUSE 11.3 really should be able to handle the i740 becuse “man i740” shows me the manual of the driver I’ll upload it also because it has some optons for the driver butn I don’t know how to use them, here it is:

I740(4) - Manual - DQ1g3aeq - Pastebin.com

Does having this file, means I have installed the driver? I do not know :stuck_out_tongue:

Maybe I have to change an option like changing SGRAM or SDRAM? because it wan not detected properly???

I’m totaly lost :frowning:

Thanks again for your help!!! lol!

The ‘#’ character is a comment character, used to precede comments, so that in this case the option is ignored (not used).

You can use the modprobe command to list available modules. The following command will show if the driver is available:

/sbin/modprobe -l |grep i740

Thanks. That suggests the i740 is being loaded, but its having problems.

I note these entries:

467.    19.532] (II) I740(0): Default Monitor: Using default hsync range of 31.50-37.90 kHz
468.    19.532] (II) I740(0): Default Monitor: Using default vrefresh range of 50.00-70.00 Hz
469.    19.532] (WW) I740(0): Unable to estimate virtual size
489.    19.533] (II) I740(0): Not using default mode "1024x768i" (bad mode clock/interlace/doublescan)
497.    19.533] (II) I740(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)

hence with only the following being setup:

547.    19.534] (--) I740(0): Virtual size is 800x600 (pitch 800)
548.    19.534] (**) I740(0): *Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
549.    19.534] (II) I740(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
550.    19.534] (**) I740(0): *Default mode "800x600": 36.0 MHz, 35.2 kHz, 56.2 Hz
551.    19.534] (II) I740(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
552.    19.534] (**) I740(0): *Default mode "640x480": 25.2 MHz, 31.5 kHz, 59.9 Hz
553.    19.534] (II) I740(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
554.    19.534] (**) I740(0): *Default mode "400x300": 20.0 MHz, 37.9 kHz, 60.3 Hz (D)
555.    19.534] (II) I740(0): Modeline "400x300"x60.3   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz)
556.    19.534] (**) I740(0): *Default mode "400x300": 18.0 MHz, 35.2 kHz, 56.3 Hz (D)
557.    19.534] (II) I740(0): Modeline "400x300"x56.3   18.00  400 412 448 512  300 300 301 312 doublescan +hsync +vsync (35.2 kHz)
558.    19.534] (**) I740(0): *Default mode "320x240": 12.6 MHz, 31.5 kHz, 60.1 Hz (D)
559.    19.534] (II) I740(0): Modeline "320x240"x60.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz) 

Reference your 50-device.conf :

As deano_ferrai noted, definitely remove the " # " ie so that it looks like:

Section "Device"
  Identifier "Default Device"
  Driver "i740"
  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

I’ll look at the rest when I get the chance.

… are you saying you get the proper resolution with the latest Puppy Linux ?

If you have this working with the latest puppy linux, can you advise which kernel that Puppy Linux has ? Which version of xorg? mesa? Also, what is the content of Puppy Linux files in /etc/X11/xorg.conf.d/ such as 50-device.conf ? Does Puppy have an /etc/X11/xorg.conf files ?

SOLVED!!! yeeeyyy

I found information in the spanish forum here and here:

Google Traductor

Google Traductor

I have used google translate on this pages, hope they are uderstandable.

so I changed my 50-device.conf
Section “Device” Identifier - Anonymous - JAHBgT2F - Pastebin.com

and my 50-screen.conf
Section “Screen” Identifier - Anonymous - rCqpTjkK - Pastebin.com

now i would only like to figure out how to change the vertical to 75Hz

I’ll post later puppy files if you still need to, but I have to go for now htanks again

Well done !

Glad to read its not a complete kernel limitation, but possibly only an autoconfig hindrance.

I confess to now having a bit of curiosity now as to what your /var/log/Xorg.0.log file looks like now.

deleted …

This was also interesting to read in the 50-device.conf

      Section "Device"
        Identifier "Device 0"

         VendorName "Intel"
         BoardName  "i740"
         Driver "i740"
         Option     "UseEdidFreqs" "false"
        ## Required magic for radeon/radeonhd drivers; output name
        ## (here: "DVI-0") can be figured out via 'xrandr -q'
        #Option "monitor-DVI-0" "Default Monitor"

Thank you so much again!

Here it is the new “Xorg.0.log”:

24.774] X.Org X Server - New Xorg.0.log - xBGCD1j8 - Pastebin.com](http://pastebin.com/xBGCD1j8)

I can share the Xorg.conf of puppy I have on my computer If you like also,

I’ll test if it works on Ubuntu also as they said they thought it was an upstream problem maybe is the same kind of solution for all!!!