Which Newer Kernel Version to Use?

Last outputs requested by @Sauerland:

#  |  Alias                        | Name                                                                                          | Enabled    | GPG  Check        | Refresh   | Priority   | Type   | URI
     | Service 
---+-----------------------------+---------------------------------------------------------------------------------------------+------------+-----------------+-----------+------------+--------+------------------------------------------------------------------------------a
-----+-------- 
 1 | NVIDIA                      | NVIDIA                                                                                        | Sim        | (r   ) Sim        | Sim       |   99       | rpm-md |  https://download.nvidia.com/opensuse/leap/15.3                                     |  
 2 | cuda-opensuse15-x86_64      | cuda-opensuse15-x86_64                                                                        | Sim        | (r   ) Sim        | Não       |   99       | rpm-md |   https://developer.download.nvidia.com/compute/cuda/repos/opensuse15/x86_64         |  
 3 | oneAPI                      | oneAPI                                                                                        | Sim        | (r   ) Sim        | Não       |   99       | rpm-md |   https://yum.repos.intel.com/oneapi                                                 |  
 4 | openSUSE-Leap-15.2-1        | openSUSE-Leap-15.2-1                                                                        | Não        | ----            | ----      |   99       | rpm-md | hd:/?device=/dev/disk/by-id/usb-SanDisk_Cruzer_Fit_4C530001170306103540-0:0-part2 |  
 5 | repo-backports-debug-update | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/update/leap/15.3/backports_debug/                   |  
 6 | repo-backports-update       | Update repository of openSUSE   Backports                                                     | Sim          | (r ) Sim        | Sim       |   99       | rpm-md |   http://download.opensuse.org/update/leap/15.3/backports/                           |  
 7 | repo-debug                  | Debug Repository                                                                            | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/oss/              |  
 8 | repo-debug-non-oss          | Debug Repository (Non-OSS)                                                                  | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/non-oss/          |  
 9 | repo-debug-update           | Update Repository (Debug)                                                                   | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/update/leap/15.3/oss/                         |  
10 | repo-debug-update-non-oss   | Update Repository (Debug, Non-OSS)                                                          | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/update/leap/15.3/non-oss/                     |  
11 | repo-non-oss                | Non-OSS Repository                                                                            | Sim        | (r   ) Sim        | Sim       |   99       | rpm-md |   http://download.opensuse.org/distribution/leap/15.3/repo/non-oss/                  |  
12 | repo-oss                    | Main Repository                                                                               | Sim        |  (r  ) Sim        | Sim       |   99       | rpm-md |   http://download.opensuse.org/distribution/leap/15.3/repo/oss/                      |  
13 | repo-sle-debug-update       | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/update/leap/15.3/sle/                         |  
14 | repo-sle-update             | Update repository with updates from   SUSE Linux Enterprise 15                                | Sim        |   (r ) Sim        | Sim       |   99       | rpm-md |   http://download.opensuse.org/update/leap/15.3/sle/                                 |  
15 | repo-source                 | Source Repository                                                                           | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/source/distribution/leap/15.3/repo/oss/             |  
16 | repo-source-non-oss         | Source Repository (Non-OSS)                                                                 | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/source/distribution/leap/15.3/repo/non-oss/         |  
17 | repo-update                 | Main Update Repository                                                                        | Sim        | (r   ) Sim        | Sim       |   99       | rpm-md |   http://download.opensuse.org/update/leap/15.3/oss/                                 |  
18 | repo-update-non-oss         | Update Repository (Non-Oss)                                                                   | Sim        |  (r  ) Sim        | Sim       |   99       | rpm-md |   http://download.opensuse.org/update/leap/15.3/non-oss/                             |

i | nvidia-gfxG05-kmp-default | pacote | 495.29.05_k4.12.14_lp150.12.82-0 | x86_64 | cuda-opensuse15-x86_64

Wrong package…
This nvidia packages are for openSUSE Leap 15.0…

As root:

zypper dup --allow-vendor-change --from NVIDIA
dracut -f

Now reboot and hope…

You should also remove this Repo, its for Leap 15.0:

 2 | cuda-opensuse15-x86_64      | cuda-opensuse15-x86_64                                                                        | Sim        | (r   ) Sim        | Não       |   99       | rpm-md |   https://developer.download.nvidia.com/compute/cuda/repos/opensuse15/x86_64         |  

Hi @Sauerland.

Thanks, but I’ll only risk it in person. I explain: those repositories are necessary to make CUDA work, and they are supposedly to work in all opensuse leap 15.* versions (it worked on 15.2 for example).

It might indicate that I’ll have to reinstall it all (just some backups are necessary in the home partition, which is separated) and even that it might not work properly with 15.3 at all, but I’ll take a shot making everything work at software level before taking it to the shop for the MB exchange/upgrade.

i | nvidia-gfxG05-kmp-default | pacote | 495.29.05_k4.12.14_lp150.12.82-0 | x86_64 | cuda-opensuse15-x86_64

That package is build against kernel 4.12 and not kernel 5.3 (or backported 5.9)…
You get also only packages for Leap 15.0 and Leap 15.1 in that Repo.

Hi @Sauerland.

Sorry for the long time to answer back.

Well, that might be an issue: maybe this incompatibility leads to issues with cuda, or not? And that is a problem, since I must have both cuda and a workable interface on those computers.

However, it is indeed funny: it actually works with 15.2, and for a long time without errors in more than one machine.

Anyway, I will probably give it a try next Thursday.

Should be able up to Leap 15.3 with Leap Kernel:
https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html
https://developer.nvidia.com/cuda-downloads?target_os=Linux&target_arch=x86_64&Distribution=OpenSUSE&target_version=15&target_type=rpm_local

Install gcc, make and kernel-devel…

I have big doubts about Gigabyte X570 UD and ASRock X570 Phantom Gaming 4.
Gigabyte X570 Gaming X is nearly the same as Gigabyte X570 UD.
ASUS TUF GAMING X570-PLUS is OK, ASUS TUF Gaming X570-Pro II is an updated version.
(Remove plastic cover near VRMs on ASUS TUF GAMING X570-PLUS).
ASUS PRIME X570-P is OK and costs much lesser.

https://www.reddit.com/r/Amd/comments/czjaja/hardware_unboxed_budget_x570_vrm_thermal/

Check top B550 motherboards - some of them are OK. Or even top B450/X470.
But they costs ~ as ASUS PRIME X570-P.