Which application is using the sound card?

I’m running Amarok 1.4 and I frequently need to restart the sound daemon. As far as I can tell; no applications are using it at the time, but alsa cycles through my playlist without playing anything (i.e. loads track, doesn’t play it, moves to the next track, so on and so forth).

I’m pretty sure this would have something to do with another process using the sndcard. I just don’t know which one so I can kill it and troubleshoot why it’s doing it.

Nope, that’s not the sound card. That’s a problem of restricted formats. This provides a lot of info on how to get this working:
Multimedia - openSUSE-Community

It’s not the format.

I’ve gone through the work around to get mp3 working. When I restart ALSA it plays the mp3’s. So, I know for certain I can play mp3s.

Alsa is just the sound system, that’s not going through your playlist, Xine usually is the engine used in Amarok to play the media files.
When you restart Alsa you’re restarting all audio applications, so the problem could very well be in Xine, i.e. in libxine as well.
Please post output of:

zypper lr

My guess is you have a mix of codec packages from Videolan and Packman. This can lead to results like described. I’ll be around for a while, so post the output and I’ll get back to you.

I don’t have my box with me atm…I’m at work and it’s at home. I can tell you that I do have both the Videolan Repo and the Packman repo. But, I disabled the Videolan repo after I pulled the libdvdcss package off; the only package I got from that repo from what I remember.

I’ll post the output later tonight…

That’s what I wanted to check. Start the software installer, select the repo view, select the packman repo, and click the “Switch packages …” line on the top right. Accept. This should (re)install all codec files. Also check if your Amarok is the Packman version:

rpm -qa | grep amarok
It should show “pm” in the packagename.

Says I’m on the PM packages. Should I still try to do the package switch?

psyber@bitslip:~> rpm -qa | grep amarok
psyber@bitslip:~> zypper lr
#  | Alias                               | Name                        | Enabled | Refresh
1  | Packman                             | Packman                     | Yes     | Yes
2  | VLC_repo                            | VLC repo                    | No      | No
3  | http-download.opensuse.org-8f0e9342 | Updates for openSUSE 11.2-0 | Yes     | Yes
4  | kde3_repo                           | kde3 repo                   | Yes     | Yes
5  | openSUSE 11.2-0                     | openSUSE 11.2-0             | No      | No
6  | packman_kde3                        | packman kde3                | Yes     | Yes
7  | repo-debug                          | openSUSE-11.2-Debug         | No      | Yes
8  | repo-non-oss                        | openSUSE-11.2-Non-Oss       | Yes     | Yes
9  | repo-oss                            | openSUSE-11.2-Oss           | Yes     | Yes
10 | repo-source                         | openSUSE-11.2-Source        | No      | Yes

bump bump bump

No, that should be alright. Please follow one of oldcpu’s HOWTO’s on sound matters. That should help you through.

BTW, running KDE4 4.4 as released today…condider changing to it, it’s incredible.

I’ve been away on business/vacation for the past 10 days and I am just going thru various threads to see if I can add anything …

To see what application is using the sound device, try this in a terminal:

 lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

There is guidance in this thread (start reading from post#8 onward, and then look at the many many examples in that thread):
sound stop working after updating on asus k50in - openSUSE Forums