where is the python3-32 executable?


I’m writing a phyton3/tkinter program that plays music while showing matching lyrics and guitar chords.

After a lot of research, I found the most generic (platform, codec, availability) music playing library with a python wrapper is libvlc.
Unfortunately vlc is 32bit only, so I’m also stuck with 32-bit python.

The program more or less works on 64bit windows with 32bit python. I’d like to package it up as a standard python package now and also make it run on linux.
On opensuse (leap, 13.1), I can see python3 32bit packages, but they do not contain a python binary. So, what are they good for? How should I use them? I always prefer doing things the distro way, but what is it in this case?
Once this is solved, how would I package the program (setup.py) so it explicitly asks for 32bit when installed? Currently, if I try to install it on 64bit, it just fails because it cannot find a vlc module.

(I’m new to python, but used to opensuse)

I haven’t thought about this, but I’d recommend…

  1. Run the following command against the package you just installed to inspect the package contents which should reveal the python binary as well as anything else you’d want to know
rpm -ql *packagename *


Thanks for the search link.

Unfortunately that gives me python 2 64bit
I also tried to search for python3-32bit and python3-base-32bit. That found matches. I installed them, but they also have no binary, only a bunch of files in /usr/lib/
The corresponding 64bit package has the binary /usr/bin/python3, so I guess this is a packaging error?

Nope, openSUSE Leap is 64bit only, the 32bit packages are just libs for compatibility.

I wonder though whether it’s still OK to install 32-bit libraries (and user mode 32-bit executable) on a 64-bit system.
There’s no reason I can think of that prevents this from working.

Even the link I gave at software.opensuse.org has a link to 32-bit python for LEAP.

Someone (or I) might have to take a closer look at what those 32-bit python packages contain.
Ideally, when those 32-bit packages are installed they would also include a virtualenv solution to easily support switching to a specified python for a specified python app.

Early results are that the 32-bit package links are broken for all distros…
So, maybe the entire 32-bit Python build has been deprecated and removed.
Looking around…


From what I can see,
It looks like the OBS project for Python was disabled 6 mths ago, so for whatever reason Python is currently frozen at that point (including TW).

So, since it appears that 32-bit Python was removed from the official repos, the only alternative I can think of is to use something like rpmfind or pbone to find an old package from some other repository.

At this point,
I’d ask the User if there is a real need to package 32-bit or if 64-bit is the path of least resistance.