Where is the PCM volume?

Hi I am having trouble with sound on my box.
soundcard: audigy SE
openSUSE 11.2

I know where the PCM is supposed to be in YaST, but…

Is it actually marked as PCM because my only options are:
Master currently 100%
Center/LFE also 100%

In addition there are separate volumes for the individual channels in the volume area all set at 100%

I have sound when playing .mp3 in amarok and I have sound in DVD with Kaffeine. but no sound in VLC for DVDs or .mp3.
I also have no sound in web browsers for watching flash video.

I have configured the desktop sound settings so that they work but I feel that I am missing something here
Any help is appreciated.

Sorry to be so much trouble; I am a newb to Linux but I really want to learn it.

I also just noticed that if I crank the volume up all the way on my speakers I can just barely hear the sound coming through. I know this is some stupid volume issue I just cannot figure out what I am missing here.

PCM is under yast–> sound–> click the other button–> pick volume and slide PCM is right under Master.

That’s where I thought it should be but I do not see PCM there, only master(the big long one at the top) and Center/LFE is right below it.

In fact I do not see any mention of PCM anywhere. I also cannot play test sounds from the YaST sound configure utility. But I can from the configure desktop utility.

hmm thats odd, is your sound card onboard or pci? Did you run lspci as root to see if your card is listed and what driver it is using?

have you already tried to configure your card. I checked ALSA wiki site and it shows that your card is support so i’m not really sure what is going on. But I’m also about a day past noob.

Where is the configure app for the card located? Maybe this is the problem.

the configure app is on the other menu where you can access master and PCM

to answer your earlier question the card is PCI,
I just ran the alsamixer and adjusted all volumes, still no effect.

I also tried the lspci and it listed my soundcard as the media audio controller.

I’m stumped now:( can you copy and past your results of lspci

To get any sound at all I had to use the configure desktop app and enable show advanced devices, then I had to select either channel #1 or soundblaster rear speakers to get sound; the pulse audio also produces sound but it is unstable for use and crashes everytime I log into the machine.

i just looked over your original post again. It almost seems more codec related than hardware except for the missing PCM in your sound manager.If you look into your system log under yast do you see anything that maybe pointing to your sound card, errors, panics, anything?

When you say "configured the desktop sound settings so that they work " I am confused. Does that mean when you configure the desktop sound settings everything works now ?

Note for sound in web browsers to work one typically needs to ensure the same sound device selected under YaST > Hardware > Sound is selected under KMenu > Configure Desktop > Multimedia … and note that later function is buggy in cutting edge KDE versions and also in early version KDE versions. My experience is one is best with KDE-4.3.4 or KDE-4.3.5 to have a stable implementation of that functionality.

Originally I had no sound whatsoever; to fix this I used the Configure Desktop>multimedia>Device Preference function. Still I have no sound from either web or VLC applications. I am using whatever version of KDE that comes on the 11.2 live cd.

I have the sound blaster audigy set as the primary card in both the YaST sound configuration utility and the desktop settings configuration utility.

One thing to note is that I cannot play a test sound from the YaST sound configuration utility but I can from the desktop settings multimedia configuration utility.

I am an idiot; I had the speakers plugged into the wrong jack on the soundcard!

all problems are now fixed.


… I confess I’ve done that before also. rotfl!

brihno wrote:
> I am an idiot;

i love it when people have the courage and self confidence needed to
admit such a (often made) mistake…

brihno, i am certain you are not idiot!


Thanks for being so nice to me guys :slight_smile:

The interesting thing is that it seems only the applications which took there sound settings from KDE itself were able to play sound.

I have been having some trouble with sound between Windows 7 and Linux it; I am thinking that the OS was setting a switch in the bios of the soundcard which was causing problems. Hopefully getting the plug into the right jack will have fixed this issue as well.

Glad to see that you finally got things up and going;) It’s not your fault that pc manufactures insist on making the jack colors so similar. I have a 5.1 onboard card on my PC and I swear there are 3 green jacksrotfl!

Part of the problem is the way they have the Audigy SE marked is confusing; yes they use the green jack, but it has digital out stamped next to it.

I have removed the soundcard and replaced it with my old Audigy 2 platinum due to sound compatibility issues between Windows7 and Linux. Something about the way they designed the Audigy SE will not allow sound output in both OSes at once.

Thanks for all your help everyone.