Where is phpmyadmin

I’ve just had a heck of a time trying to find and install phpmyadmin on 11.3

Supposedly its already included in OpenSUSE… well, I made a custom build using SUSE studio, phpmyadmin was not a package that could be picked there. OK, fine, I’ll install it from the repos once I get it installed… Install it, get apache2 and mysql started, go to install phpmyadmin, its not in the default repos.

So where is it??? I ended up trying a 1-click installer for it here: http://software.opensuse.org/search?q=phpmyadmin
but I must be stupid… one click did not run an installer, it gave me a download for phpmyadmin.ymp Okay, so maybe this file is the installer. Well, trying to open it from Firefox’s download screen prompts you for something to open it with and provides no options. Hmmm… I navigate to the file in Dolphin and click to open it and I get a text file… okay, wtf am I supposed to do with this? Well, in the text is a reference to a repo: http://download.opensuse.org/repositories/server:/php:/applications/openSUSE_11.3/]Index of /repositories/server:/php:/applications/openSUSE_11.3
If you add the above URL to your repos and search for phpmyadmin, it comes right up. I’m not finished testing and configuring, but it made a directory in my htdocs, inconveniently named phpMyAdmin so you have to play with caps in the URL (stupid)
Right now its not accepting any username I throw at it but I’ll figure that out shortly.
I’m no linux pro but I’ve been toying with it for years and I’m far from stupid. This was just plain retarded to get installed and really ought to be fixed. Easiest fix options:
1- Add phpmyadmin to the default repos
2- Add a decent repo (with phpmyadmin in it) to the default repos

Grrr… stupid link parsing. The repo URL is:

Index of /repositories/server:/php:/applications/openSUSE_11.3

If it parses it again, just open it in a browser and copy the url from there

Edit: It parsed it again… just save the link or open it in a browser and copy it there…

With the one-click installs select ‘open with’ and select the YaST
Installer, if it selects download in the future, just toggle the

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1 day 18:10, 2 users, load average: 0.01, 0.02, 0.00
GPU GeForce 8600 GTS Silent - Driver Version: 256.35

phpmyadmin was moved out of the core repo a couple of releases back and I suspect is unlikely to be added back in, like lots of other things regarded as non-core.

One-click install does work if you have the standard openSUSE Firefox which knows what to do with .ymp downloads. Maybe you installed a different Firefox?

If not, adding the repo URL in YaST will work, afterwards you will be able to search for it under Software.

I appreciate the advice but I’m having all sorts of issues with this installation… I may just download the latest release but I’d been hoping to avoid having to download the 4.7GB iso (and have to copy it around my LAN)
Okay, so I got phpmyadmin installed. It should work fine but I’m getting this message: “The additional features for working with linked tables have been deactivated. To find out why click here.” I followed, and read, and googled, and its pissing me off. Seems it didn’t install a phpmyadmin database, fine, I can create it. Grrr again. There is supposed to be a sql file: “…/htdocs/phpMyAdmin/scripts/create_tables.sql” BUT its not there… I actually don’t even have the scripts subfolder at all. I’ve just reinstalled (through Yast) phpmyadmin and just about everything related, still no scripts folder. Man this install is pissing me off.
sigh in ref to your firefox Q: I chose the firefox package (believe it said opensuse branded or something like that) when I was using suse studio. I can try reinstalling it through yast but I’m really surprised at how badly packages from suse studio do not seem to work. I understand that each package would probably need a specific config depending on what other packages are installed, and maybe thats enough hassle to just not have anything at all pre-configured. I can understand that. But what I don’t understand is why everything is becoming such a pain in the rear to get working properly. If I install it from Yast it ought to do the job properly like it does in the regular distro.
Your other comment: I understand that phpmyadmin is certainly not a core app. BUT it is very important to php/mysql setups. Yes, I can edit DBs from command line, but thats just not the easiest way to do it, especially when you’re working on a remote server.

I’d have loved to, but it wasn’t an option. I don’t even know where to find it… i checked in /sbin and /bin, no luck. I did find several variations of Yast2 in /sbin and I tried on of those, no luck though. Any idea where I can find Yast Installer when Firefox asks for it?

btw ken_yap, I reinstalled Firefox with opensuse branding, no luck, it doesn’t know what to do with ymp files.

I understand your need for phpMyAdmin, I use it heavily too. I haven’t used the linked tables feature. Sounds like the packager didn’t include it. You should file a bug report and perhaps it will get fixed.

Oh, and why is phpPgadmin easily found and available but not phpmyadmin. The former is no more “core” of an app than the latter. Just **** off us mysql users…