Where/how to get nVidia driver?

Intel Pentium III (Coppermine); processors: 0 and 1; cpu MHz: 996.908; cache: 256 KB;** clflush: 32; RAM 512; Graphics Card: Nvidia RIVA TNT2/TNT2 Pro; nv driver;* (/dev/sda)OpenSUSE 11.2, (KDE desktop); Ffx 3.5.4, Konqueror;* (/dev/sdb) PCLINUXOS 2009 (KDE, GNOME, XFCE desktops); Ffx 3.5.3; Konqueror 3.5.4. nVidia driver version: 71.86.06

ftp://download.nvidia.com/opensuse/11.2 doesn’t have ver. 71.86.07 listed. Where do I get it – preferably with yast install?

Any directions would be much appreciated.

If it’s not there you will need to do it manually.
It’s easy.

Try going here!?

It the newest version of the 71.86.xx!

Please see my post of October 15, 2009: “How to install NVIDIA- Linux
x86-71.86.11.pkg1.run?” It’s deja vu, except this time, “startx” does get me back to a screen (howbeit without a restart option). TAB still don’t work.

Let me just say that I’m pleased as punch with 11.2 (I still want the proprietary driver, though).:wink:

By the way, I added fttp://download.nvidia.com/opensuse/11.2 to yast repositories, but NVIDIA- Linux
x86-71.86.11 didn’t become an installation option – everything except the one I want!

I don’t follow your comments, too cryptic.
Are you unable to install the driver
Are you saying TAB auto complete doesn’t work?

Yes, I’m saying that the tab autocomplete doesn’t work on my computer. And I’m unable to to install the proprietary driver.

But why can’t you install? Any details?

Alright so here is how to install the nvidia driver manually, in case the one in the repo doesn’t work or u just want to use the latest.

Go to Yast>Software>Software Management

Search for and install if you don’t have these:


Now download the latest Nvidia driver:

Place the file in your /home/username

Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3

At the login
Login with your username and password

Now switch to super user with su
and root password

*Now remember you can use the {TAB} key to auto complete:X
so type:
and the whole file name should auto complete

eg: sh NVIDIA-Linux-x86-185.18.36-pkg1.run

Follow the installer and let it compile the kernel module for you.
Say Yes to everything
Use TAB to move around

So far, all the computers I’ve had are old ones recycled by FreeGeek Columbus. Often, what’s inside the cpu’s are a potpourri of random parts. Don’t get me wrong, I appreciate what FreeGeek’s done for me and I’m always welcome there.

Nevertheless, maybe that explains why, for example, my computer doesn’t do TAB auto complete. Regarding your often given instructions on how I can install the nVidia driver, it don’t work for my computer. My efforts yesterday and today are the same as my post on 16 October 2009, @ 17.22:

“cd /home/randall/documents sh nvidia-Linux-x86-71.01-pkg1.run” elicits “-bash: cd/home/randall/documents: No such file or directory.”

"Anything I type that includes “cd” or “nvidia-Linux-x86-71.01-pkg1.run” gets “No such file or directly.”

“By playing with it, I can get the command line to concede /home/randall ‘is a directory’ if I push tab following that, tab will add a ‘/’ making it ‘/home/randall/’ So far as far as I’ve gotten without command line saying ‘No such file or directory’ is ‘/home/randall/downloads’ to which commandline says ‘/home/randall/downloads is a directory.’”

Maybe I can try downloading and installing the Video Installation Tool that PSLINUXOS 2009 uses. It gets and installs the 71xx driver with no problem. It’s just that I’d rather be here, on 11.2. Or how about me going to software manager and installing the version 96 driver – would it work, or break something, or what?

As always, thank you very much for all your help and direction. It’s not in vain.:stuck_out_tongue:

If the driver is placed in your home dir
eg: /home/randall

when you login at CLI there is no cd to a /dir necessary
just switch to su
and even if you have to type the whole package name manually it’s just

sh nvidia-Linux-x86-71.01-pkg1.run

If that doesn’t work then I’ll be darn’d

caf I think you should add kernel-syms. It look like it a most have for 11.2 now. And have a look at this:

NVIDIA/The hard way - openSUSE

You could be correct. It use to be the case anyway.

Good morning, all,

I went to “NVIDIA/The hard way - openSUSE,” and I followed the instructions; when I got to “Installation,” here’s what I got:

randall@linux-cms6:~> su
linux-cms6:/home/randall # cd /usr/share/doc/nvidia
bash: cd: /usr/share/doc/nvidia: No such file or directory
linux-cms6:/home/randall # sh NVIDIA-Linux-x86-71.86.11pkg1.run -q
sh: NVIDIA-Linux-x86-71.86.11pkg1.run: No such file or directory
linux-cms6:/home/randall #

Now here’s my new question: where the prompt turns into “linux-cms6:/home/randall #,” is that part of “cd /usr/share/doc/nvidia”(?). Is “/usr/share” a pattern for “/home/randall”(?). Every time I download the driver, it automatically gets saved in “downloads” and I’ve never gotten the option to save it anywhere else. So is “/usr/share/doc/nvidia” like a template for, say, “/home/randall/downloads/driver(?)” Or is the “/home/randall” part now included in the prompt?

Please assume that I know nothing and tell me verbatim what to copy and paste into the konsole.

I apologize for being so obtuse, but I’m doing the best I can.

As always, thank you very much.


Can’t you actually boot in to the system and put the file where you want it?

Use a live cd to do it - Maybe?

I have to go out for a few hours.
This is really not that difficult :):slight_smile: No offence.

If your going to use su ensure you use su - the minus character will
setup root’s environment.

Your not using a capital “D” with the cd command unix is case sensitive!

So it’s one or the other of these commands;

cd /home/randall/Download
sh NVIDIA-Linux-x86-71.86.11pkg1.run -q


sh /home/randall/Download/NVIDIA-Linux-x86-71.86.11pkg1.run -q

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 3 days 11:28, 2 users, load average: 0.16, 0.09, 0.07
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

randall@linux-cms6:~> su-
bash: su-: command not found
randall@linux-cms6:~> su -
linux-cms6:~ # cd /home/randall/Download
-bash: cd: /home/randall/Download: No such file or directory
linux-cms6:~ # sh NVIDIA-Linux-x86-71.86.11pkg1.run -q
sh: NVIDIA-Linux-x86-71.86.11pkg1.run: No such file or directory
linux-cms6:~ #
linux-cms6:~ # sh /home/randall/Download/NVIDIA-Linux-x86-71.86.11pkg1.run -q
sh: /home/randall/Download/NVIDIA-Linux-x86-71.86.11pkg1.run: No such file or directory
linux-cms6:~ #

You need to confirm where the file has been downloaded to and change
(cd) to that directory.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 23:33, 3 users, load average: 0.20, 0.11, 0.09
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

See above in Red. Notice where you are when you start:
You then type: cd /home/randall/
NOT necessary - You are already at /home/randall
(doesn’t really matter, but it’s bugging me)

At the start, please type as shown in the strange blue: randall@linux-cms6:~>ls

post result

randall@linux-cms6:~> ls
bin dwhelper
cache firefox
computer information.odt Kubuntu desktop - edited.odt
Desktop NVIDIA-Linux-x86-71.01-pkg1.run
Documents NVIDIA.odt
Documents.odt public_html
Downloads url for novell registration.odt
randall@linux-cms6:~> randall@Linux-cms6:~> ls
bash: randall@Linux-cms6:~: command not found

I checked Dolphin and it looks to me like I have the driver in both home and in home/randall, and in home/randall/downloads.

So in the output there it tells me there is no directory in /home/randall
called Download

You have been typing: cd /home/randall/Download
and you get: No such file or directory
Which is correct. Download does not exist.

Open Firefox and go to Edit - Preferences
And edit as shown and save

Now download your driver and follow my earlier instructions