Where do I belong now?

Since the old [install-configure-administration] NG have expired - where
should I post now?

I have an issue with Suse 11.0 RC1 - when I enable Compiz, the window
titlebar disappears. And while the cube appears and functions O.K. it is
gone after I re-boot.

This is a HP Notebook (zv5000) and the nVidia drivers installed with an
auto-update, and all of that seems to work just fine!

Tony. . .

Is this on Gnome, KDE3, or KDE4?

I think I’m having a similar issue in 11.0. I’m on a thinkpad t61p with a quadro 570m, 11.0 and gnome w/ all the updates. I have the drivers from the repo installed. When I try to turn on desktop effects, it looks like it just falls back to software rendering (artifacts everywhere, very slow, high cpu usage). I’m not sure why this is happening.

Actually this is a completely different issue, but please post your /var/log/Xorg.0.log, and /etc/X11/xorg.conf in [noparse]


[/noparse] tags

The first log was too big to paste so i uploaded it to: http://josecuervo.shackspace.com/Xorg.0.log

xorg.conf is below.
[noparse]


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Mon May 19 00:33:37 PDT 2008

# /.../
# SaX generated X11 config file
# Created on: 2008-06-13T17:02:18-0400.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
    Identifier     "Layout[all]"
    Screen         "Screen[0]" 0 0
    InputDevice    "Keyboard[0]" "CoreKeyboard"
    InputDevice    "Mouse[1]" "CorePointer"
    InputDevice    "Mouse[3]" "SendCoreEvents"
    Option         "Clone" "off"
    Option         "Xinerama" "off"
    Option	   "aiglx" "true"
EndSection

Section "Files"
    InputDevices      "/dev/gpmdata"
    InputDevices      "/dev/input/mice"
    FontPath        "/usr/share/fonts/misc:unscaled"
    FontPath        "/usr/share/fonts/local"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/Type1"
    FontPath        "/usr/share/fonts/URW"
    FontPath        "/usr/share/fonts/Speedo"
    FontPath        "/usr/share/fonts/PEX"
    FontPath        "/usr/share/fonts/cyrillic"
    FontPath        "/usr/share/fonts/latin2/misc:unscaled"
    FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/Type1"
    FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath        "/usr/share/fonts/baekmuk:unscaled"
    FontPath        "/usr/share/fonts/japanese:unscaled"
    FontPath        "/usr/share/fonts/kwintv"
    FontPath        "/usr/share/fonts/truetype"
    FontPath        "/usr/share/fonts/uni:unscaled"
    FontPath        "/usr/share/fonts/CID"
    FontPath        "/usr/share/fonts/ucs/misc:unscaled"
    FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/misc:unscaled"
    FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/Type1"
    FontPath        "/usr/share/fonts/misc/sgi:unscaled"
    FontPath        "/usr/share/fonts/xtest"
    FontPath        "/opt/kde3/share/fonts"
EndSection

Section "Module"
    Load           "dbe"
    Load           "type1"
    Load           "freetype"
    Load           "extmod"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "AllowMouseOpenFail" "on"
    Option         "ZapWarning" "on"
EndSection

Section "InputDevice"
    Identifier     "Keyboard[0]"
    Driver         "kbd"
    Option         "Protocol" "Standard"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "microsoftpro"
    Option         "XkbRules" "xfree86"
EndSection

Section "InputDevice"
    Identifier     "Mouse[1]"
    Driver         "synaptics"
    Option         "Buttons" "5"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "on"
    Option         "HorizScrollDelta" "0"
    Option         "InputFashion" "Mouse"
    Option         "Name" "Synaptics;Touchpad"
    Option         "Protocol" "explorerps/2"
    Option         "SHMConfig" "on"
    Option         "Vendor" "Sysp"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier     "Mouse[3]"
    Driver         "mouse"
    Option         "Buttons" "5"
    Option         "Device" "/dev/input/mice"
    Option         "EmulateWheel" "on"
    Option         "EmulateWheelButton" "2"
    Option         "InputFashion" "Mouse"
    Option         "Name" "IBM;TPPS/2 TrackPoint"
    Option         "Protocol" "explorerps/2"
    Option         "Vendor" "Sysp"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Modes"
    Identifier         "Modes[0]"
EndSection

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "--> LCD"
    ModelName      "1920X1200@60HZ"
    UseModes       "Modes[0]"
    DisplaySize     332    207
    HorizSync       30.0 - 85.0
    VertRefresh     50.0 - 60.0
    Option         "CalcAlgorithm" "XServerPool"
    Option         "DPMS"
    Option         "PreferredMode" "1024x768"
EndSection

Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "NVidia"
    BoardName      "Quadro FX 570M"
EndSection

Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Depth       15
        Modes      "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       32
        Modes      "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection

[/noparse]

Just realized I accidentally put noparse tags around the code tags…oops.

Well, nothings wrong with your config, aiglx should be disabled but it shouldn’t affect anything

Post the output of ‘compiz --replace --loose-binding --ignore-desktop-hints --sm-disable ccp’

That basically broke the window manager, I couldn’t type anything - had to restart the x-server.

Oh, all it said was “Starting gtk-window-decorator”

I had same problem on 10.3. After your nVidia driver is installed you shold do the following three comands (as su):


nvidia-xconfig --composite
nvidia-xconfig --render-accel
nvidia-xconfig --add-argb-glx-visuals -d 24

Good luck!

They already did that
What’s the output of ‘glxinfo | grep -i direct’

direct rendering: Yes

I was able to fix all the problems I was having by uninstalling the driver packages using yast, and manually installing the 173.14.09 drivers that just went up on the nvidia site.