Where are the power management controls in 11.4 KDE?

I finally figured out to install laptop-mode package. However, I need to find the gui controls to set CPU scaling, CPU fan, & wireless power

I’m using Opensuse 11.4 KDE x64 fresh install on an X61 tablet. I can see where you can poke files in the /sys/devices/system directory to sort of control things, but, I suspect this might break things if more than one flag needs to be set. Yast contains no power options. The documentation I can find is either old or wrong or both. So, I’d love to know what people currently recommend.

I’m reluctant to invoke pm-powermode because of no visible documentation.

Also, where do I set policy for what the laptop power button does. This may be a configuration problem where the power button isn’t connected to anything, but, I can’t seem to find the usual policy questions on what to do when the power button is pressed. Any idea where those controls are?

CPU Speed control exists now in YaST. Why not do the following, open:

YaST / Software / Software Management, search on Power and install yast2-power-management. Once done, restart YaST.


YaST / System / System Services (Runlevel), select Expert Mode Bullet at the top left:


Find and highlight pm-profiler and then select the button on the bottom right and Enable the pm-profile Service and answer yes to the added services requested.


Select the button on the bottom left and Start the pm-profiler Servrce. You should get a good start with a 0 error return code.

Now select the finish button on the bottom right and allow your selections to be saved.


YaST / System / Power Management. You can select from three choices with Power Saving doing what I think you are looking for.

This is just one thing you can do, but not all you were looking for.

Thank You,

I’ll tell you why I didn’t do it, because it’s not that obvious. Anyway, that gets the CPU frequency to scale downward. Do you know what else it controls. Some people are undervolting these core2 duo machines to reduce heating. I’d love to do that but don’t think that this power control does that.

Do you know anywhere I can ask about controlling radio power. I can see some of the configuration files but don’t want to go playing.

> Also, where do I set policy for what the laptop power button does.

have a look at Personal Settings - Configure Desktop > Hardware > Power
Management, there you will find all you ask for (i think…including a
“Help” button)

except, i know nothing about adjusting the wi-fi power or how/where to

however, there is plenty of documentation at doc.opensuse.org, and you
are allowed to google’s site specific search to find stuff…like, put
this in a google search box:

site:doc.opensuse.org wireless power

dd CAVEAT: http://is.gd/bpoMD
[NNTP via openSUSE 11.4 [] + KDE 4.6.0 + Thunderbird 3.1.10]
Dual booting with Sluggish Loser7 on Acer Aspire One D255

Thanks for the help. Installing the power management solved most of the problem. However, the wireless driver is buggy, needs to be recompiled for wireless power management and apparently so does the kernel (or maybe not; hard to decide). I’m going to head on over to see if I can get some advice on how the opensuse kernel thinks it’s supposed to handle wireless power management.

The wireless power management is handled by iwconfig. Make sure it’s installed and read the man page.

I’m using this on an X61 tablet (X61t) model 7764CTO with the Intel Centrino 4965 wifi mini pci-e card. This card is responsible for the hot handrest syndrome of all this series of laptop. However, its power management is turned off because there were some problems, so, the developers just killed it. Here’s how to re-enable.

Download the latest kernel for Opensuse 11.4. The kernel that ships with it (vmlinuz- doesn’t have acpi_power enabled. I’m currently using vmlinuz-, which is what came down with the kernel-sources package.

Download compat-wireless-2.6.37-4-sn from http://www.orbit-lab.org/kernel/compat-wireless-2.6-stable/v2.6.37/compat-wireless-2.6.37-4-sn.tar.bz2
You need to untar it and edit the file …/drivers/net/wireless/iwlwifi/iwl-4965.c
Search for line “.broken_powersave = true” and just change it to ‘false’
Make sure you have the gcc and a build environment installed (make at very least) (I have no idea how many tools they used; I installed everything I could find that looked like a development tool)

Now run: (from the root directory of the wireless package)
./scripts/driver-select iwlagn
sudo make install
then reboot

Activate the powersave using the command
iwconfig wlan0 power on (works for any card that supports power management)
iwconfig wlan0 power timeout 200u (sets it to timeout & go to sleep after 200 us)
None of the other power saving options are supported by this card.

The hot handrest is still warm, but, much better. And that’s a major reason to switch to linux from windows where the hot handrest makes this machine a problem.

I’ll be adding further comments about how well the machine survives suspend & hibernate, etc.

The fixed 4965 driver survives sleep and hibernate fine.

On 05/29/2011 10:06 PM, X61 usr wrote:
> The fixed 4965 driver survives sleep and hibernate fine.

good on ya’!

dd CAVEAT: http://is.gd/bpoMD
[NNTP via openSUSE 11.4 [] + KDE 4.6.0 + Thunderbird 3.1.10]
Dual booting with Sluggish Loser7 on Acer Aspire One D255