Where are one-click installs gone?

I’m trying to get Opensuse 13.2 working on a Lenovo T61 laptop. I’ve always used the one-click sound installs and everything has worked . Now amarok is not working, and I can’t find the 13.2 one-click install. I’ve followed the directions to use packman and libdvdcss2 and install the programs mentioned there, but amarok still doesn’t work. Where has the 13.2 one c;lick install gone?

Thnaks, Bob


I followed all the directions in the link you gave me, but now when I start amarok, it doesn’t run but gives this fault:

Executable: amarok PID: 13329 Signal: Segmentation fault (11) Time: 02/06/16 09:02:49 AM

In addition, the link meant to refer to troubleshooting does not work and there are no one-click installs.

Thanks, Bob

Do a full switch to the Packman repo as described here:

If that doesn’t help or you need further help with that, please post your repo list:

zypper lr -d

That is also described in caf4926 Blog:

When done. Close the terminal. And open Yast > Software Management and Apply the Package Switcher on Packman.

KDE: Example of Packman switch in KDE

Gnome: Example of Packman switch in Gnome

If you encounter dependency errors: Eg: Errors You need to accept changes that allow vendor switch to Packman If you can’t work it out. Ask in the forum.

I had already applied the package switcher on packman.

Here is the repo list:

linux-fen0:/home/rsmits # zypper lr -d
#  | Alias                        | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                   | Service
 1 | download.nvidia.com-opensuse | nVidia Graphics Drivers            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/13.2/                             |        
 2 | libdvdcss                    | libdvdcss                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                                  |        
 3 | openSUSE-13.2-0              | openSUSE-13.2-0                    | Yes     | ( p) Yes  | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-MATSHITADVD-RAM_UJ-862_HE25_186752 |        
 4 | packman                      | packman                            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_13.2/                           |        
 5 | repo-debug                   | openSUSE-13.2-Debug                | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/        |        
 6 | repo-debug-update            | openSUSE-13.2-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2/                       |        
 7 | repo-debug-update-non-oss    | openSUSE-13.2-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/               |        
 8 | repo-non-oss                 | openSUSE-13.2-Non-Oss              | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/          |        
 9 | repo-oss                     | openSUSE-13.2-Oss                  | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/              |        
10 | repo-source                  | openSUSE-13.2-Source               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.2/repo/oss/       |        
11 | repo-update                  | openSUSE-13.2-Update               | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                             |        
12 | repo-update-non-oss          | openSUSE-13.2-Update-Non-Oss       | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/                     |        
linux-fen0:/home/rsmits # 


Then do it again.

sudo zypper dup --from 4

New packages might not necessarily be installed from Packman.

OTOH, I notice the nvidia repo in your repo list.
Did you install the driver and is it fully working?
If not, this could cause applications crashing…

Please install Mesa-demo-x (if not installed already) and post the output of:

glxinfo | grep render

(run as user)

Also. check if phonon-backend-vlc is installed and remove it if it is.
The version shipped in 13.2 doesn’t work with the latest VLC from Packman, and causes applications to crash when e.g. trying to play a sound.
You have to use the gstreamer backend.

I have backed up a stage. I was afraid I might have screwed something up with tweaking.

I have completely redone the base 13.2 install on the laptop. Formatted / and home partitions, and done the online YAST update. Nothing Else.

Where should I go next to make amarok and multimedia work?

Add the Packman repo (in YaST->Software Repositories click on “Add” and select “Community Repositories”, you should find it in the list), then do a full switch to it.

Then install gstreamer-plugins-libav, gstreamer-plugins-bad-orig-addon, gstreamer-plugins-ugly-orig-addon, and maybe vlc-codecs if you want to use VLC.

That should suffice for most people.

Ok so what I do is always first check if the program is in yast before I do the web (single click) search So I never see duplicates since the only programs I get via one click are one not found in the normal repos. and I don’t keep any of those repos active . I guess it could be that no check is done. Maybe something to ad to the wish list.:wink:

Didit. Worked a treat, and now Amarok is functioning again. Thanks

Wrong thread? :wink:

You’re welcome.

Just one additional note:
If you want to be able to play back “copy”-protected DVDs, you need to add the libdvdcss repo too (to be found in YaST’s “Community Repositories” list as well), and install libdvdcss2 after you added/enabled it.

Must have been :shame:

Would this work as well for Leap or is there another recommendation for that?

Should work the same.