When no dual screen, KDE issue

Hi all :slight_smile:

I’ve got OpenSUSE 11.4, kernel 3.0.4 (BTW, Is there an upgrade available ?), KDE 4.7.1 and Dual screen on my Laptop :slight_smile:

But when trying to use KDE without the second screen, I have to deal this… stupid issue : plasma’s wallpapers recovers the screen and the only thing to see is : mouse & wallpaper. The applications all run properly, but behind the wallpaper. So I have to kill plasma-desktop to interact with the windows…
Is there a way to set up profiles (using the same user) for display options ? even if I have to choose at boot, you know, kind of

  • OpenSUSE 11.4, kernel 3.0.4, dual screen
  • OpenSUSE 11.4, kernel 3.0.4, no dual screen

And I have one more question : how can I reduce heat from CPU ? KDE 4.6.5 didn’t make my CPU hotter than 55°C (131°F) and now, it’s around 62°C (144°F), take a look at :

[transistor@felucia:~]$ top
top - 18:44:26 up 27 min,  3 users,  load average: 0.12, 0.15, 0.53
Tasks: 212 total,   2 running, 210 sleeping,   0 stopped,   0 zombie
Cpu(s): 13.8%us,  5.2%sy,  0.5%ni, 72.2%id,  8.3%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   3914692k total,  3652784k used,   261908k free,   745236k buffers
Swap:  4088504k total,       64k used,  4088440k free,  1059688k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                 
 1855 root      20   0  732m 468m 246m R   14 12.2   6:29.06 Xorg                                                                    
 3136 transist  20   0  476m  47m  32m S    8  1.2   1:38.96 kwin                                                                    
 3426 transist  20   0 1390m 144m  59m S    8  3.8   1:59.69 amarok                                                                  
 3166 transist  20   0  869m 105m  33m S    4  2.8   1:07.59 plasma-desktop                                                          
 2962 transist  20   0 21964 2828  672 S    2  0.1   0:06.13 dbus-daemon                                                             
[transistor@felucia:~]$ sensors
Adapter: Virtual device
temp1:       +58.0°C  (crit = +105.0°C)                  

Adapter: ISA adapter
Core 0:      +57.0°C  (high = +80.0°C, crit = +90.0°C)  
Core 2:      +60.0°C  (high = +80.0°C, crit = +90.0°C) 

Of course, since I can, I do use QtCurve, Kwin effects & so on… :slight_smile: But still old KDE wasn’t that hot. (Don’t tell me to downgrade KDE : I won’t :P)

Best Regards,

So for your KDE issue, I can only say you might report a bug OR consider dropping back to KDE 4.6. Until openSUSE 12.1 comes out, I am suggesting we stick with KDE 4.6 for the very reason you have run into yet another problem. As for the other questions, I look at my CPU and its running around 34 degrees C and so a value close to 60 degrees C is getting high, though that is still under 160-180 degrees F which would be too high. What kind of cooling are you using and what is the surrounding space temp? I see my room is at 74 degrees F today and lower than it was this summer.

As to controlling the CPU speed and thus the heat build up, check out the following blogs:

  1. YaST Power Management - Control Your CPU Energy Usage How To & FAQ - Blogs - openSUSE Forums

  2. C.F.U. - CPU Frequency Utilitiy - Version 1.10 - For use with the cpufrequtils package - Blogs - openSUSE Forums

  3. GNU/Linux and openSUSE power management regressions - Blogs - openSUSE Forums

As about your kernel, kernel.org just came back online, but the most recent version shown is kernel 3.1-rc4 even as rc-8 is out. Check out these blogs on updating your kernel:

  1. SGTB - SuSE Git Kernel Tarball Creator - Version 1.30 - Blogs - openSUSE Forums

  2. S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.50 - Blogs - openSUSE Forums

Thank You,

You don’t seem to indicate what your video chip and driver are.

If you’re running nVidia, recommend you install the latest driver that zypper or YAST says is available, at least for nVidia this is as simple as making sure the nVidia repo is enabled and updating (Updater will do the rest).

Also, if this is an nVidia chip, when you install the latest driver you will also automatically install the nVidia admin tools as well.

If you’re managing screen configuration you should find that doing it with the nVidia tools instead of your hardware will be an improvement. You should also see an option to configure running profiles which can step down the usage of your GPU, therefor resulting in lower temperatures.

Despite the links that Jim posted, I doubt many of those would likely be relevant to GPU issues which IMO usually are separate from CPU kernel issues.


Ok, I have got an Intel Core i3 CPU, ATI radeon HD 5850 Graphic Card, fglrx driver from YaST.
My computer’s a laptop, temperature surrounding is 68°F (20°C), only cooling is fan, I think.

Dual screen works great. Single Screen too, when using OpenBox or LXDE (temperature ~ 45 °C , i.e. 113°F).

I don’t have much time right now, I’ll post more in the future :wink:

Best regards,

When my nVidia based laptop is set to the “Maximum Performance” GPU profile (no overclocking, but also no stepping down), the temp is 53 C and within normal range. You should also check what’s normal for your GPU.


If you are on Core 2 duo then ~55°C is normal. I guess the heat is not too much. If some proram were using a lot of CPU then the temperature would be ~75°C.

The wallpaper issue sounds pretty much like this KDE bug: https://bugs.kde.org/show_bug.cgi?id=260360

For me, the workaround suggested somewhere half down the comments made the problem disappear. So you could try setting all panels (especially those on the second screen which is not there) to a fixed size (i.e. minium and maximum sliders for the panel size in the same space). Apparently the panels of the second screen get stretched all over the first screen, if the second screen is not there.